summaryrefslogtreecommitdiffstats
path: root/abs/core/ntfs-3g
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/core/ntfs-3g
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/core/ntfs-3g')
-rw-r--r--abs/core/ntfs-3g/20-ntfs-config-write-policy.fdi13
-rw-r--r--abs/core/ntfs-3g/PKGBUILD31
-rw-r--r--abs/core/ntfs-3g/ntfs-3g.install15
3 files changed, 59 insertions, 0 deletions
diff --git a/abs/core/ntfs-3g/20-ntfs-config-write-policy.fdi b/abs/core/ntfs-3g/20-ntfs-config-write-policy.fdi
new file mode 100644
index 0000000..b0f5961
--- /dev/null
+++ b/abs/core/ntfs-3g/20-ntfs-config-write-policy.fdi
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<deviceinfo version="0.2">
+ <device>
+ <match key="volume.fstype" string="ntfs">
+ <merge key="volume.fstype" type="string">ntfs-3g</merge>
+ <merge key="volume.policy.mount_filesystem" type="string">ntfs-3g</merge>
+ <append key="volume.mount.valid_options" type="strlist">locale=</append>
+ <append key="volume.mount.valid_options" type="strlist">dmask=</append>
+ <append key="volume.mount.valid_options" type="strlist">fmask=</append>
+ </match>
+ </device>
+</deviceinfo>
+
diff --git a/abs/core/ntfs-3g/PKGBUILD b/abs/core/ntfs-3g/PKGBUILD
new file mode 100644
index 0000000..a8ae6e5
--- /dev/null
+++ b/abs/core/ntfs-3g/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id: PKGBUILD 35598 2009-04-14 08:38:34Z ronald $
+# Maintainer: Ronald van Haren <ronald.archlinux.org>
+# Contributor: Thomas Bächler <thomas.archlinux.org>
+
+pkgname=ntfs-3g
+pkgver=2009.4.4
+pkgrel=3
+pkgdesc="Stable read and write NTFS driver"
+url="http://www.ntfs-3g.org/"
+arch=('i686' 'x86_64')
+license=('GPL2')
+install=ntfs-3g.install
+depends=('glibc')
+makedepends=('pkgconfig')
+options=('!libtool')
+source=(http://www.ntfs-3g.org/${pkgname}-${pkgver}.tgz
+ 20-ntfs-config-write-policy.fdi)
+md5sums=('e0b5c170f088a8d82968f0a6b34d31da'
+ 'ece35a9108837e2008e5a47f3390755e')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ # use internal fuse at least until fuse 2.8.0 is relased, it contains
+ # some bug & security fixes
+ ac_cv_path_LDCONFIG=/bin/true ./configure --prefix=/usr \
+ --with-fuse=internal || return 1
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+ install -m755 -d "${pkgdir}/usr/share/hal/fdi/policy/10osvendor"
+ install -m644 "${srcdir}/20-ntfs-config-write-policy.fdi" "${pkgdir}/usr/share/hal/fdi/policy/10osvendor/" || return 1
+}
diff --git a/abs/core/ntfs-3g/ntfs-3g.install b/abs/core/ntfs-3g/ntfs-3g.install
new file mode 100644
index 0000000..ad8cc1b
--- /dev/null
+++ b/abs/core/ntfs-3g/ntfs-3g.install
@@ -0,0 +1,15 @@
+# arg 1: the new package version
+post_install() {
+ ln -s /sbin/mount.ntfs-3g /sbin/mount.ntfs
+}
+# arg 1: the new package version
+# arg 2: the old package version
+
+# arg 1: the old package version
+post_remove() {
+ rm -fr /sbin/mount.ntfs
+}
+
+op=$1
+shift
+$op $*