summaryrefslogtreecommitdiffstats
path: root/abs/core/nvidia-96xx
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-07-19 08:11:22 (GMT)
committerCecil <knoppmyth@gmail.com>2011-07-19 08:11:22 (GMT)
commit843da1c0f154f8f8fbe67e11ca3d30a5602325d6 (patch)
treeab4af0218646d19164bf4a479371ddc61f83cadf /abs/core/nvidia-96xx
parent149baf5d574c1fb906b637ab8807f34e8154dd3f (diff)
downloadlinhes_pkgbuild-843da1c0f154f8f8fbe67e11ca3d30a5602325d6.zip
linhes_pkgbuild-843da1c0f154f8f8fbe67e11ca3d30a5602325d6.tar.gz
linhes_pkgbuild-843da1c0f154f8f8fbe67e11ca3d30a5602325d6.tar.bz2
nvidia-96xx-utils:Bumped to latest.
Diffstat (limited to 'abs/core/nvidia-96xx')
-rw-r--r--abs/core/nvidia-96xx/PKGBUILD15
-rw-r--r--abs/core/nvidia-96xx/nvidia-legacy-2.6.39.patch10
-rw-r--r--abs/core/nvidia-96xx/nvidia.install4
3 files changed, 21 insertions, 8 deletions
diff --git a/abs/core/nvidia-96xx/PKGBUILD b/abs/core/nvidia-96xx/PKGBUILD
index 52a166a..2dafb94 100644
--- a/abs/core/nvidia-96xx/PKGBUILD
+++ b/abs/core/nvidia-96xx/PKGBUILD
@@ -3,20 +3,20 @@
pkgname=nvidia-96xx
pkgver=96.43.19
-_kernver='2.6.37-LinHES'
-pkgrel=5
+_kernver='2.6.39-LinHES'
+pkgrel=6
pkgdesc="NVIDIA drivers for kernel26, 96xx branch."
arch=('i686' 'x86_64')
[ "$CARCH" = "i686" ] && ARCH=x86
[ "$CARCH" = "x86_64" ] && ARCH=x86_64
url="http://www.nvidia.com/"
-depends=('kernel26>=2.6.37' 'kernel26<2.6.38' 'nvidia-96xx-utils')
-makedepends=('kernel26-headers>=2.6.37' 'kernel26-headers<2.6.38')
+depends=('kernel26>=2.6.39' 'kernel26<2.6.40' 'nvidia-96xx-utils')
+makedepends=('kernel26-headers>=2.6.39' 'kernel26-headers<2.6.40')
conflicts=('nvidia' 'nvidia-173xx')
license=('custom')
install=nvidia.install
-source=("http://download.nvidia.com/XFree86/Linux-$ARCH/${pkgver}/NVIDIA-Linux-$ARCH-${pkgver}-pkg0.run")
-md5sums=('53e98129d885a1b004aabc42a989fa73')
+source=("http://download.nvidia.com/XFree86/Linux-$ARCH/${pkgver}/NVIDIA-Linux-$ARCH-${pkgver}-pkg0.run"
+ nvidia-legacy-2.6.39.patch)
[ "$CARCH" = "x86_64" ] && md5sums=('7ff779e299b938b880baff6cd970ab51')
@@ -24,6 +24,7 @@ build() {
cd $srcdir
sh NVIDIA-Linux-$ARCH-${pkgver}-pkg0.run --extract-only
cd NVIDIA-Linux-$ARCH-${pkgver}-pkg0
+ patch -p0 < ${srcdir}/nvidia-legacy-2.6.39.patch
cd usr/src/nv/
ln -s Makefile.kbuild Makefile
make SYSSRC=/lib/modules/${_kernver}/build module
@@ -35,3 +36,5 @@ build() {
echo "blacklist nouveau" >> $pkgdir/etc/modprobe.d/nouveau_blacklist.conf
sed -i -e "s/KERNEL_VERSION='.*'/KERNEL_VERSION='${_kernver}'/" $startdir/nvidia.install
}
+md5sums=('53e98129d885a1b004aabc42a989fa73'
+ 'fc1ca585f5c5c3067b0fa283ee44b7c6')
diff --git a/abs/core/nvidia-96xx/nvidia-legacy-2.6.39.patch b/abs/core/nvidia-96xx/nvidia-legacy-2.6.39.patch
new file mode 100644
index 0000000..4ee8ba6
--- /dev/null
+++ b/abs/core/nvidia-96xx/nvidia-legacy-2.6.39.patch
@@ -0,0 +1,10 @@
+--- usr/src/nv/nv-linux.h.orig 2010-10-28 04:23:04.000000000 +0200
++++ usr/src/nv/nv-linux.h 2011-05-21 08:58:35.714633248 +0200
+@@ -80,7 +80,6 @@
+ #if !defined(KERNEL_2_4)
+ #include <linux/sched.h> /* suser(), capable() replacement */
+ #include <linux/moduleparam.h> /* module_param() */
+-#include <linux/smp_lock.h> /* kernel_locked */
+ #include <asm/tlbflush.h> /* flush_tlb(), flush_tlb_all() */
+ #include <asm/kmap_types.h> /* page table entry lookup */
+ #endif
diff --git a/abs/core/nvidia-96xx/nvidia.install b/abs/core/nvidia-96xx/nvidia.install
index f7ecde6..aea2fbb 100644
--- a/abs/core/nvidia-96xx/nvidia.install
+++ b/abs/core/nvidia-96xx/nvidia.install
@@ -1,5 +1,5 @@
post_install() {
- KERNEL_VERSION='2.6.37-LinHES'
+ KERNEL_VERSION='2.6.39-LinHES'
depmod $KERNEL_VERSION
}
@@ -9,6 +9,6 @@ post_upgrade() {
}
post_remove() {
- KERNEL_VERSION='2.6.37-LinHES'
+ KERNEL_VERSION='2.6.39-LinHES'
depmod $KERNEL_VERSION
}