summaryrefslogtreecommitdiffstats
path: root/abs/core/openssh/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-02-22 20:38:40 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-02-22 20:38:40 (GMT)
commit986b709cdfa90185cccd6446154deb0d1776c4b6 (patch)
tree5990f1d7024ada6bd0bd91e466a377535c0956c4 /abs/core/openssh/PKGBUILD
parentef4dcf39f7fa3d78ab5d8d6e05c2e7e636257731 (diff)
downloadlinhes_pkgbuild-986b709cdfa90185cccd6446154deb0d1776c4b6.zip
linhes_pkgbuild-986b709cdfa90185cccd6446154deb0d1776c4b6.tar.gz
linhes_pkgbuild-986b709cdfa90185cccd6446154deb0d1776c4b6.tar.bz2
openssh: update to 7.6p1
Diffstat (limited to 'abs/core/openssh/PKGBUILD')
-rw-r--r--abs/core/openssh/PKGBUILD46
1 files changed, 29 insertions, 17 deletions
diff --git a/abs/core/openssh/PKGBUILD b/abs/core/openssh/PKGBUILD
index 2fe40b3..b180b75 100644
--- a/abs/core/openssh/PKGBUILD
+++ b/abs/core/openssh/PKGBUILD
@@ -4,34 +4,43 @@
# Contributor: judd <jvinet@zeroflux.org>
pkgname=openssh
-pkgver=7.3p1
-pkgrel=1
+pkgver=7.6p1
+pkgrel=2
pkgdesc='Free version of the SSH connectivity tools'
-url='http://www.openssh.org/portable.html'
+url='https://www.openssh.com/portable.html'
license=('custom:BSD')
-arch=('i686' 'x86_64')
+arch=('x86_64')
makedepends=('linux-headers')
depends=('krb5' 'openssl' 'libedit' 'ldns')
optdepends=('xorg-xauth: X11 forwarding'
'x11-ssh-askpass: input passphrase in X')
validpgpkeys=('59C2118ED206D927E667EBE3D3E5F56B6D920D30')
-source=("http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/${pkgname}-${pkgver}.tar.gz"{,.asc}
+source=("https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/${pkgname}-${pkgver}.tar.gz"{,.asc}
+ 'openssl-1.1.0.patch'
'sshdgenkeys.service'
'sshd@.service'
'sshd.service'
'sshd.socket'
'sshd.conf'
'sshd.pam')
-sha1sums=('bfade84283fcba885e2084343ab19a08c7d123a5' 'SKIP'
- 'caaa801da59a5d14c0c29c43e9de5fef281ea03e'
- '6a0ff3305692cf83aca96e10f3bb51e1c26fccda'
- 'ec49c6beba923e201505f5669cea48cad29014db'
- 'e12fa910b26a5634e5a6ac39ce1399a132cf6796'
- 'c9b2e4ce259cd62ddb00364d3ee6f00a8bf2d05f'
- 'd93dca5ebda4610ff7647187f8928a3de28703f3')
+sha256sums=('a323caeeddfe145baaa0db16e98d784b1fbc7dd436a6bf1f479dfd5cd1d21723'
+ 'SKIP'
+ '1fcae9fc461026d96d08b38457e7ffe281b4319caaada1508f9eb74c2566ba5d'
+ '4031577db6416fcbaacf8a26a024ecd3939e5c10fe6a86ee3f0eea5093d533b7'
+ '3a0845737207f4eda221c9c9fb64e766ade9684562d8ba4f705f7ae6826886e5'
+ 'c5ed9fa629f8f8dbf3bae4edbad4441c36df535088553fe82695c52d7bde30aa'
+ 'de14363e9d4ed92848e524036d9e6b57b2d35cc77d377b7247c38111d2a3defd'
+ '4effac1186cc62617f44385415103021f72f674f8b8e26447fc1139c670090f6'
+ '64576021515c0a98b0aaf0a0ae02e0f5ebe8ee525b1e647ab68f369f81ecd846')
backup=('etc/ssh/ssh_config' 'etc/ssh/sshd_config' 'etc/pam.d/sshd')
+prepare() {
+ cd $pkgname-$pkgver
+ # OpenSSL 1.1.0 patch from http://vega.pgw.jp/~kabe/vsd/patch/openssh-7.4p1-openssl-1.1.0c.patch.html
+ patch -Np1 -i ../openssl-1.1.0.patch
+}
+
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -47,9 +56,9 @@ build() {
--with-privsep-user=nobody \
--with-kerberos5=/usr \
--with-xauth=/usr/bin/xauth \
- --with-mantype=man \
--with-md5-passwords \
--with-pid-dir=/run \
+ --with-default-path='/usr/local/sbin:/usr/local/bin:/usr/bin' \
make
}
@@ -57,10 +66,13 @@ build() {
check() {
cd "${srcdir}/${pkgname}-${pkgver}"
- make tests || true
- # hard to suitably test connectivity:
- # - fails with /bin/false as login shell
- # - fails with firewall activated, etc.
+ # Tests require openssh to be already installed system-wide,
+ # also connectivity tests will fail under makechrootpkg since
+ # it runs as nobody which has /bin/false as login shell.
+
+ if [[ -e /usr/bin/scp && ! -e /.arch-chroot ]]; then
+ make tests
+ fi
}
package() {