summaryrefslogtreecommitdiffstats
path: root/abs/core/pacman/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-08-30 22:24:02 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-08-30 22:24:02 (GMT)
commitc4bd4457b5d640e1c8f5afbca7cd54c53691e5fc (patch)
treef4e4f7a91e1d9d90033fd99d89e5e26a2c144528 /abs/core/pacman/PKGBUILD
parent0e7b327a1ae444233f1308a95420f70540ad74a3 (diff)
downloadlinhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.zip
linhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.tar.gz
linhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.tar.bz2
RSYNC CORE:
resync core-testing -> core Signed-off-by: James Meyer <james.meyer@operamail.com>
Diffstat (limited to 'abs/core/pacman/PKGBUILD')
-rw-r--r--abs/core/pacman/PKGBUILD42
1 files changed, 33 insertions, 9 deletions
diff --git a/abs/core/pacman/PKGBUILD b/abs/core/pacman/PKGBUILD
index ecb96c7..239abb8 100644
--- a/abs/core/pacman/PKGBUILD
+++ b/abs/core/pacman/PKGBUILD
@@ -1,36 +1,60 @@
-# $Id: PKGBUILD 23245 2009-01-07 02:10:32Z dan $
+# $Id: PKGBUILD 58635 2009-11-11 00:00:52Z dan $
# Maintainer: Aaron Griffin <aaron@archlinux.org>
# Maintainer: Dan McGee <dan@archlinux.org>
pkgname=pacman
-pkgver=3.2.2
-pkgrel=1
+pkgver=3.3.3
+pkgrel=10
pkgdesc="A library-based package manager with dependency support"
arch=('i686' 'x86_64')
url="http://www.archlinux.org/pacman/"
license=('GPL')
groups=('base')
-depends=('bash' 'libarchive>=2.6.0' 'libdownload>=1.3' 'pacman-mirrorlist')
+depends=('bash' 'libarchive>=2.7.1' 'libfetch>=2.25' 'pacman-mirrorlist')
optdepends=('fakeroot: for makepkg usage as normal user'
'python: for rankmirrors script usage')
-backup=(etc/pacman.conf etc/makepkg.conf etc/pacman.d/mirrorlist)
+backup=(etc/pacman.conf etc/makepkg.conf)
install=pacman.install
options=(!libtool)
source=(ftp://ftp.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz
- pacman.conf)
-md5sums=('8404fc38566bb52f8eee2ea483a41051'
- '27271a59b9c9f748547ef4feae90bc5c')
+ pacman.conf
+ makepkg.conf)
+md5sums=('a8cef73d68e2a4c3a46fb46c33210719'
+ 'abe70dabacee7036368c7afeb686eb10'
+ '52c7bc651b107d73f9902755b7594458')
build() {
cd $srcdir/$pkgname-$pkgver
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
make || return 1
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
make DESTDIR=$pkgdir install || return 1
- # install arch specific stuff
+ # install Arch specific stuff
mkdir -p $pkgdir/etc
install -m644 $srcdir/pacman.conf $pkgdir/etc/
+ install -m644 $srcdir/makepkg.conf $pkgdir/etc/
+ # set things correctly in the default conf file
+ case "$CARCH" in
+ i686)
+ mycarch="i686"
+ mychost="i686-pc-linux-gnu"
+ myflags="-march=i686 "
+ ;;
+ x86_64)
+ mycarch="x86_64"
+ mychost="x86_64-unknown-linux-gnu"
+ myflags="-march=x86-64 "
+ ;;
+ esac
+ sed -i $pkgdir/etc/makepkg.conf \
+ -e "s|@CARCH[@]|$mycarch|g" \
+ -e "s|@CHOST[@]|$mychost|g" \
+ -e "s|@CARCHFLAGS[@]|$myflags|g"
# install completion files
mkdir -p $pkgdir/etc/bash_completion.d/