summaryrefslogtreecommitdiffstats
path: root/abs/core/pacman/pacman.install
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-08-06 19:10:30 (GMT)
committerCecil <knoppmyth@gmail.com>2011-08-06 19:10:30 (GMT)
commitad58e3033f6bb5137b8dcb0e7eca12d50d888402 (patch)
tree9321335a68173bc3e4c1d237c19c8880411fa676 /abs/core/pacman/pacman.install
parent998faf16b1b62493b39aa13b3cb53dfac266ef4c (diff)
parent9709ca528ca5dfbdb6ec6ea283ac6670e8f33b9d (diff)
downloadlinhes_pkgbuild-ad58e3033f6bb5137b8dcb0e7eca12d50d888402.zip
linhes_pkgbuild-ad58e3033f6bb5137b8dcb0e7eca12d50d888402.tar.gz
linhes_pkgbuild-ad58e3033f6bb5137b8dcb0e7eca12d50d888402.tar.bz2
Merge branch 'testing' of ssh://cesman@linhes.org/mount/repository/linhes_pkgbuild into testing
Conflicts: abs/core/tzdata/PKGBUILD
Diffstat (limited to 'abs/core/pacman/pacman.install')
-rw-r--r--abs/core/pacman/pacman.install16
1 files changed, 16 insertions, 0 deletions
diff --git a/abs/core/pacman/pacman.install b/abs/core/pacman/pacman.install
index a3066bc..c066733 100644
--- a/abs/core/pacman/pacman.install
+++ b/abs/core/pacman/pacman.install
@@ -9,6 +9,7 @@ post_upgrade() {
if [ "$(vercmp $2 3.5.0)" -lt 0 ]; then
_warnupgrade
fi
+ _updateconf
echo ">>>"
echo ">>> ATTENTION! ATTENTION! ATTENTION!"
echo ">>> /etc/pacman.conf has changed. If you have customized your"
@@ -18,6 +19,21 @@ post_upgrade() {
echo ">>>"
}
+_updateconf() {
+ pacconf="/etc/pacman.conf"
+ #add SyncFirst
+ grep -q SyncFirst $pacconf
+ if [ $? -eq 1 ]
+ then
+ sed -i '/\[options\]/ a\SyncFirst = pacman ' $pacconf
+ fi
+ #remove larch
+ sed -i '/larch/d' $pacconf
+
+}
+
+
+
_warnupgrade() {
echo ">>>"
echo ">>> The pacman database format has changed as of pacman 3.5.0."