summaryrefslogtreecommitdiffstats
path: root/abs/core/pacman
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2020-07-05 02:10:03 (GMT)
committerBritney Fransen <brfransen@gmail.com>2020-07-05 02:10:03 (GMT)
commit800581e2e4365df59f1dc293b2c411786a99ccaf (patch)
treede0e4a7ba7818974fb2c46001cbd171f6e856063 /abs/core/pacman
parentcad3e735f2af8eb22f7b9e37e977558ca39c409d (diff)
downloadlinhes_pkgbuild-800581e2e4365df59f1dc293b2c411786a99ccaf.zip
linhes_pkgbuild-800581e2e4365df59f1dc293b2c411786a99ccaf.tar.gz
linhes_pkgbuild-800581e2e4365df59f1dc293b2c411786a99ccaf.tar.bz2
pacman: update to 5.2.2
Diffstat (limited to 'abs/core/pacman')
-rw-r--r--abs/core/pacman/PKGBUILD33
-rw-r--r--abs/core/pacman/makepkg-asroot.patch2
-rw-r--r--abs/core/pacman/makepkg-fix-one-more-file-seccomp-issue.patch30
-rw-r--r--abs/core/pacman/makepkg.conf6
-rw-r--r--abs/core/pacman/pacman-5.2.1-fix-pactest-package-tar-format.patch32
-rw-r--r--abs/core/pacman/pacman-5.2.1-reproducible-libprovides.patch13
6 files changed, 12 insertions, 104 deletions
diff --git a/abs/core/pacman/PKGBUILD b/abs/core/pacman/PKGBUILD
index 94ef2a4..582d60e 100644
--- a/abs/core/pacman/PKGBUILD
+++ b/abs/core/pacman/PKGBUILD
@@ -3,8 +3,8 @@
# Maintainer: Dave Reisner <dreisner@archlinux.org>
pkgname=pacman
-pkgver=5.2.1
-pkgrel=6
+pkgver=5.2.2
+pkgrel=1
pkgdesc="A library-based package manager with dependency support"
arch=('x86_64')
url="https://www.archlinux.org/pacman/"
@@ -22,29 +22,15 @@ options=('strip' 'debug')
validpgpkeys=('6645B0A8C7005E78DB1D7864F99FFE0FEAE999BD' # Allan McRae <allan@archlinux.org>
'B8151B117037781095514CA7BBDFFC92306B1121') # Andrew Gregory (pacman) <andrew@archlinux.org>
source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz{,.sig}
- makepkg-asroot.patch
- makepkg-wait-f.patch
- pacman-5.2.1-fix-pactest-package-tar-format.patch
- makepkg-fix-one-more-file-seccomp-issue.patch
- pacman-5.2.1-reproducible-libprovides.patch
pacman.conf
+ makepkg-asroot.patch
makepkg.conf)
-sha256sums=('1930c407265fd039cb3a8e6edc82f69e122aa9239d216d9d57b9d1b9315af312'
+sha256sums=('bb201a9f2fb53c28d011f661d50028efce6eef2c1d2a36728bdd0130189349a0'
'SKIP'
- 'd86967f28c57adf778070e7b92021a7e0dd14dcd67e32aa75fd09518c7cfe114'
- '2f7f800e5632de4f51307c82006be5c86e183a6f649292d9e4c41ed00ce7f048'
- '824a5c9dd458fb27b05a9a0b4b5d75b7a392de0dae79a18f5cfe8beaf4d82f0c'
- 'e481a161bba76729cd434c97e0b319ddfcb1d93b2e4890d72b4e8a32982531d9'
- '667ba659f85e3740fda9808e4751a44a63e0484072594d961b87e474c607b79c'
'3353f363088c73f1f86a890547c0f87c7473e5caf43bbbc768c2e9a7397f2aa2'
- '8c100b64450f5a19a16325dd05c143d49395bdeb96bd957f863cde4b95d3cb86')
+ '8a7019948c0917d70937a518a131b330a0adab66c1bd367ff4073046acf4c8a7'
+ '9c769f13c09a6f24c393a9762474eded2f269d8966e7764d9160d62232a7919b')
-prepare() {
- cd "$pkgname-$pkgver"
- patch -Np1 < ../pacman-5.2.1-fix-pactest-package-tar-format.patch
- patch -Np1 < ../makepkg-fix-one-more-file-seccomp-issue.patch
- patch -Np1 < ../pacman-5.2.1-reproducible-libprovides.patch
-}
build() {
cd "$pkgname-$pkgver"
@@ -73,10 +59,5 @@ package() {
#restore --asroot makepkg option
cd $pkgdir/usr/bin/
patch -p0 -i "$srcdir/makepkg-asroot.patch"
- #rm $pkgdir/usr/bin/makepkg.orig
-
- #remove wait -t option in makepkg
- cd $pkgdir/usr/bin/
- patch -p0 -i "$srcdir/makepkg-wait-f.patch"
-
+ rm $pkgdir/usr/bin/makepkg.orig
}
diff --git a/abs/core/pacman/makepkg-asroot.patch b/abs/core/pacman/makepkg-asroot.patch
index e0f085b..8169bd8 100644
--- a/abs/core/pacman/makepkg-asroot.patch
+++ b/abs/core/pacman/makepkg-asroot.patch
@@ -16,7 +16,7 @@
- error "$(gettext "Running %s as root is not allowed as it can cause permanent,\n\
-catastrophic damage to your system.")" "makepkg"
- exit $E_ROOT
-+ error "$(gettext "Running %s as root.")" "makepkg"
++ plain "$(gettext "Running %s as root.")" "makepkg"
+ #exit $E_ROOT
fi
else
diff --git a/abs/core/pacman/makepkg-fix-one-more-file-seccomp-issue.patch b/abs/core/pacman/makepkg-fix-one-more-file-seccomp-issue.patch
deleted file mode 100644
index 7b077ad..0000000
--- a/abs/core/pacman/makepkg-fix-one-more-file-seccomp-issue.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 00cfc6c5c9700b597c384743c2f057a2ba7125e2 Mon Sep 17 00:00:00 2001
-From: Eli Schwartz <eschwartz@archlinux.org>
-Date: Thu, 9 Jan 2020 20:49:17 -0500
-Subject: [pacman-dev] [PATCH] makepkg: fix one more file-seccomp issue
-
-When file is called via fakeroot, it doesn't matter whether you use -z
-or not, it is still incompatible with seccomp. Fix by configuring it
-with FILECMD when used in the fakeroot 'tidy' run.
-
-Signed-off-by: Eli Schwartz <eschwartz@archlinux.org>
----
- scripts/libmakepkg/tidy/strip.sh.in | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/scripts/libmakepkg/tidy/strip.sh.in b/scripts/libmakepkg/tidy/strip.sh.in
-index 1bd810f0..876f00f0 100644
---- a/scripts/libmakepkg/tidy/strip.sh.in
-+++ b/scripts/libmakepkg/tidy/strip.sh.in
-@@ -111,7 +111,7 @@ tidy_strip() {
-
- local binary strip_flags
- find . -type f -perm -u+w -print0 2>/dev/null | while IFS= read -rd '' binary ; do
-- case "$(file -bi "$binary")" in
-+ case "$(@FILECMD@ -bi "$binary")" in
- *application/x-sharedlib*) # Libraries (.so)
- strip_flags="$STRIP_SHARED";;
- *application/x-archive*) # Libraries (.a)
---
-2.24.1
-
diff --git a/abs/core/pacman/makepkg.conf b/abs/core/pacman/makepkg.conf
index cecfd9d..d8bf59e 100644
--- a/abs/core/pacman/makepkg.conf
+++ b/abs/core/pacman/makepkg.conf
@@ -40,11 +40,13 @@ CPPFLAGS="-D_FORTIFY_SOURCE=2"
CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fno-plt"
CXXFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fno-plt"
LDFLAGS="-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now"
+#RUSTFLAGS="-C opt-level=2"
#-- Make Flags: change this for DistCC/SMP systems
#MAKEFLAGS="-j2"
#-- Debugging flags
DEBUG_CFLAGS="-g -fvar-tracking-assignments"
DEBUG_CXXFLAGS="-g -fvar-tracking-assignments"
+#DEBUG_RUSTFLAGS="-C debuginfo=2"
#########################################################################
# BUILD ENVIRONMENT
@@ -87,7 +89,7 @@ BUILDENV=(!distcc color !ccache check !sign)
#
OPTIONS=(strip docs !libtool !staticlibs emptydirs zipman purge !debug)
-#-- File integrity checks to use. Valid: md5, sha1, sha256, sha384, sha512
+#-- File integrity checks to use. Valid: md5, sha1, sha224, sha256, sha384, sha512, b2
INTEGRITY_CHECK=(md5)
#-- Options to be used when stripping binaries. See `man strip' for details.
STRIP_BINARIES="--strip-all"
@@ -141,5 +143,5 @@ COMPRESSLZ=(lzip -c -f)
# EXTENSION DEFAULTS
#########################################################################
#
-PKGEXT='.pkg.tar.xz'
+PKGEXT='.pkg.tar.zst'
SRCEXT='.src.tar.gz'
diff --git a/abs/core/pacman/pacman-5.2.1-fix-pactest-package-tar-format.patch b/abs/core/pacman/pacman-5.2.1-fix-pactest-package-tar-format.patch
deleted file mode 100644
index cdf7e32..0000000
--- a/abs/core/pacman/pacman-5.2.1-fix-pactest-package-tar-format.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From b9faf652735c603d1bdf849a570185eb721f11c1 Mon Sep 17 00:00:00 2001
-From: Allan McRae <allan@archlinux.org>
-Date: Tue, 12 Nov 2019 16:14:57 +1000
-Subject: pactest: set package tar format to GNU_FORMAT
-
-python-3.8 changed the default tar format to PAX_FORMAT. This caused
-issues in our testsuite with package extraction of files with UTF-8
-characters as we run the tests under the C locale.
-
-sycn600.py:
-error: error while reading package /tmp/pactest-xuhri4xa/var/cache/pacman/pkg/unicodechars-2.0-1.pkg.tar.gz: Pathname can't be converted from UTF-8 to current locale.
-
-Set format back to GNU_FORMAT.
-
-Signed-off-by: Allan McRae <allan@archlinux.org>
----
- test/pacman/pmpkg.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/test/pacman/pmpkg.py b/test/pacman/pmpkg.py
-index 6a845222..e40868cc 100644
---- a/test/pacman/pmpkg.py
-+++ b/test/pacman/pmpkg.py
-@@ -142,7 +142,7 @@ class pmpkg(object):
- util.mkdir(os.path.dirname(self.path))
-
- # Generate package metadata
-- tar = tarfile.open(self.path, "w:gz")
-+ tar = tarfile.open(self.path, "w:gz", format=tarfile.GNU_FORMAT)
- for name, data in archive_files:
- info = tarfile.TarInfo(name)
- info.size = len(data)
diff --git a/abs/core/pacman/pacman-5.2.1-reproducible-libprovides.patch b/abs/core/pacman/pacman-5.2.1-reproducible-libprovides.patch
deleted file mode 100644
index fea6958..0000000
--- a/abs/core/pacman/pacman-5.2.1-reproducible-libprovides.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/scripts/makepkg.sh.in b/scripts/makepkg.sh.in
-index d1416d15..b95a03af 100644
---- a/scripts/makepkg.sh.in
-+++ b/scripts/makepkg.sh.in
-@@ -521,7 +521,7 @@ find_libprovides() {
- missing=0
- case "$p" in
- *.so)
-- mapfile -t filename < <(find "$pkgdir" -type f -name $p\*)
-+ mapfile -t filename < <(find "$pkgdir" -type f -name $p\* | LC_ALL=C sort)
- if [[ $filename ]]; then
- # packages may provide multiple versions of the same library
- for fn in "${filename[@]}"; do