summaryrefslogtreecommitdiffstats
path: root/abs/core/pam/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2015-09-04 15:53:07 (GMT)
committerBritney Fransen <brfransen@gmail.com>2015-09-04 15:53:07 (GMT)
commit0b9399abdb44bb7fc85da014c69b1cc540830c8e (patch)
tree34b08f437eb51f925e2dbd9f5ac1aae95065f581 /abs/core/pam/PKGBUILD
parent337998c9b743c72a437951f0e3e78c40a007c195 (diff)
downloadlinhes_pkgbuild-0b9399abdb44bb7fc85da014c69b1cc540830c8e.zip
linhes_pkgbuild-0b9399abdb44bb7fc85da014c69b1cc540830c8e.tar.gz
linhes_pkgbuild-0b9399abdb44bb7fc85da014c69b1cc540830c8e.tar.bz2
pam: update to 1.2.1
Diffstat (limited to 'abs/core/pam/PKGBUILD')
-rw-r--r--abs/core/pam/PKGBUILD37
1 files changed, 23 insertions, 14 deletions
diff --git a/abs/core/pam/PKGBUILD b/abs/core/pam/PKGBUILD
index 965f215..9290c1e 100644
--- a/abs/core/pam/PKGBUILD
+++ b/abs/core/pam/PKGBUILD
@@ -1,31 +1,40 @@
-# $Id: PKGBUILD 197836 2013-10-30 11:06:23Z allan $
+# $Id$
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: judd <jvinet@zeroflux.org>
pkgname=pam
-pkgver=1.1.8
-pkgrel=2
+pkgver=1.2.1
+pkgrel=1
pkgdesc="PAM (Pluggable Authentication Modules) library"
arch=('i686' 'x86_64')
license=('GPL2')
-url="http://www.kernel.org/pub/linux/libs/pam/"
-depends=('glibc' 'db' 'cracklib' 'libtirpc' 'pambase')
+url="http://linux-pam.org"
+depends=('glibc' 'cracklib' 'libtirpc' 'pambase')
makedepends=('flex' 'w3m' 'docbook-xml>=4.4' 'docbook-xsl')
backup=(etc/security/{access.conf,group.conf,limits.conf,namespace.conf,namespace.init,pam_env.conf,time.conf} etc/default/passwd etc/environment)
-source=(https://fedorahosted.org/releases/l/i/linux-pam/Linux-PAM-$pkgver.tar.bz2
- #http://www.kernel.org/pub/linux/libs/pam/library/Linux-PAM-$pkgver.tar.bz2
- ftp://ftp.archlinux.org/other/pam_unix2/pam_unix2-2.9.1.tar.bz2
+source=(http://linux-pam.org/library/Linux-PAM-$pkgver.tar.bz2
+ https://sources.archlinux.org/other/pam_unix2/pam_unix2-2.9.1.tar.bz2
pam_unix2-glibc216.patch)
+md5sums=('9dc53067556d2dd567808fd509519dd6'
+ 'da6a46e5f8cd3eaa7cbc4fc3a7e2b555'
+ 'dac109f68e04a4df37575fda6001ea17')
+
options=('!emptydirs')
+prepare () {
+ cd $srcdir/Linux-PAM-$pkgver
+
+ # fix pam_unix2 building
+ cd $srcdir/pam_unix2-2.9.1
+ patch -Np1 -i "${srcdir}/pam_unix2-glibc216.patch"
+}
+
build() {
cd $srcdir/Linux-PAM-$pkgver
- ./configure --libdir=/usr/lib --sbindir=/usr/bin
+ ./configure --libdir=/usr/lib --sbindir=/usr/bin --disable-db
make
cd $srcdir/pam_unix2-2.9.1
- patch -Np1 -i ../pam_unix2-glibc216.patch
-
# modify flags to build against the pam compiled here, not a system lib.
./configure \
CFLAGS="$CFLAGS -I$srcdir/Linux-PAM-$pkgver/libpam/include/" \
@@ -63,7 +72,7 @@ _EOT
# set unix_chkpwd uid
chmod +s $pkgdir/usr/bin/unix_chkpwd
+ # remove doc which is not used anymore
+ # FS #40749
+ rm $pkgdir/usr/share/doc/Linux-PAM/sag-pam_userdb.html
}
-md5sums=('35b6091af95981b1b2cd60d813b5e4ee'
- 'da6a46e5f8cd3eaa7cbc4fc3a7e2b555'
- 'dac109f68e04a4df37575fda6001ea17')