summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-module-build
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-26 14:49:49 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-26 14:49:49 (GMT)
commit1ee7cc86da31af9c0b0f16f8934626093df968a8 (patch)
tree28ef252b3b04b01ac64c9ebb3ad8497f13c0352f /abs/core/perl_modules/perl-module-build
parent9b02f79cac1b37a36a6be3bd658a693369fccc62 (diff)
downloadlinhes_pkgbuild-1ee7cc86da31af9c0b0f16f8934626093df968a8.zip
linhes_pkgbuild-1ee7cc86da31af9c0b0f16f8934626093df968a8.tar.gz
linhes_pkgbuild-1ee7cc86da31af9c0b0f16f8934626093df968a8.tar.bz2
perl_modules needed for frozen bubble:
perl-aliean-sdl perl-capture-tiny perl-compress-bzip2 perl-file-sharedir perl-file-which perl-ipc-system-simple perl-local-maketext-lexicon perl-module-build perl-sdl perl-text-patch perl-tie-simple
Diffstat (limited to 'abs/core/perl_modules/perl-module-build')
-rw-r--r--abs/core/perl_modules/perl-module-build/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-module-build/PKGBUILD b/abs/core/perl_modules/perl-module-build/PKGBUILD
new file mode 100644
index 0000000..96712a7
--- /dev/null
+++ b/abs/core/perl_modules/perl-module-build/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id: PKGBUILD 166452 2012-09-08 01:51:46Z eric $
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor : Alan Young <harleypig@gmail.com>
+
+pkgname=perl-module-build
+pkgver=0.4003
+pkgrel=1
+pkgdesc="Build, test, and install Perl modules"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+url='http://search.cpan.org/dist/Module-Build'
+depends=('perl>=5.6.1')
+options=('!emptydirs')
+source=(http://search.cpan.org/CPAN/authors/id/L/LE/LEONT/Module-Build-$pkgver.tar.gz)
+md5sums=('ed5fe7e023af43b0722639b13ece8d2d')
+
+build() {
+ cd Module-Build-$pkgver
+ perl Build.PL installdirs=vendor
+ perl Build
+}
+
+check() {
+ cd Module-Build-$pkgver
+ perl Build test
+}
+
+package() {
+ cd Module-Build-$pkgver
+ perl Build install destdir="$pkgdir"
+}