summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-www-robotrules
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 17:54:22 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 17:54:22 (GMT)
commitff0f7cee2dc2b420e257313fef663a3f78bbc800 (patch)
tree7af473b8667e5c685144e8123934878b79896412 /abs/core/perl_modules/perl-www-robotrules
parent16a043fed17ea05b6d6ca012ff09b71008562790 (diff)
downloadlinhes_pkgbuild-ff0f7cee2dc2b420e257313fef663a3f78bbc800.zip
linhes_pkgbuild-ff0f7cee2dc2b420e257313fef663a3f78bbc800.tar.gz
linhes_pkgbuild-ff0f7cee2dc2b420e257313fef663a3f78bbc800.tar.bz2
perl_modules: updated to many to list
Diffstat (limited to 'abs/core/perl_modules/perl-www-robotrules')
-rw-r--r--abs/core/perl_modules/perl-www-robotrules/PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-www-robotrules/PKGBUILD b/abs/core/perl_modules/perl-www-robotrules/PKGBUILD
new file mode 100644
index 0000000..790cf73
--- /dev/null
+++ b/abs/core/perl_modules/perl-www-robotrules/PKGBUILD
@@ -0,0 +1,49 @@
+# Packager: Justin "juster" Davis <jrcd83@gmail.com>
+# $Id: PKGBUILD 150764 2012-02-21 20:29:03Z juster $
+
+pkgname=perl-www-robotrules
+pkgver=6.02
+pkgrel=1
+pkgdesc="database of robots.txt-derived permissions"
+arch=(any)
+license=(PerlArtistic GPL)
+options=(!emptydirs)
+depends=('perl>=5.8.1' 'perl-uri>=1.10')
+conflicts=('perl-libwww<6')
+url=https://metacpan.org/release/WWW-RobotRules
+source=("http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/WWW-RobotRules-${pkgver}.tar.gz")
+md5sums=(b7186e8b8b3701e70c22abf430742403)
+sha512sums=(781a2fc90e4efed901a91ecf4f2aaac2684409c6a75a8434ff140654838bb05d11f8fa760642e20eee96450d3ced6815a4dab11a4245bc8120c69ca68ab49e44)
+_distdir="${srcdir}/WWW-RobotRules-${pkgver}"
+
+build()
+(
+ export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+)
+
+check()
+(
+ export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ cd "$_distdir"
+ make test
+)
+
+package() {
+ cd "$_distdir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: