summaryrefslogtreecommitdiffstats
path: root/abs/core/python-netifaces/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/core/python-netifaces/PKGBUILD
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/core/python-netifaces/PKGBUILD')
-rw-r--r--abs/core/python-netifaces/PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/abs/core/python-netifaces/PKGBUILD b/abs/core/python-netifaces/PKGBUILD
new file mode 100644
index 0000000..13a424e
--- /dev/null
+++ b/abs/core/python-netifaces/PKGBUILD
@@ -0,0 +1,17 @@
+pkgname=python-netifaces
+__pkgname="netifaces"
+pkgver=0.5
+pkgrel=2
+pkgdesc="Python modules for network interfaces"
+arch=(i686 x86_64)
+license=('LGPL' 'MPL')
+depends=('python')
+makedepends=('setuptools' )
+source=(http://alastairs-place.net/2007/03/netifaces/netifaces-0.5.tar.gz)
+url="http://alastairs-place.net/netifaces/"
+
+build() {
+ cd "${srcdir}/${__pkgname}-${pkgver}"
+ chmod -x -R netifaces.egg-info
+ yes "" | python setup.py install --root=$startdir/pkg --prefix=/usr
+}