summaryrefslogtreecommitdiffstats
path: root/abs/core/python/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-12-09 03:51:31 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-12-09 03:51:31 (GMT)
commit22cf86961b2c62437603fd3a61dfab580bedd837 (patch)
tree91f5f1fb6d52e4a879d0e21ef60be86c6e2a07a4 /abs/core/python/PKGBUILD
parent387348a06c19253fa328d8aa9d421328e2aab993 (diff)
downloadlinhes_pkgbuild-22cf86961b2c62437603fd3a61dfab580bedd837.zip
linhes_pkgbuild-22cf86961b2c62437603fd3a61dfab580bedd837.tar.gz
linhes_pkgbuild-22cf86961b2c62437603fd3a61dfab580bedd837.tar.bz2
gdbm: recompile with some needed patches. Remove python (python3).
Diffstat (limited to 'abs/core/python/PKGBUILD')
-rw-r--r--abs/core/python/PKGBUILD55
1 files changed, 0 insertions, 55 deletions
diff --git a/abs/core/python/PKGBUILD b/abs/core/python/PKGBUILD
deleted file mode 100644
index fcbfc50..0000000
--- a/abs/core/python/PKGBUILD
+++ /dev/null
@@ -1,55 +0,0 @@
-# $Id: PKGBUILD 94083 2010-10-04 12:47:13Z allan $
-# Maintainer: Allan McRae <allan@archlinux.org>
-# Contributer: Jason Chu <jason@archlinux.org>
-
-pkgname=python
-pkgver=3.1.2
-pkgrel=3
-_pybasever=3.1
-pkgdesc="Next generation of the python high-level scripting language"
-arch=('i686' 'x86_64')
-license=('custom')
-url="http://www.python.org"
-depends=('expat' 'bzip2' 'gdbm' 'openssl' 'zlib')
-makedepends=('tk' 'sqlite3')
-optdepends=('tk: for tkinter')
-provides=('python3')
-replaces=('python3')
-conflicts=('python2')
-options=('!makeflags')
-source=(http://www.python.org/ftp/python/${pkgver}/Python-${pkgver}.tar.bz2
- python-internal-expat.patch)
-md5sums=('45350b51b58a46b029fb06c61257e350'
- '993800dbcc0c4f199c1ceee998a06e71')
-
-build() {
- cd ${srcdir}/Python-${pkgver}
-
- patch -Np0 -i ${srcdir}/python-internal-expat.patch
-
- export OPT="${CFLAGS}"
- ./configure --prefix=/usr --enable-shared --with-threads --with-computed-gotos \
- --enable-unicode --with-wide-unicode
-
- make || return 1
-}
-
-package() {
- cd ${srcdir}/Python-${pkgver}
- make DESTDIR=${pkgdir} install || return 1
-
- # why are these not done by default...
- ln -sf python3 ${pkgdir}/usr/bin/python
- ln -sf python3-config ${pkgdir}/usr/bin/python-config
- ln -sf idle3 ${pkgdir}/usr/bin/idle
- ln -sf pydoc3 ${pkgdir}/usr/bin/pydoc
-
- # clean-up reference to build directory
- sed -i "s#$srcdir/Python-${pkgver}:##" $pkgdir/usr/lib/python3.1/config/Makefile
-
- # Fix conflicts with python2 - python2 version is newer...
- rm ${pkgdir}/usr/bin/2to3
-
- # license
- install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
-}