summaryrefslogtreecommitdiffstats
path: root/abs/core/python2/fix-profile-task.patch
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-02-13 19:40:33 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-02-13 19:40:33 (GMT)
commit99386916bbaf4d29bc546ae0a24fed284f655a46 (patch)
treefe8330703eda4b0a2ad9d60c7cdfb9f0d89e24af /abs/core/python2/fix-profile-task.patch
parent92857bef1f105647b7e834e69d9f980a81705622 (diff)
downloadlinhes_pkgbuild-99386916bbaf4d29bc546ae0a24fed284f655a46.zip
linhes_pkgbuild-99386916bbaf4d29bc546ae0a24fed284f655a46.tar.gz
linhes_pkgbuild-99386916bbaf4d29bc546ae0a24fed284f655a46.tar.bz2
python2: update to 2.7.14
Diffstat (limited to 'abs/core/python2/fix-profile-task.patch')
-rw-r--r--abs/core/python2/fix-profile-task.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/abs/core/python2/fix-profile-task.patch b/abs/core/python2/fix-profile-task.patch
new file mode 100644
index 0000000..c6558ef
--- /dev/null
+++ b/abs/core/python2/fix-profile-task.patch
@@ -0,0 +1,13 @@
+diff --git a/Python-2.7.13/Makefile.pre.in b/Python-2.7.13/Makefile.pre.in
+index e288964..22edc27 100644
+--- a/Python-2.7.13/Makefile.pre.in
++++ b/Python-2.7.13/Makefile.pre.in
+@@ -456,7 +456,7 @@ build_all_generate_profile:
+
+ run_profile_task:
+ : # FIXME: can't run for a cross build
+- $(LLVM_PROF_FILE) ./$(BUILDPYTHON) $(PROFILE_TASK) || true
++ $(LLVM_PROF_FILE) $(RUNSHARED) ./$(BUILDPYTHON) $(PROFILE_TASK) || true
+
+ build_all_merge_profile:
+ $(LLVM_PROF_MERGER)