summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/gitpython
diff options
context:
space:
mode:
authorMichael Hanson <mihanson@linhes.org>2011-11-07 00:00:50 (GMT)
committerMichael Hanson <mihanson@linhes.org>2011-11-07 00:00:50 (GMT)
commitbe3b15c43874fde0cd6820b27912161b23fe5ba5 (patch)
treeceb63e144df9bab08a56e0289a33d9553a94f8b5 /abs/core/python_modules/gitpython
parent4408210bf04aedaccfc8b33ed73179e3b48b49c8 (diff)
downloadlinhes_pkgbuild-be3b15c43874fde0cd6820b27912161b23fe5ba5.zip
linhes_pkgbuild-be3b15c43874fde0cd6820b27912161b23fe5ba5.tar.gz
linhes_pkgbuild-be3b15c43874fde0cd6820b27912161b23fe5ba5.tar.bz2
git-python: rename git directory to be consistent with pkgname and AUR.
Diffstat (limited to 'abs/core/python_modules/gitpython')
-rw-r--r--abs/core/python_modules/gitpython/PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/abs/core/python_modules/gitpython/PKGBUILD b/abs/core/python_modules/gitpython/PKGBUILD
new file mode 100644
index 0000000..5b4d975
--- /dev/null
+++ b/abs/core/python_modules/gitpython/PKGBUILD
@@ -0,0 +1,20 @@
+# Contributor: Jon Bergli Heier <snakebite@jvnv.net>
+pkgname=gitpython
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="A python library used to interact with Git repositories"
+arch=('any')
+url="http://gitorious.org/git-python"
+license=('BSD')
+depends=('python2' 'git' 'python-gitdb')
+conflicts=('gitpython-git')
+source=("http://pypi.python.org/packages/source/G/GitPython/GitPython-${pkgver}.tar.gz")
+md5sums=('98f9a4e33574065660b7257fa93d707d')
+
+build() {
+ cd "$srcdir/GitPython-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1 || return 1
+ install -D -m 644 LICENSE "$pkgdir"/usr/share/licenses/gitpython/LICENSE
+}
+# vim:set ts=2 sw=2 et:
+