summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/gnome-python-extras/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-12-09 23:50:12 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-12-09 23:50:12 (GMT)
commit7d4b636ebff9abb2650fb99594819dfb62a65385 (patch)
treeb696cb1e2be7f02e2b1ed343d2b02e9ef06d6d53 /abs/core/python_modules/gnome-python-extras/PKGBUILD
parent4345c9628a39c7d76c6d8dd6765038cf8bd5dffd (diff)
downloadlinhes_pkgbuild-7d4b636ebff9abb2650fb99594819dfb62a65385.zip
linhes_pkgbuild-7d4b636ebff9abb2650fb99594819dfb62a65385.tar.gz
linhes_pkgbuild-7d4b636ebff9abb2650fb99594819dfb62a65385.tar.bz2
gnome-python-extras: recompile
Diffstat (limited to 'abs/core/python_modules/gnome-python-extras/PKGBUILD')
-rw-r--r--abs/core/python_modules/gnome-python-extras/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/core/python_modules/gnome-python-extras/PKGBUILD b/abs/core/python_modules/gnome-python-extras/PKGBUILD
new file mode 100644
index 0000000..690ec2e
--- /dev/null
+++ b/abs/core/python_modules/gnome-python-extras/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 35285 2009-04-11 20:46:50Z jgc $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=gnome-python-extras
+pkgver=2.25.3
+pkgrel=2
+pkgdesc="Gnome Python interfaces for libraries not part of the core platform"
+arch=('i686' 'x86_64')
+license=('GPL' 'LGPL')
+depends=('gnome-python>=2.22.1')
+makedepends=('libgtkhtml' 'gtkspell' 'gdl' 'xulrunner>=1.9' 'libgksu' 'pkgconfig' 'libgnomeui' 'libgda')
+optdepends=('libgtkhtml' 'gtkspell' 'gdl' 'xulrunner' 'libgksu' 'libgnomeui' 'libgda')
+options=('!libtool')
+source=(http://ftp.gnome.org/pub/gnome/sources/gnome-python-extras/2.25/gnome-python-extras-${pkgver}.tar.bz2)
+url="http://www.daa.com.au/~james/pygtk/"
+md5sums=('9f3b7ec5c57130b96061cb486b79c076')
+
+build() {
+ cd "${srcdir}/gnome-python-extras-${pkgver}"
+ ./configure --prefix=/usr || return 1
+ make MOZILLA_HOME=/usr/lib/xulrunner-1.9 || return 1
+}
+package() {
+ cd "${srcdir}/gnome-python-extras-${pkgver}"
+ make DESTDIR="${pkgdir}" install || return 1
+}