summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/pyopenssl/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <jams@linhes.org>2010-12-10 01:32:23 (GMT)
committerJames Meyer <jams@linhes.org>2010-12-10 01:32:23 (GMT)
commit5c40bb464357d486339e90f4118e4adaa8989e09 (patch)
tree8b5f680e7867c24eb5f3d1347eef9ea19c92beeb /abs/core/python_modules/pyopenssl/PKGBUILD
parentf9b90df04a227fb2607482bed9a2f56678d95d30 (diff)
parent59771e9d114b75eafb316e94b7612dda202edd83 (diff)
downloadlinhes_pkgbuild-5c40bb464357d486339e90f4118e4adaa8989e09.zip
linhes_pkgbuild-5c40bb464357d486339e90f4118e4adaa8989e09.tar.gz
linhes_pkgbuild-5c40bb464357d486339e90f4118e4adaa8989e09.tar.bz2
Merge branch 'testing' of ssh://linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/core/python_modules/pyopenssl/PKGBUILD')
-rw-r--r--abs/core/python_modules/pyopenssl/PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/abs/core/python_modules/pyopenssl/PKGBUILD b/abs/core/python_modules/pyopenssl/PKGBUILD
new file mode 100644
index 0000000..a136830
--- /dev/null
+++ b/abs/core/python_modules/pyopenssl/PKGBUILD
@@ -0,0 +1,21 @@
+# $Id: PKGBUILD 87790 2010-08-18 10:10:07Z ibiru $
+# Maintainer : Ionut Biru<ibiru@archlinux.org>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+
+pkgname=pyopenssl
+pkgver=0.10
+pkgrel=4
+pkgdesc="pyOpenSSL is a Python interface to the OpenSSL library"
+arch=('i686' 'x86_64')
+url="http://pyopenssl.sourceforge.net"
+license=('LGPL')
+depends=('python2' 'openssl')
+source=(http://pypi.python.org/packages/source/p/pyOpenSSL/pyOpenSSL-${pkgver}.tar.gz)
+md5sums=('34db8056ec53ce80c7f5fc58bee9f093')
+
+build() {
+ cd "${srcdir}/pyOpenSSL-${pkgver}"
+ python2 setup.py build
+ python2 setup.py install --prefix="$pkgdir/usr" --optimize=1
+}
+