summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-beautifulsoup4
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-09-23 19:14:54 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-09-23 19:14:54 (GMT)
commitc96cd6fab2342335a4f64b7eb2c843cd576eb610 (patch)
tree551793d94c47f1e4d88ed5309d5224435762bf1e /abs/core/python_modules/python-beautifulsoup4
parent048e83695f2b4cb9ddc118e128a7d08f7d48e651 (diff)
parentcafd1e5f46d61c3175d4a3347c65ae79c476c61a (diff)
downloadlinhes_pkgbuild-c96cd6fab2342335a4f64b7eb2c843cd576eb610.zip
linhes_pkgbuild-c96cd6fab2342335a4f64b7eb2c843cd576eb610.tar.gz
linhes_pkgbuild-c96cd6fab2342335a4f64b7eb2c843cd576eb610.tar.bz2
Merge remote-tracking branch 'origin/testing' into testing
# By Cecil (6) and Britney Fransen (2) # Via Britney Fransen (1) and Cecil (1) * origin/testing: LinHES-system: myth_status.py: fix conflicted recordings mythtv: bump to latest fixes to get python bindings fix pyxis:Initial inclusion. Needed for pyxis to close #63/4). python-distribute:Needed for python-beautifulsoup (to close #63/4). python-beautifulsoup4:Needed for pyxis (to close #63/4). python-libconcord:Moved to core with rest of python modules. gdb:Recompile against Python 2.6. Closes 850. mythappletrailers:Closes 849. Adds Play All, Shuffle and Play Random trailer to the menu. Conflicts were set to 64 bit versions, except for appletrailers Conflicts: abs/core/LinHES-system/PKGBUILD abs/core/gdb/PKGBUILD abs/core/gdb/__changelog abs/core/mythtv/stable-0.25/mythtv/PKGBUILD abs/core/python_modules/python-distribute/PKGBUILD abs/core/python_modules/python-distribute/__changelog abs/extra/mythappletrailers/PKGBUILD
Diffstat (limited to 'abs/core/python_modules/python-beautifulsoup4')
-rw-r--r--abs/core/python_modules/python-beautifulsoup4/PKGBUILD51
-rw-r--r--abs/core/python_modules/python-beautifulsoup4/__changelog2
2 files changed, 53 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-beautifulsoup4/PKGBUILD b/abs/core/python_modules/python-beautifulsoup4/PKGBUILD
new file mode 100644
index 0000000..e5eba14
--- /dev/null
+++ b/abs/core/python_modules/python-beautifulsoup4/PKGBUILD
@@ -0,0 +1,51 @@
+# $Id: PKGBUILD 73500 2012-07-08 17:25:45Z dwallace $
+# Maintainer: Daniel Wallace <danielwallace at gtmanfred dot com>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+
+pkgbase=python-beautifulsoup4
+pkgname=('python2-beautifulsoup4' 'python-beautifulsoup4')
+pkgver=4.1.1
+pkgrel=2
+pkgdesc="A Python HTML/XML parser designed for quick turnaround projects like screen-scraping"
+arch=('any')
+url="http://www.crummy.com/software/BeautifulSoup/index.html"
+license=('PSF')
+#makedepends=('python-distribute' 'python2-distribute')
+makedepends=('python2-distribute')
+source=("http://www.crummy.com/software/BeautifulSoup/bs4/download/${pkgver%\.*}/${pkgbase#*-}-${pkgver}.tar.gz")
+md5sums=('fccee58b4d914fb489385d672fe89f43')
+
+build() {
+ cd "${srcdir}"
+ cp -a beautifulsoup4-${pkgver}{,-python2}
+
+ # Build python 3 module
+ cd "${srcdir}/beautifulsoup4-${pkgver}"
+ python setup.py build
+
+ # Build python 2 module
+ cd "${srcdir}/beautifulsoup4-${pkgver}-python2"
+ python2 setup.py build
+}
+
+package_python2-beautifulsoup4() {
+ depends=('python2-distribute')
+ optdepends=('python2-chardet: universal encoding detector'
+ 'python2-lxml: pythonic binding for the libxml2 and libxslt libraries')
+
+ cd "${srcdir}/beautifulsoup4-${pkgver}-python2"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+
+ rm -rf ${pkgdir}/usr/lib/python2.7/site-packages/bs4/tests
+}
+
+package_python-beautifulsoup4() {
+# depends=('python-distribute')
+ optdepends=('python-chardet: universal encoding detector'
+ 'python-lxml: pythonic binding for the libxml2 and libxslt libraries')
+
+ cd "${srcdir}/beautifulsoup4-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+
+ rm -rf ${pkgdir}/usr/lib/python3.2/site-packages/bs4/{__pycache__,tests,builder/__pycache__}
+}
diff --git a/abs/core/python_modules/python-beautifulsoup4/__changelog b/abs/core/python_modules/python-beautifulsoup4/__changelog
new file mode 100644
index 0000000..1cdf6fa
--- /dev/null
+++ b/abs/core/python_modules/python-beautifulsoup4/__changelog
@@ -0,0 +1,2 @@
+9/3/12 - chw
+commented python-distribute as dep since we don't include python3. Built with mp.py --pkg=python2-beautisoup4.