summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-notify
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-15 16:06:42 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-15 16:06:42 (GMT)
commited6f98d16de03a1a6511cf7cb12f5dbf0c9220e0 (patch)
tree573158032e117f45e489a894c42617896eb22b3f /abs/core/python_modules/python-notify
parentfe739ba880e1fa2f54451a1053d59df031e22ee1 (diff)
downloadlinhes_pkgbuild-ed6f98d16de03a1a6511cf7cb12f5dbf0c9220e0.zip
linhes_pkgbuild-ed6f98d16de03a1a6511cf7cb12f5dbf0c9220e0.tar.gz
linhes_pkgbuild-ed6f98d16de03a1a6511cf7cb12f5dbf0c9220e0.tar.bz2
python_modules: updated several modules
python-notify python-pysqlite python_aosd pywebkitgtk
Diffstat (limited to 'abs/core/python_modules/python-notify')
-rw-r--r--abs/core/python_modules/python-notify/PKGBUILD27
-rw-r--r--abs/core/python_modules/python-notify/libnotify07.patch36
-rw-r--r--abs/core/python_modules/python-notify/notify-python-0.1.1-fix-GTK-symbols.patch25
3 files changed, 81 insertions, 7 deletions
diff --git a/abs/core/python_modules/python-notify/PKGBUILD b/abs/core/python_modules/python-notify/PKGBUILD
index 47c25e5..ad9a615 100644
--- a/abs/core/python_modules/python-notify/PKGBUILD
+++ b/abs/core/python_modules/python-notify/PKGBUILD
@@ -1,25 +1,38 @@
-# $Id: PKGBUILD 82 2009-07-17 19:56:55Z aaron $
+# $Id: PKGBUILD 148890 2012-02-05 11:54:24Z ibiru $
+# Maintainer: Angel Velasquez <angvp@archlinux.org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Roman Kyrylych <Roman.Kyrylych@gmail.com>
# Contributor: Mario Danic <mario.danic@gmail.com>
-# Maintainer: Daniel J Griffiths <ghost1227@archlinux.us>
-
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=python-notify
pkgver=0.1.1
-pkgrel=8
+pkgrel=11
pkgdesc="Python bindings for libnotify"
arch=('i686' 'x86_64')
url="http://www.galago-project.org/"
license=('GPL')
-depends=('pygtk>=2.22.0' 'libnotify>=0.4.5')
+depends=('pygtk>=2.22.0' 'libnotify>=0.7.1')
makedepends=('pkgconfig' 'python2')
options=(!libtool)
-source=(http://www.galago-project.org/files/releases/source/notify-python/notify-python-${pkgver}.tar.gz)
-md5sums=('8f0ef0939cc8edd2efd896ce5ba80cf4')
+source=(http://www.galago-project.org/files/releases/source/notify-python/notify-python-${pkgver}.tar.gz
+ libnotify07.patch
+ notify-python-0.1.1-fix-GTK-symbols.patch)
+md5sums=('8f0ef0939cc8edd2efd896ce5ba80cf4'
+ 'b40c4542575d5aef559908fe60a21634'
+ 'c6922028da5951e69a6a0167bdb4461c')
build() {
cd ${srcdir}/notify-python-${pkgver}
+
+ patch -Np1 -i ${srcdir}/libnotify07.patch
+ patch -Np1 -i ${srcdir}/notify-python-0.1.1-fix-GTK-symbols.patch
+
./configure --prefix=/usr
+
+ # WARNING - we touch src/pynotify.override in build because upstream did not rebuild pynotify.c
+ # from the input definitions, this forces pynotify.c to be regenerated, at some point this can be removed
+ touch src/pynotify.override
+
make clean
make
}
diff --git a/abs/core/python_modules/python-notify/libnotify07.patch b/abs/core/python_modules/python-notify/libnotify07.patch
new file mode 100644
index 0000000..289573d
--- /dev/null
+++ b/abs/core/python_modules/python-notify/libnotify07.patch
@@ -0,0 +1,36 @@
+diff -up notify-python-0.1.1/src/pynotify.defs.notify070 notify-python-0.1.1/src/pynotify.defs
+--- notify-python-0.1.1/src/pynotify.defs.notify070 2010-11-02 17:11:14.928179237 -0400
++++ notify-python-0.1.1/src/pynotify.defs 2010-11-02 17:11:51.153180231 -0400
+@@ -38,7 +38,6 @@
+ '("const-gchar*" "summary")
+ '("const-gchar*" "message" (null-ok) (default "NULL"))
+ '("const-gchar*" "icon" (null-ok) (default "NULL"))
+- '("GtkWidget*" "attach" (null-ok) (default "NULL"))
+ )
+ )
+
+@@ -53,24 +52,6 @@
+ )
+ )
+
+-(define-method attach_to_widget
+- (of-object "NotifyNotification")
+- (c-name "notify_notification_attach_to_widget")
+- (return-type "none")
+- (parameters
+- '("GtkWidget*" "attach")
+- )
+-)
+-
+-(define-method attach_to_status_icon
+- (of-object "NotifyNotification")
+- (c-name "notify_notification_attach_to_status_icon")
+- (return-type "none")
+- (parameters
+- '("GtkStatusIcon*" "attach")
+- )
+-)
+-
+ (define-method show
+ (of-object "NotifyNotification")
+ (c-name "notify_notification_show")
diff --git a/abs/core/python_modules/python-notify/notify-python-0.1.1-fix-GTK-symbols.patch b/abs/core/python_modules/python-notify/notify-python-0.1.1-fix-GTK-symbols.patch
new file mode 100644
index 0000000..f985c01
--- /dev/null
+++ b/abs/core/python_modules/python-notify/notify-python-0.1.1-fix-GTK-symbols.patch
@@ -0,0 +1,25 @@
+diff -up notify-python-0.1.1/src/__init__.py.BAD notify-python-0.1.1/src/__init__.py
+--- notify-python-0.1.1/src/__init__.py.BAD 2010-08-31 09:04:45.353844005 -0400
++++ notify-python-0.1.1/src/__init__.py 2010-08-31 09:04:49.281844300 -0400
+@@ -1 +1,21 @@
++"""
++Fedora's libnotify.so is not linked against GTK2 or GTK3. The idea
++was to support being linked against different parallel-installable
++GTK stacks.
++
++Unfortunately, python needs to jump through some special hoops in order
++to share symbols with extension modules, specifically, pygtk, which does
++link against GTK2.
++
++Without using sys.setdlopenflags(sys.getdlopenflags() | ctypes.RTLD_GLOBAL),
++the result is:
++libnotify-WARNING **: Missing symbol 'gdk_screen_make_display_name'
++
++Thanks to David Malcolm for figuring out the workaround.
++"""
++import ctypes
++import sys
++sys.setdlopenflags(sys.getdlopenflags() | ctypes.RTLD_GLOBAL)
++import gtk
++
+ from _pynotify import *