summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-numpy
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-12-09 23:51:19 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-12-09 23:51:19 (GMT)
commit231ef4b199673eb1070aa7dbc9383bb1fa11173f (patch)
tree6c16390db5ebdf1e456740e932f344740e42a16f /abs/core/python_modules/python-numpy
parente0f5e12c18d1c430a55baeece571484b61877453 (diff)
downloadlinhes_pkgbuild-231ef4b199673eb1070aa7dbc9383bb1fa11173f.zip
linhes_pkgbuild-231ef4b199673eb1070aa7dbc9383bb1fa11173f.tar.gz
linhes_pkgbuild-231ef4b199673eb1070aa7dbc9383bb1fa11173f.tar.bz2
python-numpy: recompile
Diffstat (limited to 'abs/core/python_modules/python-numpy')
-rw-r--r--abs/core/python_modules/python-numpy/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-numpy/PKGBUILD b/abs/core/python_modules/python-numpy/PKGBUILD
new file mode 100644
index 0000000..57b41f5
--- /dev/null
+++ b/abs/core/python_modules/python-numpy/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id: PKGBUILD 95257 2010-10-17 20:17:04Z ibiru $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: Douglas Soares de Andrade <dsa@aur.archlinux.org>
+# Contributor: Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
+
+pkgname=python-numpy
+pkgver=1.5.0
+pkgrel=3
+pkgdesc="Scientific tools for Python"
+arch=('i686' 'x86_64')
+license=('custom')
+url="http://numpy.scipy.org/"
+depends=('lapack' 'python2')
+makedepends=('python-nose' 'gcc-fortran')
+optdepends=('python-nose: test suite')
+source=(http://downloads.sourceforge.net/numpy/numpy-${pkgver}.tar.gz)
+md5sums=('3a8bfdc434df782d647161c48943ee09')
+
+build() {
+ cd "${srcdir}/numpy-${pkgver}"
+
+ export Atlas=None
+ export LDFLAGS="$LDFLAGS -shared"
+ python2 setup.py config_fc --fcompiler=gnu95 build
+}
+
+package() {
+ cd "${srcdir}/numpy-${pkgver}"
+ python2 setup.py config_fc --fcompiler=gnu95 install --prefix=/usr --root="${pkgdir}"
+
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ sed -i -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
+ -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
+ $(find $pkgdir -name '*.py')
+}