summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-oauth/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <jams@linhes.org>2010-12-10 01:32:23 (GMT)
committerJames Meyer <jams@linhes.org>2010-12-10 01:32:23 (GMT)
commit5c40bb464357d486339e90f4118e4adaa8989e09 (patch)
tree8b5f680e7867c24eb5f3d1347eef9ea19c92beeb /abs/core/python_modules/python-oauth/PKGBUILD
parentf9b90df04a227fb2607482bed9a2f56678d95d30 (diff)
parent59771e9d114b75eafb316e94b7612dda202edd83 (diff)
downloadlinhes_pkgbuild-5c40bb464357d486339e90f4118e4adaa8989e09.zip
linhes_pkgbuild-5c40bb464357d486339e90f4118e4adaa8989e09.tar.gz
linhes_pkgbuild-5c40bb464357d486339e90f4118e4adaa8989e09.tar.bz2
Merge branch 'testing' of ssh://linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/core/python_modules/python-oauth/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-oauth/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-oauth/PKGBUILD b/abs/core/python_modules/python-oauth/PKGBUILD
new file mode 100644
index 0000000..1404fec
--- /dev/null
+++ b/abs/core/python_modules/python-oauth/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Snowknight (hopkinsth@gmail.com)
+pkgname=python-oauth
+pkgver=1.0.1
+pkgrel=6
+pkgdesc="An open protocol to allow API authentication in a simple and standard method from desktop and web applications."
+arch=('any')
+url="http://code.google.com/p/oauth/"
+license=('MIT')
+depends=('python2')
+#makedepends=('python2-distribute')
+makedepends=('setuptools')
+source=(http://pypi.python.org/packages/source/o/oauth/oauth-${pkgver}.tar.gz)
+md5sums=('30ed3cc8c11d7841a89feab437aabf81')
+sha1sums=('b2d7609e4852b33d0d33f0bc6ae5cab8fadca014')
+
+build() {
+ cd ${srcdir}/oauth-${pkgver}
+
+ python2 setup.py build || return 1
+}
+package() {
+ cd ${srcdir}/oauth-${pkgver}
+ python2 setup.py install --root=${pkgdir} || return 1
+
+ install -Dm644 LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+