summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-pymedia/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/core/python_modules/python-pymedia/PKGBUILD
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/core/python_modules/python-pymedia/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-pymedia/PKGBUILD35
1 files changed, 0 insertions, 35 deletions
diff --git a/abs/core/python_modules/python-pymedia/PKGBUILD b/abs/core/python_modules/python-pymedia/PKGBUILD
deleted file mode 100644
index 5433471..0000000
--- a/abs/core/python_modules/python-pymedia/PKGBUILD
+++ /dev/null
@@ -1,35 +0,0 @@
-# Maintainer: TDY <tdy@gmx.com>
-
-pkgname=python-pymedia
-pkgver=1.3.7.3
-pkgrel=2
-pkgdesc="A Python library for accessing and manipulating multimedia files"
-arch=('i686' 'x86_64')
-url="http://pymedia.org/"
-license=('LGPL')
-depends=('alsa-lib' 'ffmpeg-svn' 'python2')
-optdepends=('faad2: AAC support'
- 'lame: MP3 support'
- 'libogg: Ogg support'
- 'libvorbis: Vorbis support')
-source=(http://downloads.sourceforge.net/${pkgname/*-}/${pkgname/*-}-$pkgver.tar.gz
- ${pkgname/*-}-$pkgver-amd64-gentoo.diff)
-md5sums=('2f4930c63866c97af5090b176e2a118a'
- '3137e65e1208db98e404ee894fcd744a')
-
-build() {
- cd "$srcdir/${pkgname/*-}-$pkgver"
- patch -Np1 -i ../${pkgname/*-}-$pkgver-amd64-gentoo.diff || return 1
-
- find "$srcdir/${pkgname/*-}-$pkgver" -name '*.py' | \
- xargs sed -i "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" || return 1
- find "$srcdir/${pkgname/*-}-$pkgver" -name '*.py' | \
- xargs sed -i "s|#![ ]*/bin/env python$|#!/usr/bin/env python2|" || return 1
-
- python2 setup.py build || return 1
-}
-
-package() {
- cd "$srcdir/${pkgname/*-}-$pkgver"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
-}