summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-pysqlite
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-15 16:06:42 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-15 16:06:42 (GMT)
commited6f98d16de03a1a6511cf7cb12f5dbf0c9220e0 (patch)
tree573158032e117f45e489a894c42617896eb22b3f /abs/core/python_modules/python-pysqlite
parentfe739ba880e1fa2f54451a1053d59df031e22ee1 (diff)
downloadlinhes_pkgbuild-ed6f98d16de03a1a6511cf7cb12f5dbf0c9220e0.zip
linhes_pkgbuild-ed6f98d16de03a1a6511cf7cb12f5dbf0c9220e0.tar.gz
linhes_pkgbuild-ed6f98d16de03a1a6511cf7cb12f5dbf0c9220e0.tar.bz2
python_modules: updated several modules
python-notify python-pysqlite python_aosd pywebkitgtk
Diffstat (limited to 'abs/core/python_modules/python-pysqlite')
-rw-r--r--abs/core/python_modules/python-pysqlite/ChangeLog3
-rw-r--r--abs/core/python_modules/python-pysqlite/PKGBUILD23
2 files changed, 17 insertions, 9 deletions
diff --git a/abs/core/python_modules/python-pysqlite/ChangeLog b/abs/core/python_modules/python-pysqlite/ChangeLog
index 12c0ad0..2f42c5d 100644
--- a/abs/core/python_modules/python-pysqlite/ChangeLog
+++ b/abs/core/python_modules/python-pysqlite/ChangeLog
@@ -1,3 +1,6 @@
+2011-10-07 Angel Velasquez <angvp@archlinux.org>
+ * Updated to: 2.6.3
+ * Added check function
2009-08-06 Douglas Soares de Andrade <douglas@archlinux.org>
diff --git a/abs/core/python_modules/python-pysqlite/PKGBUILD b/abs/core/python_modules/python-pysqlite/PKGBUILD
index 4a45ba5..0302233 100644
--- a/abs/core/python_modules/python-pysqlite/PKGBUILD
+++ b/abs/core/python_modules/python-pysqlite/PKGBUILD
@@ -1,21 +1,26 @@
-# $Id: PKGBUILD 89652 2010-09-02 20:47:02Z remy $
+# $Id: PKGBUILD 155872 2012-04-08 07:25:46Z remy $
+# Maintainer: Angel Velasquez <angvp@archlinux.org>
# Contributor: Aaron Griffin <aaron@archlinux.org>
-# Contributor: Aaron Griffin <aaron@archlinux.org>
-# Maintainer: Daniel J Griffiths <ghost1227@archlinux.us>
-
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=python-pysqlite
-pkgver=2.6.0
-pkgrel=3
+pkgver=2.6.3
+pkgrel=2
pkgdesc="A Python DB-API 2.0 interface for the SQLite embedded relational database engine"
license=('custom')
arch=('i686' 'x86_64')
url="http://code.google.com/p/pysqlite/"
-depends=('python2' 'sqlite3')
+depends=('python2' 'sqlite')
replaces=('pysqlite2')
source=(http://pysqlite.googlecode.com/files/pysqlite-${pkgver}.tar.gz \
setup.cfg)
-md5sums=('fc92618b3b39d02e6ff10dc467c36640'
- '86dd356c65afd14a22f2f8f64a26441e')
+md5sums=('711afa1062a1d2c4a67acdf02a33d86e'
+ '86dd356c65afd14a22f2f8f64a26441e')
+
+check() {
+ cd ${pkgdir}/usr/lib/python2.7/site-packages
+ python2 -c "from pysqlite2 import test; test.test()"
+}
+
build() {
cd ${srcdir}/pysqlite-${pkgver}
cp ${srcdir}/setup.cfg .