summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-simplejson/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-12-10 00:00:51 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-12-10 00:00:51 (GMT)
commitf6ed2c0b13678466ab6a7da378a46d4a7435b392 (patch)
tree7506d65f4373f1b97edcc7021845194e17356885 /abs/core/python_modules/python-simplejson/PKGBUILD
parent4d3bb16316675e226439b22f11fdd401c6eb80fa (diff)
downloadlinhes_pkgbuild-f6ed2c0b13678466ab6a7da378a46d4a7435b392.zip
linhes_pkgbuild-f6ed2c0b13678466ab6a7da378a46d4a7435b392.tar.gz
linhes_pkgbuild-f6ed2c0b13678466ab6a7da378a46d4a7435b392.tar.bz2
python-simplejson: recompile
Diffstat (limited to 'abs/core/python_modules/python-simplejson/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-simplejson/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-simplejson/PKGBUILD b/abs/core/python_modules/python-simplejson/PKGBUILD
new file mode 100644
index 0000000..05e2b1b
--- /dev/null
+++ b/abs/core/python_modules/python-simplejson/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 26298 2010-09-14 17:18:19Z schuay $
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: David Moore <davidm@sjsoft.com>
+
+pkgname=python-simplejson
+pkgver=2.1.1
+pkgrel=3
+pkgdesc="Simple, fast, extensible JSON encoder/decoder for Python"
+license=('MIT')
+arch=('any')
+url="http://undefined.org/python/#simplejson"
+depends=('python2')
+makedepends=('setuptools')
+source=(http://pypi.python.org/packages/source/s/simplejson/simplejson-${pkgver}.tar.gz)
+md5sums=('0bbe3a2e5e4cac040013733aca159d89')
+
+build() {
+ cd ${srcdir}/simplejson-${pkgver}
+
+ python2 setup.py install --root=${pkgdir}
+
+# License
+ install -Dm644 ${srcdir}/simplejson-${pkgver}/LICENSE.txt \
+ ${pkgdir}/usr/share/licenses/python-simplejson/LICENSE
+}