summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-12-09 23:56:56 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-12-09 23:56:56 (GMT)
commit35b481b3d126b1df9304cc7e0a89d5539d900739 (patch)
tree04136b45f1fae9cb6d22f3aaf67d1bf0acf151c6 /abs/core/python_modules
parenteeaaa2c8f33493cf66160846d3b17d0d448d3abc (diff)
downloadlinhes_pkgbuild-35b481b3d126b1df9304cc7e0a89d5539d900739.zip
linhes_pkgbuild-35b481b3d126b1df9304cc7e0a89d5539d900739.tar.gz
linhes_pkgbuild-35b481b3d126b1df9304cc7e0a89d5539d900739.tar.bz2
python-imaging: recompile
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python-imaging/PKGBUILD42
-rw-r--r--abs/core/python_modules/python-imaging/__changelog2
2 files changed, 44 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-imaging/PKGBUILD b/abs/core/python_modules/python-imaging/PKGBUILD
new file mode 100644
index 0000000..f0b5f3a
--- /dev/null
+++ b/abs/core/python_modules/python-imaging/PKGBUILD
@@ -0,0 +1,42 @@
+# $Id: PKGBUILD 87626 2010-08-17 13:21:07Z allan $
+# Maintainer: Allan McRae <allan@archlinux.org>
+# Contributor: simo <simo@archlinux.org>
+
+pkgname=python-imaging
+pkgver=1.1.7
+pkgrel=5
+pkgdesc="PIL. Provides image processing capabilities for python"
+arch=('i686' 'x86_64')
+url="http://www.pythonware.com/products/pil/index.htm"
+license=('custom:"pil"')
+depends=('python2' 'libjpeg' 'freetype2')
+makedepends=('tk')
+optdepends=('tk')
+provides=("pil=$pkgver")
+conflicts=('pil')
+replaces=('pil')
+source=(http://effbot.org/downloads/Imaging-$pkgver.tar.gz)
+md5sums=('fc14a54e1ce02a0225be8854bfba478e')
+
+build() {
+ cd $srcdir/Imaging-$pkgver
+ sed -i "s#JPEG_ROOT\ =\ None#JPEG_ROOT\ =\ \"/opt/libjpeg6/lib\",\ \"/opt/libjpeg6/include\"#" setup.py
+ python2 setup.py build_ext
+}
+
+package() {
+ cd $srcdir/Imaging-$pkgver
+ python2 setup.py install --root=$pkgdir
+ install -dm755 $pkgdir/usr/include/python2.7/
+ install -m644 -t $pkgdir/usr/include/python2.7/ libImaging/*.h
+
+ # do not have files ending in .py in /usr/bin
+ for f in pildriver pilprint pilconvert pilfile pilfont; do
+ mv $pkgdir/usr/bin/$f{.py,}
+ done
+
+ # Install license
+ install -Dm644 $srcdir/Imaging-$pkgver/README \
+ $pkgdir/usr/share/licenses/$pkgname/README
+}
+
diff --git a/abs/core/python_modules/python-imaging/__changelog b/abs/core/python_modules/python-imaging/__changelog
new file mode 100644
index 0000000..91214ed
--- /dev/null
+++ b/abs/core/python_modules/python-imaging/__changelog
@@ -0,0 +1,2 @@
+__change so that it builds against libjpeg6 and not libjpeg7
+ sed -i "s#JPEG_ROOT\ =\ None#JPEG_ROOT\ =\ \"/opt/libjpeg6\"#" setup.py