summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-12-09 23:58:55 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-12-09 23:58:55 (GMT)
commitf28addfb7aa9eabf3a93d8a034abae0af4a34669 (patch)
tree9dacfe25bf0962fedabe78b09c1bb0d2c20dca75 /abs/core/python_modules
parente65f0abdbc263cb8fa5d367f0999fbb8776e3972 (diff)
downloadlinhes_pkgbuild-f28addfb7aa9eabf3a93d8a034abae0af4a34669.zip
linhes_pkgbuild-f28addfb7aa9eabf3a93d8a034abae0af4a34669.tar.gz
linhes_pkgbuild-f28addfb7aa9eabf3a93d8a034abae0af4a34669.tar.bz2
python-parted: recompile
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python-parted/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-parted/PKGBUILD b/abs/core/python_modules/python-parted/PKGBUILD
new file mode 100644
index 0000000..862405c
--- /dev/null
+++ b/abs/core/python_modules/python-parted/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=python-parted
+__pkgname=pyparted
+pkgver=2.0.12
+pkgver=3.4
+pkgrel=4
+pkgdesc="Python bindings for libparted"
+arch=('i686' 'x86_64')
+license=('LGPL' 'MPL')
+depends=('python2' 'parted' 'python-decorator')
+options=('!libtool')
+source=(https://fedorahosted.org/releases/p/y/pyparted/pyparted-${pkgver}.tar.gz)
+url="https://fedorahosted.org/pyparted/"
+
+build() {
+ cd "${srcdir}/${__pkgname}-${pkgver}"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+package(){
+ cd "${srcdir}/${__pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+md5sums=('8fc485db0b88e59bbdfc4be8ba4068fa')
+md5sums=('cc064f12110a6f0d0c236ee7b18fee88')
+md5sums=('f244958142c9fd3ff5ee95f578e2f76d')
+md5sums=('7f5d06bd6336f3a699840d8639ab8a0d')
+md5sums=('f244958142c9fd3ff5ee95f578e2f76d')
+md5sums=('cc064f12110a6f0d0c236ee7b18fee88')