summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-12-09 23:58:24 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-12-09 23:58:24 (GMT)
commit1010c1a9d0b7e82f726e5a8c1c5c7a78bc20b8cb (patch)
tree88c6596a16442b7f38d21843724ee9b182b9c29c /abs/core/python_modules
parent4028df9e28e491e273c7a837028272e981397be2 (diff)
downloadlinhes_pkgbuild-1010c1a9d0b7e82f726e5a8c1c5c7a78bc20b8cb.zip
linhes_pkgbuild-1010c1a9d0b7e82f726e5a8c1c5c7a78bc20b8cb.tar.gz
linhes_pkgbuild-1010c1a9d0b7e82f726e5a8c1c5c7a78bc20b8cb.tar.bz2
python-netifaces: recompile
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python-netifaces/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-netifaces/PKGBUILD b/abs/core/python_modules/python-netifaces/PKGBUILD
new file mode 100644
index 0000000..258a9c2
--- /dev/null
+++ b/abs/core/python_modules/python-netifaces/PKGBUILD
@@ -0,0 +1,24 @@
+#Maintainer: Gergely Imreh <imrehg(at)gmail(dot)com>
+#Contributor: Gergely Imreh <imrehg(at)gmail(dot)com>
+pkgname=python-netifaces
+_orig_name=netifaces
+pkgver=0.5
+pkgrel=3
+pkgdesc="Portable module to access network interface information in Python."
+depends=('python2')
+makedepend=('gcc')
+arch=('i686' 'x86_64')
+url="http://alastairs-place.net/netifaces/"
+license=('MIT')
+provides=('netifaces' 'python-netifaces')
+source=("http://alastairs-place.net/2007/03/netifaces/${_orig_name}-${pkgver}.tar.gz")
+build() {
+ cd "${srcdir}/${_orig_name}-${pkgver}"
+ python2 setup.py install --root "${pkgdir}" || return 1
+
+ # Install license, that is inside the readme file
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 README "${pkgdir}/usr/share/licenses/${pkgname}/README" || return 1
+}
+md5sums=('ea662a4b4c7db5d1631cc33bf68eb030')
+