summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-12-09 23:55:45 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-12-09 23:55:45 (GMT)
commit700c5f9a274d1a685c7f516cd132f672f1f93f77 (patch)
tree52cae3e7fbb406e5a7726514a72cabdc39c3bb9c /abs/core/python_modules
parentecc694a641ad5fa450c09c8d67858186a6458879 (diff)
downloadlinhes_pkgbuild-700c5f9a274d1a685c7f516cd132f672f1f93f77.zip
linhes_pkgbuild-700c5f9a274d1a685c7f516cd132f672f1f93f77.tar.gz
linhes_pkgbuild-700c5f9a274d1a685c7f516cd132f672f1f93f77.tar.bz2
python-beaker: recompile
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python-beaker/PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-beaker/PKGBUILD b/abs/core/python_modules/python-beaker/PKGBUILD
new file mode 100644
index 0000000..8780497
--- /dev/null
+++ b/abs/core/python_modules/python-beaker/PKGBUILD
@@ -0,0 +1,21 @@
+# $Id: PKGBUILD 87715 2010-08-18 03:37:40Z allan $
+# Maintainer : Ionut Biru <ibiru@archlinux.org>
+# Contributor: Massimiliano Torromeo < massimiliano DOT torromeo AT gmail DOT com >
+pkgname=python-beaker
+pkgver=1.5.4
+pkgrel=3
+arch=('any')
+license=('custom')
+pkgdesc="Caching and sessions WSGI middleware for use with web applications and stand-alone Python scripts and applications"
+url="http://beaker.groovie.org/"
+depends=('python2')
+makedepends=('setuptools')
+source=("http://cheeseshop.python.org/packages/source/B/Beaker/Beaker-$pkgver.tar.gz")
+md5sums=('de84e7511119dc0b8eb4ac177d3e2512')
+
+build() {
+ cd ${srcdir}/Beaker-${pkgver}
+ sed -i "s#/usr/bin/python#/usr/bin/python2#" beaker/crypto/pbkdf2.py
+ python2 setup.py install --root=${pkgdir} --optimize=1
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/$pkgname/LICENSE
+}