summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-07-16 04:14:58 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-07-16 04:14:58 (GMT)
commitb393d6fd2288b3a35480234c29a6e3939194a6a5 (patch)
tree7d4666afe5ecb576147fa584ad8851c8e2f20f9d /abs/core/python_modules
parentfe4647560ee433d6735ebe84b584d5faf1865809 (diff)
downloadlinhes_pkgbuild-b393d6fd2288b3a35480234c29a6e3939194a6a5.zip
linhes_pkgbuild-b393d6fd2288b3a35480234c29a6e3939194a6a5.tar.gz
linhes_pkgbuild-b393d6fd2288b3a35480234c29a6e3939194a6a5.tar.bz2
python2-ndg-httpsclient: initial inclusion. dep of flexget
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python-ndg-httpsclient/PKGBUILD48
-rw-r--r--abs/core/python_modules/python-ndg-httpsclient/__changelog2
2 files changed, 50 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-ndg-httpsclient/PKGBUILD b/abs/core/python_modules/python-ndg-httpsclient/PKGBUILD
new file mode 100644
index 0000000..7b0047f
--- /dev/null
+++ b/abs/core/python_modules/python-ndg-httpsclient/PKGBUILD
@@ -0,0 +1,48 @@
+# $Id: PKGBUILD 134777 2015-06-04 13:33:01Z mtorromeo $
+# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+# Contributor: Hugo Osvaldo Barrera <hugo@osvaldobarrera.com.ar>
+
+pkgbase=python-ndg-httpsclient
+pkgname=(python2-ndg-httpsclient)
+_pkgname=ndg_httpsclient
+pkgver=0.4.2
+pkgrel=2
+pkgdesc="Provides enhanced HTTPS support for httplib and urllib2 using PyOpenSSL"
+arch=(any)
+url="https://pypi.python.org/pypi/ndg-httpsclient"
+license=('BSD')
+makedepends=(python2-setuptools python2-pyopenssl python2-pyasn1)
+options=(!emptydirs)
+source=(https://files.pythonhosted.org/packages/source/n/ndg-httpsclient/$_pkgname-$pkgver.tar.gz)
+sha256sums=('580987ef194334c50389e0d7de885fccf15605c13c6eecaabd8d6c43768eb8ac')
+
+build() {
+ cd "$srcdir"/$_pkgname-$pkgver
+
+# rm -rf ../buildpy3; mkdir ../buildpy3
+# python setup.py build -b ../buildpy3
+
+ rm -rf ../buildpy2; mkdir ../buildpy2
+ python2 setup.py build -b ../buildpy2
+}
+
+package_python-ndg-httpsclient() {
+ depends=(python-pyopenssl python-pyasn1)
+ _site_packages=$(python -sSc 'import site; print(site.getsitepackages()[0])')
+
+ cd "$srcdir"/$_pkgname-$pkgver
+ rm -rf build; ln -s ../buildpy3 build
+ python setup.py install --skip-build -O1 --root="$pkgdir"
+ install -Dm0644 "$pkgdir$_site_packages"/ndg/httpsclient/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+package_python2-ndg-httpsclient() {
+ depends=(python2-pyopenssl python2-pyasn1)
+ _site_packages=$(python2 -sSc 'import site; print(site.getsitepackages()[0])')
+
+ cd "$srcdir"/$_pkgname-$pkgver
+ rm -rf build; ln -s ../buildpy2 build
+ python2 setup.py install --skip-build -O1 --root="$pkgdir"
+ install -Dm0644 "$pkgdir$_site_packages"/ndg/httpsclient/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ mv "$pkgdir"/usr/bin/ndg_httpclient{,2}
+}
diff --git a/abs/core/python_modules/python-ndg-httpsclient/__changelog b/abs/core/python_modules/python-ndg-httpsclient/__changelog
new file mode 100644
index 0000000..4f818ef
--- /dev/null
+++ b/abs/core/python_modules/python-ndg-httpsclient/__changelog
@@ -0,0 +1,2 @@
+PKGBUILD: don't build py 3 stuff
+