summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-15 16:06:42 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-15 16:06:42 (GMT)
commited6f98d16de03a1a6511cf7cb12f5dbf0c9220e0 (patch)
tree573158032e117f45e489a894c42617896eb22b3f /abs/core/python_modules
parentfe739ba880e1fa2f54451a1053d59df031e22ee1 (diff)
downloadlinhes_pkgbuild-ed6f98d16de03a1a6511cf7cb12f5dbf0c9220e0.zip
linhes_pkgbuild-ed6f98d16de03a1a6511cf7cb12f5dbf0c9220e0.tar.gz
linhes_pkgbuild-ed6f98d16de03a1a6511cf7cb12f5dbf0c9220e0.tar.bz2
python_modules: updated several modules
python-notify python-pysqlite python_aosd pywebkitgtk
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python-notify/PKGBUILD27
-rw-r--r--abs/core/python_modules/python-notify/libnotify07.patch36
-rw-r--r--abs/core/python_modules/python-notify/notify-python-0.1.1-fix-GTK-symbols.patch25
-rw-r--r--abs/core/python_modules/python-pysqlite/ChangeLog3
-rw-r--r--abs/core/python_modules/python-pysqlite/PKGBUILD23
-rw-r--r--abs/core/python_modules/python_aosd/PKGBUILD2
-rw-r--r--abs/core/python_modules/pywebkitgtk/PKGBUILD22
7 files changed, 110 insertions, 28 deletions
diff --git a/abs/core/python_modules/python-notify/PKGBUILD b/abs/core/python_modules/python-notify/PKGBUILD
index 47c25e5..ad9a615 100644
--- a/abs/core/python_modules/python-notify/PKGBUILD
+++ b/abs/core/python_modules/python-notify/PKGBUILD
@@ -1,25 +1,38 @@
-# $Id: PKGBUILD 82 2009-07-17 19:56:55Z aaron $
+# $Id: PKGBUILD 148890 2012-02-05 11:54:24Z ibiru $
+# Maintainer: Angel Velasquez <angvp@archlinux.org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Roman Kyrylych <Roman.Kyrylych@gmail.com>
# Contributor: Mario Danic <mario.danic@gmail.com>
-# Maintainer: Daniel J Griffiths <ghost1227@archlinux.us>
-
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=python-notify
pkgver=0.1.1
-pkgrel=8
+pkgrel=11
pkgdesc="Python bindings for libnotify"
arch=('i686' 'x86_64')
url="http://www.galago-project.org/"
license=('GPL')
-depends=('pygtk>=2.22.0' 'libnotify>=0.4.5')
+depends=('pygtk>=2.22.0' 'libnotify>=0.7.1')
makedepends=('pkgconfig' 'python2')
options=(!libtool)
-source=(http://www.galago-project.org/files/releases/source/notify-python/notify-python-${pkgver}.tar.gz)
-md5sums=('8f0ef0939cc8edd2efd896ce5ba80cf4')
+source=(http://www.galago-project.org/files/releases/source/notify-python/notify-python-${pkgver}.tar.gz
+ libnotify07.patch
+ notify-python-0.1.1-fix-GTK-symbols.patch)
+md5sums=('8f0ef0939cc8edd2efd896ce5ba80cf4'
+ 'b40c4542575d5aef559908fe60a21634'
+ 'c6922028da5951e69a6a0167bdb4461c')
build() {
cd ${srcdir}/notify-python-${pkgver}
+
+ patch -Np1 -i ${srcdir}/libnotify07.patch
+ patch -Np1 -i ${srcdir}/notify-python-0.1.1-fix-GTK-symbols.patch
+
./configure --prefix=/usr
+
+ # WARNING - we touch src/pynotify.override in build because upstream did not rebuild pynotify.c
+ # from the input definitions, this forces pynotify.c to be regenerated, at some point this can be removed
+ touch src/pynotify.override
+
make clean
make
}
diff --git a/abs/core/python_modules/python-notify/libnotify07.patch b/abs/core/python_modules/python-notify/libnotify07.patch
new file mode 100644
index 0000000..289573d
--- /dev/null
+++ b/abs/core/python_modules/python-notify/libnotify07.patch
@@ -0,0 +1,36 @@
+diff -up notify-python-0.1.1/src/pynotify.defs.notify070 notify-python-0.1.1/src/pynotify.defs
+--- notify-python-0.1.1/src/pynotify.defs.notify070 2010-11-02 17:11:14.928179237 -0400
++++ notify-python-0.1.1/src/pynotify.defs 2010-11-02 17:11:51.153180231 -0400
+@@ -38,7 +38,6 @@
+ '("const-gchar*" "summary")
+ '("const-gchar*" "message" (null-ok) (default "NULL"))
+ '("const-gchar*" "icon" (null-ok) (default "NULL"))
+- '("GtkWidget*" "attach" (null-ok) (default "NULL"))
+ )
+ )
+
+@@ -53,24 +52,6 @@
+ )
+ )
+
+-(define-method attach_to_widget
+- (of-object "NotifyNotification")
+- (c-name "notify_notification_attach_to_widget")
+- (return-type "none")
+- (parameters
+- '("GtkWidget*" "attach")
+- )
+-)
+-
+-(define-method attach_to_status_icon
+- (of-object "NotifyNotification")
+- (c-name "notify_notification_attach_to_status_icon")
+- (return-type "none")
+- (parameters
+- '("GtkStatusIcon*" "attach")
+- )
+-)
+-
+ (define-method show
+ (of-object "NotifyNotification")
+ (c-name "notify_notification_show")
diff --git a/abs/core/python_modules/python-notify/notify-python-0.1.1-fix-GTK-symbols.patch b/abs/core/python_modules/python-notify/notify-python-0.1.1-fix-GTK-symbols.patch
new file mode 100644
index 0000000..f985c01
--- /dev/null
+++ b/abs/core/python_modules/python-notify/notify-python-0.1.1-fix-GTK-symbols.patch
@@ -0,0 +1,25 @@
+diff -up notify-python-0.1.1/src/__init__.py.BAD notify-python-0.1.1/src/__init__.py
+--- notify-python-0.1.1/src/__init__.py.BAD 2010-08-31 09:04:45.353844005 -0400
++++ notify-python-0.1.1/src/__init__.py 2010-08-31 09:04:49.281844300 -0400
+@@ -1 +1,21 @@
++"""
++Fedora's libnotify.so is not linked against GTK2 or GTK3. The idea
++was to support being linked against different parallel-installable
++GTK stacks.
++
++Unfortunately, python needs to jump through some special hoops in order
++to share symbols with extension modules, specifically, pygtk, which does
++link against GTK2.
++
++Without using sys.setdlopenflags(sys.getdlopenflags() | ctypes.RTLD_GLOBAL),
++the result is:
++libnotify-WARNING **: Missing symbol 'gdk_screen_make_display_name'
++
++Thanks to David Malcolm for figuring out the workaround.
++"""
++import ctypes
++import sys
++sys.setdlopenflags(sys.getdlopenflags() | ctypes.RTLD_GLOBAL)
++import gtk
++
+ from _pynotify import *
diff --git a/abs/core/python_modules/python-pysqlite/ChangeLog b/abs/core/python_modules/python-pysqlite/ChangeLog
index 12c0ad0..2f42c5d 100644
--- a/abs/core/python_modules/python-pysqlite/ChangeLog
+++ b/abs/core/python_modules/python-pysqlite/ChangeLog
@@ -1,3 +1,6 @@
+2011-10-07 Angel Velasquez <angvp@archlinux.org>
+ * Updated to: 2.6.3
+ * Added check function
2009-08-06 Douglas Soares de Andrade <douglas@archlinux.org>
diff --git a/abs/core/python_modules/python-pysqlite/PKGBUILD b/abs/core/python_modules/python-pysqlite/PKGBUILD
index 4a45ba5..0302233 100644
--- a/abs/core/python_modules/python-pysqlite/PKGBUILD
+++ b/abs/core/python_modules/python-pysqlite/PKGBUILD
@@ -1,21 +1,26 @@
-# $Id: PKGBUILD 89652 2010-09-02 20:47:02Z remy $
+# $Id: PKGBUILD 155872 2012-04-08 07:25:46Z remy $
+# Maintainer: Angel Velasquez <angvp@archlinux.org>
# Contributor: Aaron Griffin <aaron@archlinux.org>
-# Contributor: Aaron Griffin <aaron@archlinux.org>
-# Maintainer: Daniel J Griffiths <ghost1227@archlinux.us>
-
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=python-pysqlite
-pkgver=2.6.0
-pkgrel=3
+pkgver=2.6.3
+pkgrel=2
pkgdesc="A Python DB-API 2.0 interface for the SQLite embedded relational database engine"
license=('custom')
arch=('i686' 'x86_64')
url="http://code.google.com/p/pysqlite/"
-depends=('python2' 'sqlite3')
+depends=('python2' 'sqlite')
replaces=('pysqlite2')
source=(http://pysqlite.googlecode.com/files/pysqlite-${pkgver}.tar.gz \
setup.cfg)
-md5sums=('fc92618b3b39d02e6ff10dc467c36640'
- '86dd356c65afd14a22f2f8f64a26441e')
+md5sums=('711afa1062a1d2c4a67acdf02a33d86e'
+ '86dd356c65afd14a22f2f8f64a26441e')
+
+check() {
+ cd ${pkgdir}/usr/lib/python2.7/site-packages
+ python2 -c "from pysqlite2 import test; test.test()"
+}
+
build() {
cd ${srcdir}/pysqlite-${pkgver}
cp ${srcdir}/setup.cfg .
diff --git a/abs/core/python_modules/python_aosd/PKGBUILD b/abs/core/python_modules/python_aosd/PKGBUILD
index 35af3d7..309aca6 100644
--- a/abs/core/python_modules/python_aosd/PKGBUILD
+++ b/abs/core/python_modules/python_aosd/PKGBUILD
@@ -5,7 +5,7 @@ pkgdesc="Python binding for libaosd_ an on screen display (OSD) library"
arch=(any)
url="http://code.google.com/p/python-aosd/"
license=('GPL')
-depends=('python2' 'cython2' 'libaosd' 'pyrex' 'pycairo')
+depends=('python2' 'cython2' 'libaosd' 'pyrex' 'python2-cairo')
source=(http://python-aosd.googlecode.com/files/python-aosd-${pkgver}.tar.gz)
build() {
diff --git a/abs/core/python_modules/pywebkitgtk/PKGBUILD b/abs/core/python_modules/pywebkitgtk/PKGBUILD
index 6f56900..9fec0ff 100644
--- a/abs/core/python_modules/pywebkitgtk/PKGBUILD
+++ b/abs/core/python_modules/pywebkitgtk/PKGBUILD
@@ -1,9 +1,11 @@
+# $Id: PKGBUILD 148894 2012-02-05 11:54:35Z ibiru $
+# Maintainer: Angel Velasquez <angvp@archlinux.org>
# Contributor: kasa <biuta.jr@gmail.com>
-# Maintainer: Daniel J Griffiths <ghost1227@archlinux.us>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=pywebkitgtk
-pkgver=1.1.7
-pkgrel=4
+pkgver=1.1.8
+pkgrel=2
pkgdesc="Python bindings to the WebKit GTK+ port"
arch=('i686' 'x86_64')
url="http://code.google.com/p/pywebkitgtk/"
@@ -11,17 +13,15 @@ license=('LGPL')
depends=('libwebkit' 'pygtk')
options=('!libtool' '!makeflags')
source=(http://pywebkitgtk.googlecode.com/files/${pkgname}-${pkgver}.tar.gz)
-md5sums=('4dbe0111c0b0ad2280052e4534903a9b')
+md5sums=('158335385354ba38090c9324b37bf225')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
-
- ./configure --prefix=/usr
- make
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
-
- make DESTDIR=${pkgdir} install
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
}