summaryrefslogtreecommitdiffstats
path: root/abs/core/runit-scripts/fbsplash-runit.sh
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2011-10-19 18:31:38 (GMT)
committerJames Meyer <james.meyer@operamail.com>2011-10-19 18:31:38 (GMT)
commitd9aad8b00a9f3fb60e456c0e528df90189acb5b3 (patch)
tree6b9126d2336c62d1e5533798e7348f6a5723f6ba /abs/core/runit-scripts/fbsplash-runit.sh
parentd9a08ac22f9c6661cf3b478927be321274d10794 (diff)
parentc65b741914b31ac88086e363edc4415eb6aa1686 (diff)
downloadlinhes_pkgbuild-d9aad8b00a9f3fb60e456c0e528df90189acb5b3.zip
linhes_pkgbuild-d9aad8b00a9f3fb60e456c0e528df90189acb5b3.tar.gz
linhes_pkgbuild-d9aad8b00a9f3fb60e456c0e528df90189acb5b3.tar.bz2
Merge remote-tracking branch 'origin/testing' into testing
Conflicts: abs/core/LinHES-config/PKGBUILD
Diffstat (limited to 'abs/core/runit-scripts/fbsplash-runit.sh')
-rwxr-xr-xabs/core/runit-scripts/fbsplash-runit.sh55
1 files changed, 24 insertions, 31 deletions
diff --git a/abs/core/runit-scripts/fbsplash-runit.sh b/abs/core/runit-scripts/fbsplash-runit.sh
index a9432d0..87435ee 100755
--- a/abs/core/runit-scripts/fbsplash-runit.sh
+++ b/abs/core/runit-scripts/fbsplash-runit.sh
@@ -1,44 +1,37 @@
-# fbsplash function.d script #
-# Author: Greg Helton <gt@fallendusk.org> #
+# fbsplash functions.d runit script #
-# Who is calling? #
-CALLER=$0
printhlr() {
printf "${C_OTHER}${PREFIX_REG} ${C_H1}${1}${C_CLEAR} \n"
}
+stat_runit(){
+ printf ""
+ printhlr "${C_MAIN}${1}${C_CLEAR} "
+}
+
+
# splash stuff #
-if [ -e /etc/conf.d/fbsplash.conf ]
+if [ -e /etc/conf.d/fbcondecor ]
then
- . /etc/conf.d/fbsplash.conf
+ . /etc/conf.d/fbcondecor
. /sbin/splash-functions.sh
-# Redefine the stat functions #
-
- stat_runit() {
- # printf "${C_OTHER}${PREFIX_REG} ${C_MAIN}${1}${C_CLEAR} "
- # printf "${SAVE_POSITION}"
- # deltext
- # printf " ${C_OTHER}[${C_BUSY}BKGD${C_OTHER}]${C_CLEAR} "a
-
- printf ""
- printhlr "${C_MAIN}${1}${C_CLEAR} "
-
- # Load variables #
+ case $0 in /etc/runit/1 )
+ # Prevent splash destruction
+ CONSOLEFONT=""
+ # Continue to use a splash daemon started in initcpio
+ if /bin/mountpoint -q /run/.splash-cache; then
+ /bin/mount --move /run/.splash-cache $spl_cachedir || return
+ # Mount a tmpfs
+ else
+ ( splash_cache_prep ) || return
+ fi
- var_load STEP_NR MAX_STEPS RC_MULTI RC_SYSINIT RC_SHUTDOWN
- # Only update the splash progress if we're in sysinit, multi, or shutdown. #
+ splash_comm_send set message "$SPLASH_BOOT_MESSAGE"
- ((SPLASH_STEP_NR++))
- SPLASH_PROGRESS=$((100*${SPLASH_STEP_NR}/${SPLASH_MAX_STEPS}))
- SPLASH_CURRENT_PROGRESS=${SPLASH_PROGRESS}
- splash_update_progress ${SPLASH_PROGRESS}
- var_save STEP_NR CURRENT_PROGRESS
+ ;; /etc/runit/3 )
+ ( splash_cache_prep ) || return
- }
-else
- stat_runit(){
- printf ""
- printhlr "${C_MAIN}${1}${C_CLEAR} "
- }
+ splash_comm_send set message "$SPLASH_SHUTDOWN_MESSAGE"
+ esac
fi