summaryrefslogtreecommitdiffstats
path: root/abs/core/tdb/PKGBUILD
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-08-03 23:14:05 (GMT)
committerCecil <knoppmyth@gmail.com>2011-08-03 23:14:05 (GMT)
commit998faf16b1b62493b39aa13b3cb53dfac266ef4c (patch)
treee39f222ebd2e5ca78211045d1d12ccc02f8c5516 /abs/core/tdb/PKGBUILD
parent085e16d501ac72951e7455385cc8af7e90fa02cb (diff)
parenta9c47f145393b31d7f656b14a2952ab6fc6fec58 (diff)
downloadlinhes_pkgbuild-998faf16b1b62493b39aa13b3cb53dfac266ef4c.zip
linhes_pkgbuild-998faf16b1b62493b39aa13b3cb53dfac266ef4c.tar.gz
linhes_pkgbuild-998faf16b1b62493b39aa13b3cb53dfac266ef4c.tar.bz2
Merge branch 'testing' of ssh://cesman@linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/core/tdb/PKGBUILD')
-rw-r--r--abs/core/tdb/PKGBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/abs/core/tdb/PKGBUILD b/abs/core/tdb/PKGBUILD
index 44f1e69..ffa330b 100644
--- a/abs/core/tdb/PKGBUILD
+++ b/abs/core/tdb/PKGBUILD
@@ -1,11 +1,11 @@
-# $Id: PKGBUILD 89866 2010-09-04 14:37:32Z remy $
+# $Id: PKGBUILD 116933 2011-03-26 14:55:24Z tpowa $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
-# Contributorr: eric <eric@archlinux.org>
+# Contributor: eric <eric@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
pkgname=tdb
-pkgver=1.2.1
-pkgrel=3
+pkgver=1.2.9
+pkgrel=1
pkgdesc="A Trivia Database similar to GDBM but allows simultaneous commits"
arch=(i686 x86_64)
license=('GPL3')
@@ -13,23 +13,23 @@ url="http://tdb.samba.org/"
source=(http://samba.org/ftp/${pkgname}/${pkgname}-${pkgver}.tar.gz)
makedepends=('python2' 'libxslt' 'docbook-xsl')
optdepends=('python2: for python bindings')
-options=(force)
+epoch=1
build() {
cd ${srcdir}/${pkgname}-${pkgver}
- sed -i 's#python2\.6\([^ ]*\)#python2.7\1 python2.6\1#' configure
+ sed -i -e 's#python#python2#g' buildtools/bin/waf
+ #sed -i 's#python2\.6\([^ ]*\)#python2.7\1 python2.6\1#' configure
# Use system docbook.xsl
- _manstyle="/usr/share/xml/docbook/xsl-stylesheets-1.76.0/manpages/docbook.xsl"
- sed -i "s#http.*xsl#$_manstyle#" tdb.mk
-
+ #_manstyle="/usr/share/xml/docbook/xsl-stylesheets-1.76.1/manpages/docbook.xsl"
+ #sed -i "s#http.*xsl#$_manstyle#" tdb.mk
./configure --prefix=/usr \
--localstatedir=/var \
--sysconfdir=/etc/samba
- make || return 1
+ make
}
+
package() {
cd ${srcdir}/${pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install
+ make DESTDIR=$pkgdir/ install
}
-md5sums=('73ea81282a82e5c959d9c082af2d0215')
-
+md5sums=('4d97d18bbe9040038d4e003495bb8cd1')