summaryrefslogtreecommitdiffstats
path: root/abs/core/wget/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hanson <mihanson@linhes.org>2011-10-08 00:48:25 (GMT)
committerMichael Hanson <mihanson@linhes.org>2011-10-08 00:48:25 (GMT)
commitee019be570e80f20f106a6b0b739be427c5f89bc (patch)
tree47c56548770be52fc9a600f28eb4935844820f5b /abs/core/wget/PKGBUILD
parentf37574bd879953f9c2c1ee1dc97577d804759895 (diff)
parent04949a18e6ea4a313d101911dcdc689d029ddcb1 (diff)
downloadlinhes_pkgbuild-ee019be570e80f20f106a6b0b739be427c5f89bc.zip
linhes_pkgbuild-ee019be570e80f20f106a6b0b739be427c5f89bc.tar.gz
linhes_pkgbuild-ee019be570e80f20f106a6b0b739be427c5f89bc.tar.bz2
Merge branch 'testing' of knoppmyth.net:linhes_pkgbuild into testing
Diffstat (limited to 'abs/core/wget/PKGBUILD')
-rw-r--r--abs/core/wget/PKGBUILD36
1 files changed, 26 insertions, 10 deletions
diff --git a/abs/core/wget/PKGBUILD b/abs/core/wget/PKGBUILD
index eb13f03..44a6477 100644
--- a/abs/core/wget/PKGBUILD
+++ b/abs/core/wget/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id: PKGBUILD 75183 2010-04-01 01:40:17Z pierre $
+# $Id$
# Maintainer: Allan McRae <allan@archlinux.org>
# Contributor: Judd Vinet <jvinet@zeroflux.org>
pkgname=wget
-pkgver=1.12
-pkgrel=3
+pkgver=1.13.4
+pkgrel=1
pkgdesc="A network utility to retrieve files from the Web"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/wget/wget.html"
@@ -14,16 +14,32 @@ depends=('glibc' 'openssl')
optdepends=('ca-certificates: HTTPS downloads')
backup=('etc/wgetrc')
install=wget.install
-source=(ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz)
-md5sums=('141461b9c04e454dc8933c9d1f2abf83')
+source=(ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz)
+md5sums=('7f518b3a71e9efd330e9a0c3714f8463')
build() {
- cd ${srcdir}/$pkgname-$pkgver
- ./configure --prefix=/usr --sysconfdir=/etc
- make || return 1
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # Note : We do not build with --enable-nls, because there is a bug in wget causing
+ # international domain names to be not properly converted to punycode if
+ # the current locale is a UTF-8 one
+ # See : http://lists.gnu.org/archive/html/bug-wget/2011-02/msg00026.html
+
+ ./configure -with-ssl=openssl --prefix=/usr --sysconfdir=/etc
+ make
}
package() {
- cd ${srcdir}/$pkgname-$pkgver
- make DESTDIR=${pkgdir} install
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ cat >> "$pkgdir/etc/wgetrc" <<EOF
+
+# default root certs location
+ca_certificate=/etc/ssl/certs/ca-certificates.crt
+EOF
+
+ # remove IRI option from wgetrc as it does not work (see above)
+ sed -i '118,120d' $pkgdir/etc/wgetrc
+
}