summaryrefslogtreecommitdiffstats
path: root/abs/core/windowmaker-crm-git/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-09 01:43:59 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-09 01:43:59 (GMT)
commit6b218299785aedd78128a9c7831aff1a6eefdcb8 (patch)
tree79f48e3bac89f7120496e6b3021072212fa6a780 /abs/core/windowmaker-crm-git/PKGBUILD
parentf33c5716af099ce4d779cf67f65204f11b551ed6 (diff)
parente40ac065f9a09f99b37e898b8684d70a0984f399 (diff)
downloadlinhes_pkgbuild-6b218299785aedd78128a9c7831aff1a6eefdcb8.zip
linhes_pkgbuild-6b218299785aedd78128a9c7831aff1a6eefdcb8.tar.gz
linhes_pkgbuild-6b218299785aedd78128a9c7831aff1a6eefdcb8.tar.bz2
Merge branch 'testing' of knoppmyth.net:linhes_pkgbuild into testing
Diffstat (limited to 'abs/core/windowmaker-crm-git/PKGBUILD')
-rw-r--r--abs/core/windowmaker-crm-git/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/abs/core/windowmaker-crm-git/PKGBUILD b/abs/core/windowmaker-crm-git/PKGBUILD
new file mode 100644
index 0000000..6a47895
--- /dev/null
+++ b/abs/core/windowmaker-crm-git/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id: PKGBUILD 94218 2010-10-05 16:33:23Z daniel $
+# Maintainer: Daniel Isenmann <daniel@archlinux.org>
+
+pkgname=windowmaker-crm-git
+pkgver=20101005
+pkgrel=1
+pkgdesc="An X11 window manager with a NEXTSTEP look and feel - git version from Carlos R. Mafra"
+arch=(i686 x86_64)
+url="http://www.windowmaker.org"
+license=('GPL' 'custom')
+depends=('libxinerama' 'libxrandr' 'libpng' 'libxpm' 'libxft' 'libtiff>=3.9.1' 'giflib' 'libxmu')
+options=('!libtool')
+provides=('windowmaker')
+conflicts=('windowmaker')
+source=(ftp://ftp.archlinux.org/other/windowmaker/windowmaker-$pkgver.tar.gz wmaker.desktop)
+md5sums=('8cc7e736a8d7e446f696b80fc7dcb79c'
+ '2fba97bebfd691836b92b8f0db79ff13')
+
+build() {
+ cd $srcdir/windowmaker-$pkgver
+ [ -z "$LINGUAS" ] && export LINGUAS="`ls po/*.po | sed 's:po/\(.*\)\.po$:\1:'`"
+ ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc --enable-xinerama \
+ --with-nlsdir=/usr/share/locale --with-gnustepdir=/usr/lib/GNUstep \
+ --enable-usermenu --enable-modelock
+ make || return 1
+ make DESTDIR=$pkgdir install || return 1
+ install -D -m644 COPYING.WTFPL $pkgdir/usr/share/licenses/$pkgname/COPYING.WTFPL
+ install -D -m644 $srcdir/wmaker.desktop $pkgdir/usr/share/xsessions/wmaker.desktop
+}