summaryrefslogtreecommitdiffstats
path: root/abs/core/windowmaker/PKGBUILD
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2012-05-14 01:38:13 (GMT)
committerCecil <knoppmyth@gmail.com>2012-05-14 01:38:13 (GMT)
commit6fa6efd0975ac9e669ee73fe009c25fe739ac017 (patch)
treeb4e1cdb3e3001a1209fe932b2e26db33b0ed9120 /abs/core/windowmaker/PKGBUILD
parente465b073524b59ea2b795d525cf39675857cf2ee (diff)
parentc04f2dfff3a4abbe0e3b4a7247f0001f797b07ac (diff)
downloadlinhes_pkgbuild-6fa6efd0975ac9e669ee73fe009c25fe739ac017.zip
linhes_pkgbuild-6fa6efd0975ac9e669ee73fe009c25fe739ac017.tar.gz
linhes_pkgbuild-6fa6efd0975ac9e669ee73fe009c25fe739ac017.tar.bz2
Merge branch 'testing' of git@linhes.org:linhes_pkgbuild into testing
Diffstat (limited to 'abs/core/windowmaker/PKGBUILD')
-rw-r--r--abs/core/windowmaker/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/core/windowmaker/PKGBUILD b/abs/core/windowmaker/PKGBUILD
new file mode 100644
index 0000000..e9a9853
--- /dev/null
+++ b/abs/core/windowmaker/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 150208 2012-02-14 20:50:29Z daniel $
+# Maintainer: Daniel Isenmann <daniel@archlinux.org>
+# Contributor: Judd Vinet <jvinet@zeroflux.org>
+pkgname=windowmaker
+pkgver=0.95.2
+pkgrel=1
+pkgdesc="An X11 window manager with a NEXTSTEP look and feel"
+arch=(i686 x86_64)
+url="http://www.windowmaker.org/"
+license=('GPL' 'custom')
+depends=('libxinerama' 'libxrandr' 'libxmu' 'libpng' 'libxpm' 'libxft' 'libtiff' 'giflib')
+options=('!libtool')
+source=(http://windowmaker.org/pub/source/release/WindowMaker-$pkgver.tar.gz wmaker.desktop)
+md5sums=('ae62bad9c4dee504066e0f172b565ff0'
+ '2fba97bebfd691836b92b8f0db79ff13')
+
+build() {
+ cd $srcdir/WindowMaker-$pkgver
+ [ -z "$LINGUAS" ] && export LINGUAS="`ls po/*.po | sed 's:po/\(.*\)\.po$:\1:'`"
+ ./configure --prefix=/usr --sysconfdir=/etc --enable-xinerama \
+ --with-nlsdir=/usr/share/locale --with-gnustepdir=/usr/lib/GNUstep \
+ --enable-usermenu --enable-modelock --enable-xrandr
+ make
+}
+
+package() {
+ cd $srcdir/WindowMaker-$pkgver
+
+ make DESTDIR=$pkgdir install
+ install -D -m644 COPYING.WTFPL $pkgdir/usr/share/licenses/$pkgname/COPYING.WTFPL
+ install -D -m644 $srcdir/wmaker.desktop $pkgdir/usr/share/xsessions/wmaker.desktop
+}
+