summaryrefslogtreecommitdiffstats
path: root/abs/core/xf86-input-wacom
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-12-10 02:50:56 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-12-10 02:50:56 (GMT)
commitafb7b09fa3a85f4e3af6acd559274ef890d97184 (patch)
tree200be2f5c24819c8f5766517f7ea6fd62dba25b2 /abs/core/xf86-input-wacom
parent62cbfd9cdba8b98cdffed685b395c596e92ed8d6 (diff)
downloadlinhes_pkgbuild-afb7b09fa3a85f4e3af6acd559274ef890d97184.zip
linhes_pkgbuild-afb7b09fa3a85f4e3af6acd559274ef890d97184.tar.gz
linhes_pkgbuild-afb7b09fa3a85f4e3af6acd559274ef890d97184.tar.bz2
xf86-input-*: recompiling from local arch abs. Some removals as they do not exist in Arch anymore.
Diffstat (limited to 'abs/core/xf86-input-wacom')
-rw-r--r--abs/core/xf86-input-wacom/70-wacom.rules8
-rw-r--r--abs/core/xf86-input-wacom/PKGBUILD30
2 files changed, 38 insertions, 0 deletions
diff --git a/abs/core/xf86-input-wacom/70-wacom.rules b/abs/core/xf86-input-wacom/70-wacom.rules
new file mode 100644
index 0000000..67e5580
--- /dev/null
+++ b/abs/core/xf86-input-wacom/70-wacom.rules
@@ -0,0 +1,8 @@
+ACTION!="add|change", GOTO="wacom_end"
+
+# Match all wacom tablets with a serial ID starting with WACf
+ATTRS{id}=="WACf*" ENV{NAME}="Serial Wacom Tablet", ENV{SUBSYSTEM}="input", ENV{ID_INPUT}="1", ENV{ID_INPUT_TABLET}="1"
+ATTRS{id}=="FUJ*" ENV{NAME}="Serial Wacom Tablet", ENV{SUBSYSTEM}="input", ENV{ID_INPUT}="1", ENV{ID_INPUT_TABLET}="1"
+
+LABEL="wacom_end"
+
diff --git a/abs/core/xf86-input-wacom/PKGBUILD b/abs/core/xf86-input-wacom/PKGBUILD
new file mode 100644
index 0000000..5296159
--- /dev/null
+++ b/abs/core/xf86-input-wacom/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id: PKGBUILD 88601 2010-08-24 09:13:17Z jgc $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: M Rawash <mrawash@gmail.com>
+
+pkgname=xf86-input-wacom
+pkgver=0.10.8
+pkgrel=2
+pkgdesc="X.Org Wacom tablet driver"
+arch=('i686' 'x86_64')
+url="http://linuxwacom.sourceforge.net/"
+license=('GPL')
+backup=('etc/X11/xorg.conf.d/50-wacom.conf')
+depends=('libxi')
+makedepends=('xorg-server-devel' 'libxext' 'libxi')
+conflicts=('xorg-server<1.9.0')
+options=(!libtool)
+source=(http://downloads.sourceforge.net/project/linuxwacom/${pkgname}/${pkgname}-${pkgver}.tar.bz2
+ 70-wacom.rules)
+md5sums=('e2bcc125070a16a7e3608d074d5d27dc'
+ '4d3665bb2ef8a8190734640dffa4c6f7')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --with-xorg-conf-dir=/etc/X11/xorg.conf.d
+ make
+ make DESTDIR="${pkgdir}" install
+
+ install -m755 -d "${pkgdir}/lib/udev/rules.d"
+ install -m644 "${srcdir}/70-wacom.rules" "${pkgdir}/lib/udev/rules.d/"
+}