summaryrefslogtreecommitdiffstats
path: root/abs/core/zoneminder/run
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2011-10-19 18:31:38 (GMT)
committerJames Meyer <james.meyer@operamail.com>2011-10-19 18:31:38 (GMT)
commitd9aad8b00a9f3fb60e456c0e528df90189acb5b3 (patch)
tree6b9126d2336c62d1e5533798e7348f6a5723f6ba /abs/core/zoneminder/run
parentd9a08ac22f9c6661cf3b478927be321274d10794 (diff)
parentc65b741914b31ac88086e363edc4415eb6aa1686 (diff)
downloadlinhes_pkgbuild-d9aad8b00a9f3fb60e456c0e528df90189acb5b3.zip
linhes_pkgbuild-d9aad8b00a9f3fb60e456c0e528df90189acb5b3.tar.gz
linhes_pkgbuild-d9aad8b00a9f3fb60e456c0e528df90189acb5b3.tar.bz2
Merge remote-tracking branch 'origin/testing' into testing
Conflicts: abs/core/LinHES-config/PKGBUILD
Diffstat (limited to 'abs/core/zoneminder/run')
-rwxr-xr-xabs/core/zoneminder/run19
1 files changed, 17 insertions, 2 deletions
diff --git a/abs/core/zoneminder/run b/abs/core/zoneminder/run
index e458bc8..ce61c24 100755
--- a/abs/core/zoneminder/run
+++ b/abs/core/zoneminder/run
@@ -2,5 +2,20 @@
export TERM=linux
. /etc/rc.conf
. /etc/rc.d/functions
-stat_runit "Starting ZoneMinder"
-exec /etc/rc.d/zm start
+
+while true ; do
+ PID=`pidof -x zmdc.pl`
+ if test -n "$PID" ; then
+ sleep 60
+ continue
+ fi
+ stat_runit "Starting ZoneMinder"
+ /etc/rc.d/zm start
+ if test $? -ne 0 ; then
+ stat_fail
+ else
+ add_daemon zm
+ stat_done
+ fi
+ sleep 30
+done