summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2013-12-09 23:00:57 (GMT)
committerBritney Fransen <brfransen@gmail.com>2013-12-09 23:00:57 (GMT)
commitfc357b029363755a1a75e05700701265134e71d6 (patch)
tree3934ade5d8c8e32875cdc18cd536359de9c62532 /abs/core
parent23b63734b90bb8c37d88673383002cbd210cdc99 (diff)
parentefb028d99b56e06e48dfc3d762e9d699ee1f24b7 (diff)
downloadlinhes_pkgbuild-fc357b029363755a1a75e05700701265134e71d6.zip
linhes_pkgbuild-fc357b029363755a1a75e05700701265134e71d6.tar.gz
linhes_pkgbuild-fc357b029363755a1a75e05700701265134e71d6.tar.bz2
Merge branch 'testing' of linhes.org:linhes_pkgbuild into testing
Diffstat (limited to 'abs/core')
-rwxr-xr-xabs/core/LinHES-system/LinHES-session8
-rwxr-xr-xabs/core/LinHES-system/PKGBUILD4
-rwxr-xr-xabs/core/runit-scripts/PKGBUILD11
-rw-r--r--abs/core/runit-scripts/fbsplash-runit.sh37
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/cron/log/run2
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/frontend/log/run2
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/mpd/log/run5
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/mpd/run9
8 files changed, 69 insertions, 9 deletions
diff --git a/abs/core/LinHES-system/LinHES-session b/abs/core/LinHES-system/LinHES-session
index d7b70ea..c6d0b09 100755
--- a/abs/core/LinHES-system/LinHES-session
+++ b/abs/core/LinHES-system/LinHES-session
@@ -299,10 +299,16 @@ function start_myth() {
while [ $rc -ne 0 ]
do
msg "Waiting for connection to MythBackend"
+ sleep 6
/usr/LH/bin/be_check.py
rc=$?
- sleep 6
+ if [ $rc -eq 0 ]
+ then
+ msg "Successful Connection to MythBackend"
+ fi
done
+ sleep 3 #give time for MBE to be fully operational
+
fi
#continue on with starting mythtv
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index 406cc05..d400e6d 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-system
pkgver=8.1
-pkgrel=6
+pkgrel=7
arch=('i686' 'x86_64')
install=system.install
pkgdesc="Everything that makes LinHES an automated system"
@@ -75,7 +75,7 @@ package() {
}
-md5sums=('49e9847cedcf26a977d64fd44e460b11'
+md5sums=('7f5624a2d965a4cd3ed6a37ebee13fd9'
'de32a1c50101265dd7f6ca5037f7a26a'
'a875ee97f86e46f34a741c2bc455f894'
'76b2637cac0452b3acdbeeb4e8a5474b'
diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index 745edb3..1f1c12c 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
pkgver=8.1
-pkgrel=2
+pkgrel=3
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
@@ -10,7 +10,7 @@ conflicts=()
replaces=()
backup=('etc/runit/1.local' 'etc/runit/3.local')
install=runit.install
-source=()
+source=('fbsplash-runit.sh')
arch=('i686' 'x86_64')
build() {
@@ -24,11 +24,14 @@ package() {
install -d $pkgdir/etc/sv
install -d $pkgdir/sbin
install -d $pkgdir/etc/rc.d/functions.d
-
+
+ #this file contains the function runit-stat which is needed by the runit service scripts
+ install -m755 $srcdir/fbsplash-runit.sh $pkgdir/etc/rc.d/functions.d/fbsplash-runit.sh
+
install -m0700 1 2 3 1.local 3.local ctrlaltdel $pkgdir/etc/runit
install -m0755 reboot-runit halt-runit logger $pkgdir/sbin
rsync -a --exclude=.svn services/* $pkgdir/etc/sv
chmod -R 755 $pkgdir/etc/sv
chown -R root:root $pkgdir/etc/sv
}
-md5sums=()
+md5sums=('30b944b91aa1f57c5469c8bd210cb497')
diff --git a/abs/core/runit-scripts/fbsplash-runit.sh b/abs/core/runit-scripts/fbsplash-runit.sh
new file mode 100644
index 0000000..9fb9591
--- /dev/null
+++ b/abs/core/runit-scripts/fbsplash-runit.sh
@@ -0,0 +1,37 @@
+# fbsplash functions.d runit script #
+
+printhlr() {
+ printf "${C_OTHER}${PREFIX_REG} ${C_H1}${1}${C_CLEAR} \n"
+ }
+
+stat_runit(){
+ printf ""
+ printhlr "${C_MAIN}${1}${C_CLEAR} "
+}
+
+
+# splash stuff #
+if [ -e /etc/conf.d/fbcondecor ]
+then
+ . /etc/conf.d/fbcondecor
+ . /sbin/splash-functions.sh
+
+ case $0 in /etc/runit/1 )
+ # Prevent splash destruction
+ CONSOLEFONT=""
+ # Continue to use a splash daemon started in initcpio
+ if /bin/mountpoint -q /run/.splash-cache; then
+ /bin/mount --move /run/.splash-cache $spl_cachedir || return
+ # Mount a tmpfs
+ else
+ ( splash_cache_prep ) || return
+ fi
+
+ splash_comm_send set message "$SPLASH_BOOT_MESSAGE"
+
+ ;; /etc/runit/3 )
+ ( splash_cache_prep ) || return
+
+ splash_comm_send set message "$SPLASH_SHUTDOWN_MESSAGE"
+ esac
+fi
diff --git a/abs/core/runit-scripts/runitscripts/services/cron/log/run b/abs/core/runit-scripts/runitscripts/services/cron/log/run
index 9dd37e3..785d6c7 100755
--- a/abs/core/runit-scripts/runitscripts/services/cron/log/run
+++ b/abs/core/runit-scripts/runitscripts/services/cron/log/run
@@ -1,5 +1,5 @@
#!/bin/sh
exec 2>&1
. /etc/systemconfig
- /usr/bin/logger -p local6.info -t cron
+ /usr/bin/logger -t cron
diff --git a/abs/core/runit-scripts/runitscripts/services/frontend/log/run b/abs/core/runit-scripts/runitscripts/services/frontend/log/run
index 801eaf2..bd431b2 100755
--- a/abs/core/runit-scripts/runitscripts/services/frontend/log/run
+++ b/abs/core/runit-scripts/runitscripts/services/frontend/log/run
@@ -1,5 +1,5 @@
#!/bin/sh
exec 2>&1
. /etc/systemconfig
- /usr/bin/logger -p local6.info -t frontend
+ /usr/bin/logger -t frontend
diff --git a/abs/core/runit-scripts/runitscripts/services/mpd/log/run b/abs/core/runit-scripts/runitscripts/services/mpd/log/run
new file mode 100755
index 0000000..bc856fe
--- /dev/null
+++ b/abs/core/runit-scripts/runitscripts/services/mpd/log/run
@@ -0,0 +1,5 @@
+#!/bin/sh
+exec 2>&1
+. /etc/systemconfig
+ /usr/bin/logger -t mpd
+
diff --git a/abs/core/runit-scripts/runitscripts/services/mpd/run b/abs/core/runit-scripts/runitscripts/services/mpd/run
new file mode 100755
index 0000000..c4bd347
--- /dev/null
+++ b/abs/core/runit-scripts/runitscripts/services/mpd/run
@@ -0,0 +1,9 @@
+#!/bin/sh
+export TERM=linux
+. /etc/rc.conf
+. /etc/rc.d/functions
+stat_runit "Starting mpd"
+
+
+exec 2>&1
+exec /usr/bin/mpd --no-daemon --stdout 2>&1