summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-07-16 04:02:33 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-07-16 04:02:33 (GMT)
commit486cd93c48ef3a6bad3d6e2fe2b373ba264e3646 (patch)
treed9f302669fd8274e11ed3fdc36cb901bbb890656 /abs/core
parent1495d71d035815f3c126686ac5132125078f4899 (diff)
downloadlinhes_pkgbuild-486cd93c48ef3a6bad3d6e2fe2b373ba264e3646.zip
linhes_pkgbuild-486cd93c48ef3a6bad3d6e2fe2b373ba264e3646.tar.gz
linhes_pkgbuild-486cd93c48ef3a6bad3d6e2fe2b373ba264e3646.tar.bz2
python2-zxcvbn: initial inclusion. dep of flexget
Diffstat (limited to 'abs/core')
-rw-r--r--abs/core/python_modules/python2-zxcvbn/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/core/python_modules/python2-zxcvbn/PKGBUILD b/abs/core/python_modules/python2-zxcvbn/PKGBUILD
new file mode 100644
index 0000000..5b85cd8
--- /dev/null
+++ b/abs/core/python_modules/python2-zxcvbn/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Cedric Girard <girard.cedric@gmail.com>
+_pythonmod=zxcvbn-python
+pkgname=python2-zxcvbn
+pkgver=4.4.12
+pkgrel=1
+pkgdesc="Password strength estimator"
+arch=('any')
+url="http://pypi.python.org/pypi/${_pythonmod}"
+license=('Apache')
+depends=(
+ 'python2'
+ )
+makedepends=('python2-setuptools')
+source=("https://pypi.io/packages/source/${_pythonmod:0:1}/${_pythonmod}/${_pythonmod}-$pkgver.tar.gz")
+md5sums=('ca8e19e3ff37c16e88bd0f70e3fabdad')
+
+build() {
+ cd ${srcdir}/${_pythonmod}-$pkgver
+ python2 setup.py build
+}
+
+package() {
+ cd ${srcdir}/${_pythonmod}-$pkgver
+ python2 setup.py install --root=${pkgdir}
+}