summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-10-21 19:06:29 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-10-21 19:06:29 (GMT)
commit485c58c50fed5d253874b41f28f9ec75ff4f4910 (patch)
treea2de7078aed971f6a872cc7efa13e0d702e16b1e /abs/core
parent4d9e0928c1756fa28b62b29cc0d79f9fc1b953f8 (diff)
downloadlinhes_pkgbuild-485c58c50fed5d253874b41f28f9ec75ff4f4910.zip
linhes_pkgbuild-485c58c50fed5d253874b41f28f9ec75ff4f4910.tar.gz
linhes_pkgbuild-485c58c50fed5d253874b41f28f9ec75ff4f4910.tar.bz2
mythinstall & LinHES-config: remove miro
add webmin
Diffstat (limited to 'abs/core')
-rwxr-xr-xabs/core/LinHES-config/PKGBUILD6
-rwxr-xr-xabs/core/LinHES-config/mv_common.py1
-rwxr-xr-xabs/core/LinHES-config/mv_software.py1
-rwxr-xr-xabs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp137
-rwxr-xr-xabs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h14
-rwxr-xr-xabs/core/mythinstall/MythVantage-app/mythinstall/main.cpp4
-rw-r--r--abs/core/mythinstall/PKGBUILD2
7 files changed, 31 insertions, 134 deletions
diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index b389fb0..8ce1e97 100755
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=8.2
-pkgrel=13
+pkgrel=14
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
pkgdesc="Install and configure your system"
depends=('bc' 'libstatgrab' 'mysql-python' 'expect' 'curl' 'dnsutils' 'parted'
@@ -157,14 +157,14 @@ md5sums=('af15ebdfbbc3442626a807569a0db2a4'
'e959df98947eb0d2ea64ff616b61aab5'
'2506860a416e1988934225d80d501c2c'
'c0549457750c4f8e8038d904a0f3012a'
- '08dff9a1fc70c30bf4759e1821e824bd'
+ '1224a6a51cfe3283b562e3c250688b53'
'b845de3e05c1734cce4b9ac5e8f1baaf'
'885fcb99a0179d9704385e14aefd7af6'
'8b7dce4a3a0a281fa6656aa8781a648e'
'4b10fff21a0274f950f97f2b61e92463'
'824e49d9b01fed295c704ab68908b464'
'fe5e31b833cc6707209e9d656b6eb53c'
- '16778701173c8465c4a288cd31d94de4'
+ '36dc1ae5fae0bbf99cb2bf5ae9419e67'
'087a0ef743bc8af915503f8773536ce4'
'38665330aeb3a8bdf7be24857fe035bb'
'80685e047993b00161be29e3580f3a40'
diff --git a/abs/core/LinHES-config/mv_common.py b/abs/core/LinHES-config/mv_common.py
index bc5382d..3160989 100755
--- a/abs/core/LinHES-config/mv_common.py
+++ b/abs/core/LinHES-config/mv_common.py
@@ -212,7 +212,6 @@ def pacinstall(pkg):
elif pkg == "dvdcss":
pacinstall("libdvdcss")
elif pkg == "webmin":
- pacinstall("webmin")
add_service("webmin")
elif pkg == "fuppes":
pacinstall("fuppes-svn")
diff --git a/abs/core/LinHES-config/mv_software.py b/abs/core/LinHES-config/mv_software.py
index 98fe2cf..13f0f2f 100755
--- a/abs/core/LinHES-config/mv_software.py
+++ b/abs/core/LinHES-config/mv_software.py
@@ -69,6 +69,7 @@ def setup_software(systemconfig, data_config):
"dolphinemu",
"xe",
"mythappletrailers",
+ "webmin",
"webonlinhes",
"huludesktop",
"xbmc",
diff --git a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
index 3171c67..3592f09 100755
--- a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
+++ b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
@@ -936,16 +936,6 @@ static HostCheckBox *Hostpluginmythbrowser()
};
-// static HostCheckBox *Hostpluginmythcontrols()
-// {
-// HostCheckBox *gc = new HostCheckBox("Hostpluginmythcontrols");
-// gc->setLabel(QObject::tr("mythcontrols"));
-// gc->setValue(true);
-// gc->setHelpText(QObject::tr("check to enable mythcontrols"));
-// return gc;
-// };
-
-
static HostCheckBox *Hostpluginmythnetvision()
{
HostCheckBox *gc = new HostCheckBox("Hostpluginmythnetvision");
@@ -1048,17 +1038,6 @@ static HostCheckBox *HostpluginmythgameXe()
};
-/*
-static HostCheckBox *Hostpluginmythmovietime()
-{
- HostCheckBox *gc = new HostCheckBox("Hostpluginmythmovietime");
- gc->setLabel(QObject::tr("mythmovietime"));
- gc->setValue(true);
- gc->setHelpText(QObject::tr("Check to enable mythmovietime"));
- return gc;
-};*/
-
-
static HostCheckBox *Hostpluginmythmusic()
{
HostCheckBox *gc = new HostCheckBox("Hostpluginmythmusic");
@@ -1079,25 +1058,6 @@ static HostCheckBox *Hostpluginmythnews()
};
-// static HostCheckBox *Hostpluginmythsmolt()
-// {
-// HostCheckBox *gc = new HostCheckBox("Hostpluginmythsmolt");
-// gc->setLabel(QObject::tr("mythsmolt"));
-// gc->setValue(true);
-// gc->setHelpText(QObject::tr("check to enable mythsmolt"));
-// return gc;
-// };
-
-
-// static HostCheckBox *Hostpluginmythvideo()
-// {
-// HostCheckBox *gc = new HostCheckBox("Hostpluginmythvideo");
-// gc->setLabel(QObject::tr("mythvideo"));
-// gc->setValue(true);
-// gc->setHelpText(QObject::tr("check to enable mythvideo"));
-// return gc;
-// };
-
static HostCheckBox *Hostpluginmythvideo_dvdcss()
{
HostCheckBox *gc = new HostCheckBox("Hostpluginmythvideo_dvdcss");
@@ -1109,15 +1069,6 @@ static HostCheckBox *Hostpluginmythvideo_dvdcss()
-// static HostCheckBox *Hostpluginmythstream()
-// {
-// HostCheckBox *gc = new HostCheckBox("Hostpluginmythstream");
-// gc->setLabel(QObject::tr("mythstream"));
-// gc->setValue(false);
-// gc->setHelpText(QObject::tr("MythStream is an unofficial MythTv plugin that plays Internet audio and video streams."));
-// return gc;
-// };
-
static HostCheckBox *Hostpluginmythappletrailers()
{
HostCheckBox *gc = new HostCheckBox("Hostpluginmythappletrailers");
@@ -1138,14 +1089,14 @@ static HostCheckBox *Hostpluginmythweather()
};
-static HostCheckBox *HostMiro()
-{
- HostCheckBox *gc = new HostCheckBox("HostMiro");
- gc->setLabel(QObject::tr("Miro"));
- gc->setValue(false);
- gc->setHelpText(QObject::tr("Miro is a popular, free, and open internet TV application. It brings video channels from thousands of sources and has more free HD than any other platform."));
- return gc;
-};
+//static HostCheckBox *HostMiro()
+//{
+// HostCheckBox *gc = new HostCheckBox("HostMiro");
+// gc->setLabel(QObject::tr("Miro"));
+// gc->setValue(false);
+// gc->setHelpText(QObject::tr("Miro is a popular, free, and open internet TV application. It brings video channels from thousands of sources and has more free HD than any other platform."));
+// return gc;
+//};
// static HostCheckBox *HostXine()
@@ -1158,23 +1109,15 @@ static HostCheckBox *HostMiro()
// };
-// static HostCheckBox *Hostwebmin()
-// {
-// HostCheckBox *gc = new HostCheckBox("Hostwebmin");
-// gc->setLabel(QObject::tr("Webmin"));
-// gc->setValue(false);
-// gc->setHelpText(QObject::tr("Webmin is a web-based interface for system administration for Unix. Once installed, you can access it at https://ip.of.back.end:10000 using your root password."));
-// return gc;
-// };
+static HostCheckBox *Hostwebmin()
+{
+ HostCheckBox *gc = new HostCheckBox("Hostwebmin");
+ gc->setLabel(QObject::tr("Webmin"));
+ gc->setValue(false);
+ gc->setHelpText(QObject::tr("Webmin is a web-based interface for system administration. Once installed, access it at https://ip.of.back.end:10000 using your root password."));
+ return gc;
+};
-// static HostCheckBox *Hostfuppes()
-// {
-// HostCheckBox *gc = new HostCheckBox("Hostfuppes");
-// gc->setLabel(QObject::tr("Fuppes"));
-// gc->setValue(false);
-// gc->setHelpText(QObject::tr("Upnp server"));
-// return gc;
-// };
static HostCheckBox *Hostfoldingathome()
{
@@ -4026,16 +3969,11 @@ void writesettings ()
//plugins
hostparm.ThisHostpluginmytharchive = gCoreContext->GetSetting("Hostpluginmytharchive");
hostparm.ThisHostpluginmythbrowser = gCoreContext->GetSetting("Hostpluginmythbrowser");
- //hostparm.ThisHostpluginmythcontrols = gCoreContext->GetSetting("Hostpluginmythcontrols");
hostparm.ThisHostpluginmythnetvision = gCoreContext->GetSetting("Hostpluginmythnetvision");
hostparm.ThisHostpluginmythgallery = gCoreContext->GetSetting("Hostpluginmythgallery");
hostparm.ThisHostpluginmythgame = gCoreContext->GetSetting("Hostpluginmythgame");
- // hostparm.ThisHostpluginmythmovietime = gCoreContext->GetSetting("Hostpluginmythmovietime");
hostparm.ThisHostpluginmythmusic = gCoreContext->GetSetting("Hostpluginmythmusic");
hostparm.ThisHostpluginmythnews = gCoreContext->GetSetting("Hostpluginmythnews");
-// hostparm.ThisHostpluginmythphone = gCoreContext->GetSetting("Hostpluginmythphone");
-// hostparm.ThisHostpluginmythsmolt = gCoreContext->GetSetting("Hostpluginmythsmolt");
-// hostparm.ThisHostpluginmythvideo = gCoreContext->GetSetting("Hostpluginmythvideo");
hostparm.ThisHostpluginmythweather = gCoreContext->GetSetting("Hostpluginmythweather");
hostparm.ThisHostpluginmythzoneminder = gCoreContext->GetSetting("Hostpluginmythzoneminder");
hostparm.ThisHostpluginmythgamefceux = gCoreContext->GetSetting("Hostpluginmythgamefceux");
@@ -4046,24 +3984,16 @@ void writesettings ()
hostparm.ThisHostpluginmythvideo_dvdcss = gCoreContext->GetSetting("Hostpluginmythvideo_dvdcss");
hostparm.ThisHostpluginmythappletrailers= gCoreContext->GetSetting("Hostpluginmythappletrailers");
-// hostparm.ThisHostpluginmythstream= gCoreContext->GetSetting("Hostpluginmythstream");
-// hostparm.ThisHostpluginmythvodka= gCoreContext->GetSetting("Hostpluginmythvodka");
- hostparm.ThisHostMiro= gCoreContext->GetSetting("HostMiro");
+// hostparm.ThisHostMiro= gCoreContext->GetSetting("HostMiro");
hostparm.ThisHostpluginmythgameMednafen= gCoreContext->GetSetting("HostpluginmythgameMednafen");
hostparm.ThisHostpluginmythgameROMDB= gCoreContext->GetSetting("HostpluginmythgameROMDB");
hostparm.ThisHostpluginmythgameMupen64= gCoreContext->GetSetting("HostpluginmythgameMupen64");
// hostparm.ThisHostXine = gCoreContext->GetSetting("HostXine");
-// hostparm.ThisHostwebmin = gCoreContext->GetSetting("Hostwebmin");
-// hostparm.ThisHostfuppes = gCoreContext->GetSetting("Hostfuppes");
+ hostparm.ThisHostwebmin = gCoreContext->GetSetting("Hostwebmin");
hostparm.ThisHostHuluDesktop = gCoreContext->GetSetting("HostHuluDesktop");
hostparm.ThisHostwebonlinhes = gCoreContext->GetSetting("HostWebonlinhes");
hostparm.ThisHostXBMC = gCoreContext->GetSetting("HostXBMC");
-// hostparm.ThisHostfuppes = gCoreContext->GetSetting("Hostfuppes");
-
-
-
-
hostparm.ThisHostfoldingathome = gCoreContext->GetSetting("Hostfoldingathome");
hostparm.ThisHostfoldingusername = gCoreContext->GetSetting("Hostfoldingusername");
hostparm.ThisHostfoldingworksize = gCoreContext->GetSetting("Hostfoldingworksize");
@@ -4392,23 +4322,15 @@ void writesettings ()
myfile << "dvdcss=\"" + hostparm.ThisHostpluginmythvideo_dvdcss + "\"\n";
myfile << "mythappletrailers=\"" + hostparm.ThisHostpluginmythappletrailers + "\"\n";
- myfile << "miro=\"" + hostparm.ThisHostMiro + "\"\n";
+// myfile << "miro=\"" + hostparm.ThisHostMiro + "\"\n";
myfile << "webonlinhes=\"" + hostparm.ThisHostwebonlinhes + "\"\n";
myfile << "huludesktop=\"" + hostparm.ThisHostHuluDesktop + "\"\n";
myfile << "xbmc=\"" + hostparm.ThisHostXBMC + "\"\n";
- //myfile << "fuppes=\"" + hostparm.ThisHostfuppes + "\"\n";
myfile << "foldingathome=\"" + hostparm.ThisHostfoldingathome + "\"\n";
myfile << "foldingusername=\"" + hostparm.ThisHostfoldingusername + "\"\n";
myfile << "foldingworksize=\"" + hostparm.ThisHostfoldingworksize + "\"\n";
- //myfile << "mythstream=\"" + hostparm.ThisHostpluginmythstream + "\"\n";
- // myfile << "mythphone=\"" + hostparm.ThisHostpluginmythphone + "\"\n";
- // myfile << "mythsmolt=\"" + hostparm.ThisHostpluginmythsmolt + "\"\n";
- // myfile << "mythvideo=\"" + hostparm.ThisHostpluginmythvideo + "\"\n";
- // myfile << "mythcontrols=\"" + hostparm.ThisHostpluginmythcontrols + "\"\n";
- // myfile << "mythmovietime=\"" + hostparm.ThisHostpluginmythmovietime + "\"\n";
- // myfile << "mythvodka=\"" +hostparm.ThisHostpluginmythvodka + "\"\n";
// myfile << "xine=\"" + hostparm.ThisHostXine + "\"\n";
- // myfile << "webmin=\"" + hostparm.ThisHostwebmin + "\"\n";er + "\"\n";
+ myfile << "webmin=\"" + hostparm.ThisHostwebmin + "\"\n";
systemheader="\n# ddns settings\n" ;
@@ -4790,30 +4712,20 @@ MythInstallSettings::MythInstallSettings()
GridShowPlugin->setLabel(QObject::tr("Programs (1/4)"));
GridShowPlugin->addChild(Hostpluginmytharchive());
GridShowPlugin->addChild(Hostpluginmythbrowser());
- //GridShowPlugin->addChild(Hostpluginmythcontrols());
GridShowPlugin->addChild(Hostpluginmythnetvision());
GridShowPlugin->addChild(Hostpluginmythgallery());
- //GridShowPlugin->addChild(Hostpluginmythmovietime());
//ConfigurationGroup *GridShowPlugin2 = new GridConfigurationGroup(2);
GridShowPlugin->addChild(Hostpluginmythmusic());
GridShowPlugin->addChild(Hostpluginmythnews());
- //GridShowPlugin2->addChild(Hostpluginmythphone());
- //GridShowPlugin2->addChild(Hostpluginmythsmolt());
GridShowPlugin->addChild(Hostpluginmythweather());
GridShowPlugin->addChild(Hostpluginmythzoneminder());
-// ConfigurationGroup *Mythvideoplugin = new HorizontalConfigurationGroup();
-// Mythvideoplugin->addChild(Hostpluginmythvideo());
-// Mythvideoplugin->addChild(Hostpluginmythvideo_dvdcss());
-
-
ConfigurationGroup *GridShowPlugin3 = new VerticalConfigurationGroup(false,true);
GridShowPlugin3->setLabel(QObject::tr("Programs (2/4)"));
GridShowPlugin3->addChild(new MythGamesettings);
GridShowPlugin3->addChild(Hostpluginmythvideo_dvdcss());
- //GridShowPlugin3->addChild(Mythvideoplugin);
addChild(GridShowPlugin);
// addChild(GridShowPlugin2);
@@ -4833,19 +4745,14 @@ MythInstallSettings::MythInstallSettings()
ConfigurationGroup *GridShowPlugin4 = new GridConfigurationGroup(2,false);
GridShowPlugin4->setLabel(QObject::tr("Programs (3/4)"));
GridShowPlugin4->addChild(Hostpluginmythappletrailers());
- //GridShowPlugin4->addChild(Hostpluginmythstream());
- //GridShowPlugin4->addChild(Hostpluginmythvodka());
- GridShowPlugin4->addChild(HostMiro());
+ //GridShowPlugin4->addChild(HostMiro());
//GridShowPlugin4->addChild(HostXine());
- //GridShowPlugin4->addChild(Hostwebmin());
- //GridShowPlugin4->addChild(Hostfuppes());
GridShowPlugin4->addChild(HostHuluDesktop());
+ GridShowPlugin4->addChild(Hostwebmin());
GridShowPlugin4->addChild(Hostwebonlinhes());
GridShowPlugin4->addChild(HostXBMC());
-
ConfigurationGroup *GridShowPlugin5 = new GridConfigurationGroup(2);
- //GridShowPlugin5->addChild(Hostfuppes());
ConfigurationGroup *GridShowPlugin6 = new VerticalConfigurationGroup(false,true);
GridShowPlugin6->setLabel(QObject::tr("Programs (4/4)"));
diff --git a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h
index 719eea5..6ce0eff 100755
--- a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h
+++ b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h
@@ -510,27 +510,18 @@ struct HostParms
QString ThisHostRemoteBackupDir;
QString ThisHostpluginmytharchive;
QString ThisHostpluginmythbrowser;
- QString ThisHostpluginmythcontrols;
QString ThisHostpluginmythnetvision;
QString ThisHostpluginmythgallery;
QString ThisHostpluginmythgame;
- QString ThisHostpluginmythmovietime;
QString ThisHostpluginmythmusic;
QString ThisHostpluginmythnews;
- QString ThisHostpluginmythphone;
- QString ThisHostpluginmythsmolt;
- QString ThisHostpluginmythvideo;
QString ThisHostpluginmythweather;
QString ThisHostpluginmythzoneminder;
-
-
QString ThisHostpluginmythvideo_dvdcss;
QString ThisHostpluginmythappletrailers;
- QString ThisHostpluginmythstream;
- QString ThisHostpluginmythvodka;
- QString ThisHostMiro;
+// QString ThisHostMiro;
QString ThisHostwebonlinhes;
QString ThisHostXBMC;
QString ThisHostHuluDesktop;
@@ -545,8 +536,7 @@ struct HostParms
QString ThisHostpluginmythgameXe;
// QString ThisHostXine;
-// QString ThisHostwebmin;
-// QString ThisHostfuppes;
+ QString ThisHostwebmin;
QString ThisHostfoldingathome;
QString ThisHostfoldingusername;
QString ThisHostfoldingworksize;
diff --git a/abs/core/mythinstall/MythVantage-app/mythinstall/main.cpp b/abs/core/mythinstall/MythVantage-app/mythinstall/main.cpp
index bac24ad..a9f0aa9 100755
--- a/abs/core/mythinstall/MythVantage-app/mythinstall/main.cpp
+++ b/abs/core/mythinstall/MythVantage-app/mythinstall/main.cpp
@@ -330,8 +330,8 @@ int main(int argc, char **argv)
"mythweather",
"mythzoneminder",
"huludesktop",
- "miro",
"xbmc",
+ "webmin",
"web-on-linhes",
"foldingathome"};
QString progDBNamesArray[] = { "Hostpluginmythappletrailers",
@@ -354,8 +354,8 @@ int main(int argc, char **argv)
"Hostpluginmythweather",
"Hostpluginmythzoneminder",
"HostHuluDesktop",
- "HostMiro",
"HostXBMC",
+ "Hostwebmin",
"Hostwebonlinhes",
"Hostfoldingathome"};
char cmd[200];
diff --git a/abs/core/mythinstall/PKGBUILD b/abs/core/mythinstall/PKGBUILD
index e268ddd..45fbd26 100644
--- a/abs/core/mythinstall/PKGBUILD
+++ b/abs/core/mythinstall/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jams
pkgname=mythinstall
pkgver=8.2
-pkgrel=4
+pkgrel=6
pkgdesc="LinHES installer/systemconfig GUI."
arch=('i686' 'x86_64')
depends=('mythtv>=0.27')