summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2020-11-15 20:44:09 (GMT)
committerBritney Fransen <brfransen@gmail.com>2020-11-15 20:44:09 (GMT)
commit6f4de74bbd91489233207557c94fa50c8e8c5ba8 (patch)
tree2c303fb1056ba838c16f41e6c817644ede220d34 /abs/core
parente70c1195556daf2b8ab077b0a3fb6c823abccf63 (diff)
downloadlinhes_pkgbuild-6f4de74bbd91489233207557c94fa50c8e8c5ba8.zip
linhes_pkgbuild-6f4de74bbd91489233207557c94fa50c8e8c5ba8.tar.gz
linhes_pkgbuild-6f4de74bbd91489233207557c94fa50c8e8c5ba8.tar.bz2
python-sphinxcontrib-jsmath: 1.0.1
Diffstat (limited to 'abs/core')
-rw-r--r--abs/core/python_modules/python-sphinxcontrib-jsmath/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-sphinxcontrib-jsmath/PKGBUILD b/abs/core/python_modules/python-sphinxcontrib-jsmath/PKGBUILD
new file mode 100644
index 0000000..d50d95e
--- /dev/null
+++ b/abs/core/python_modules/python-sphinxcontrib-jsmath/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Daniel M. Capella <polyzen@archlinux.org>
+
+_name=sphinxcontrib-jsmath
+pkgname=python-sphinxcontrib-jsmath
+pkgver=1.0.1
+pkgrel=6
+pkgdesc='Sphinx extension which renders display math in HTML via JavaScript'
+arch=('any')
+url=https://github.com/sphinx-doc/sphinxcontrib-jsmath
+license=('BSD')
+makedepends=('python-setuptools')
+checkdepends=('python-pytest' 'python-sphinx')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('a9925e4a4587247ed2191a22df5f6970656cb8ca2bd6284309578f2153e0c4b8')
+
+build() {
+ cd $_name-$pkgver
+ python setup.py build
+}
+
+check() {
+ cd $_name-$pkgver
+ pytest
+}
+
+package() {
+ cd $_name-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname LICENSE
+}
+
+# vim:set ts=2 sw=2 et: