summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2020-06-07 03:04:17 (GMT)
committerBritney Fransen <brfransen@gmail.com>2020-06-07 03:04:17 (GMT)
commit90771986bdacea89ecc05d7755a0927323e9d3f1 (patch)
treecd2c5add5db2ba678f446bf7a71a84635b248a24 /abs/core
parent672eb4dee98c99f5da7f77d026968b6cbadcb905 (diff)
downloadlinhes_pkgbuild-90771986bdacea89ecc05d7755a0927323e9d3f1.zip
linhes_pkgbuild-90771986bdacea89ecc05d7755a0927323e9d3f1.tar.gz
linhes_pkgbuild-90771986bdacea89ecc05d7755a0927323e9d3f1.tar.bz2
cmake: update to 3.17.3
Diffstat (limited to 'abs/core')
-rw-r--r--abs/core/cmake/PKGBUILD32
-rw-r--r--abs/core/cmake/cmake-3.10-boost-1.66-support.patch259
-rw-r--r--abs/core/cmake/cmake-cppflags.patch26
-rw-r--r--abs/core/cmake/rebuild.list3
4 files changed, 45 insertions, 275 deletions
diff --git a/abs/core/cmake/PKGBUILD b/abs/core/cmake/PKGBUILD
index 94f426f..b732aac 100644
--- a/abs/core/cmake/PKGBUILD
+++ b/abs/core/cmake/PKGBUILD
@@ -1,32 +1,30 @@
-# $Id$
# Maintainer: Felix Yan <felixonmars@archlinux.org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Pierre Schmitz <pierre@archlinux.de>
pkgname=cmake
-pkgver=3.10.2
-pkgrel=3
+pkgver=3.17.3
+pkgrel=1
pkgdesc='A cross-platform open-source make system'
arch=('x86_64')
-url="http://www.cmake.org/"
+url="https://www.cmake.org/"
license=('custom')
-depends=('curl' 'libarchive' 'shared-mime-info' 'jsoncpp' 'libuv' 'rhash')
+depends=('curl' 'libarchive' 'shared-mime-info' 'jsoncpp' 'libjsoncpp.so' 'libuv' 'rhash')
makedepends=('qt5-base' 'python-sphinx' 'emacs')
-optdepends=('qt5-base: cmake-gui'
- 'libxkbcommon-x11: cmake-gui')
+optdepends=('qt5-base: cmake-gui')
source=("https://www.cmake.org/files/v${pkgver%.*}/${pkgname}-${pkgver}.tar.gz"
- 'cmake-3.10-boost-1.66-support.patch')
-sha512sums=('f58fdd025285c9ff5396c0bd0d9573fc8a498fcbe5c11b336cb8ad6154ca6bc875c1a5e22d6654ba98596791ecf89ae8adffb83450839fa1275756b0af5bf82b'
- 'edc24a0e057056427e15b0b4c23828c8d0d23a69061d0ede9ae1bb6104bece53157480f63361b48994ea9f3b12f5bcd9f1d56c4f7d5c4b1b88c8e1a7b6ee5b68')
+ cmake-cppflags.patch)
+sha512sums=('13479bd48ef8a8c95277a62b4f42e63152a5979292a98b5456022ca42ad3963cad75e917cc8b92a8485dbf5a2b59cde3fdc90fd9abdb806bc97c8570d03c1c69'
+ '407c5c63a31266e44641ada8229dbc33df44df98e5bb575db3a33590e8ffdff9aea3f2ee5cb0cb855858facf1e46c63886dea9f948a0cad2da042e7f7f258cac')
prepare() {
- cd ${pkgname}-${pkgver}
- patch -p1 -i "${srcdir}/cmake-3.10-boost-1.66-support.patch"
+ cd ${pkgname}-${pkgver}
+ patch -p1 -i ../cmake-cppflags.patch # Honor CPPFLAGS https://gitlab.kitware.com/cmake/cmake/issues/12928
}
build() {
cd ${pkgname}-${pkgver}
-
+ export CXXFLAGS+=" ${CPPFLAGS}"
./bootstrap --prefix=/usr \
--mandir=/share/man \
--docdir=/share/doc/cmake \
@@ -42,7 +40,7 @@ package() {
make DESTDIR="${pkgdir}" install
vimpath="${pkgdir}/usr/share/vim/vimfiles"
- install -d "${vimpath}"/{help,indent,syntax}
+ install -d "${vimpath}"/{indent,syntax}
ln -s /usr/share/cmake-${pkgver%.*}/editors/vim/indent/cmake.vim \
"${vimpath}"/indent/
ln -s /usr/share/cmake-${pkgver%.*}/editors/vim/syntax/cmake.vim \
@@ -53,7 +51,13 @@ package() {
"${pkgdir}"/usr/share/cmake-${pkgver%.*}/editors/emacs/cmake-mode.el
ln -s /usr/share/cmake-${pkgver%.*}/editors/emacs/cmake-mode.el \
"${pkgdir}"/usr/share/emacs/site-lisp/
+ ln -s /usr/share/cmake-${pkgver%.*}/editors/emacs/cmake-mode.elc \
+ "${pkgdir}"/usr/share/emacs/site-lisp/
install -Dm644 Copyright.txt \
"${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+
+# install bash completions
+ mkdir -p "$pkgdir"/usr/share/bash-completion/completions
+ ln -s /usr/share/cmake-${pkgver%.*}/completions/{cmake,cpack,ctest} "$pkgdir"/usr/share/bash-completion/completions
}
diff --git a/abs/core/cmake/cmake-3.10-boost-1.66-support.patch b/abs/core/cmake/cmake-3.10-boost-1.66-support.patch
deleted file mode 100644
index fbca966..0000000
--- a/abs/core/cmake/cmake-3.10-boost-1.66-support.patch
+++ /dev/null
@@ -1,259 +0,0 @@
-From d757601d51304b12afa11aedb2f3748c9958fa81 Mon Sep 17 00:00:00 2001
-From: "Paul \"TBBle\" Hampson" <Paul.Hampson@Pobox.com>
-Date: Fri, 29 Dec 2017 19:55:49 +1100
-Subject: [PATCH 1/5] Boost 1.66.0 dependency and release update
-
-Release notes: http://www.boost.org/users/history/version_1_66_0.html
-
-* All new libraries are header-only.
-* _Boost_COMPONENT_DEPENDENCIES is unchanged from 1.65.1
-* _Boost_FIBER_COMPILER_FEATURES is unchanged from 1.64.0
----
- Modules/FindBoost.cmake | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/Modules/FindBoost.cmake b/Modules/FindBoost.cmake
-index 88d14ab..8db9800 100644
---- a/Modules/FindBoost.cmake
-+++ b/Modules/FindBoost.cmake
-@@ -797,7 +797,7 @@ function(_Boost_COMPONENT_DEPENDENCIES component _ret)
- set(_Boost_WAVE_DEPENDENCIES filesystem system serialization thread chrono date_time atomic)
- set(_Boost_WSERIALIZATION_DEPENDENCIES serialization)
- endif()
-- if(NOT Boost_VERSION VERSION_LESS 106600)
-+ if(NOT Boost_VERSION VERSION_LESS 106700)
- message(WARNING "New Boost version may have incorrect or missing dependencies and imported targets")
- set(_Boost_IMPORTED_TARGETS FALSE)
- endif()
-@@ -931,8 +931,8 @@ endfunction()
- # `${Boost_ROOT}/libs/fiber/build/Jamfile.v2`.
- #
- function(_Boost_COMPILER_FEATURES component _ret)
-- # Boost >= 1.62 and < 1.65
-- if(NOT Boost_VERSION VERSION_LESS 106200 AND Boost_VERSION VERSION_LESS 106500)
-+ # Boost >= 1.62 and < 1.67
-+ if(NOT Boost_VERSION VERSION_LESS 106200 AND Boost_VERSION VERSION_LESS 106700)
- set(_Boost_FIBER_COMPILER_FEATURES
- cxx_alias_templates
- cxx_auto_type
-@@ -1038,7 +1038,7 @@ else()
- # _Boost_COMPONENT_HEADERS. See the instructions at the top of
- # _Boost_COMPONENT_DEPENDENCIES.
- set(_Boost_KNOWN_VERSIONS ${Boost_ADDITIONAL_VERSIONS}
-- "1.65.1" "1.65.0" "1.65"
-+ "1.66.0" "1.66" "1.65.1" "1.65.0" "1.65"
- "1.64.0" "1.64" "1.63.0" "1.63" "1.62.0" "1.62" "1.61.0" "1.61" "1.60.0" "1.60"
- "1.59.0" "1.59" "1.58.0" "1.58" "1.57.0" "1.57" "1.56.0" "1.56" "1.55.0" "1.55"
- "1.54.0" "1.54" "1.53.0" "1.53" "1.52.0" "1.52" "1.51.0" "1.51"
---
-2.15.1
-
-From 73605cce7b4c0157c4cf3251e46877bee4cb1160 Mon Sep 17 00:00:00 2001
-From: "Paul \"TBBle\" Hampson" <Paul.Hampson@Pobox.com>
-Date: Fri, 29 Dec 2017 20:07:31 +1100
-Subject: [PATCH 2/5] Fix incorrect alphabetisation of headers list
-
----
- Modules/FindBoost.cmake | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Modules/FindBoost.cmake b/Modules/FindBoost.cmake
-index 8db9800..a7df333 100644
---- a/Modules/FindBoost.cmake
-+++ b/Modules/FindBoost.cmake
-@@ -831,8 +831,8 @@ function(_Boost_COMPONENT_HEADERS component _hdrs)
- set(_Boost_CONTAINER_HEADERS "boost/container/container_fwd.hpp")
- set(_Boost_CONTEXT_HEADERS "boost/context/all.hpp")
- set(_Boost_COROUTINE_HEADERS "boost/coroutine/all.hpp")
-- set(_Boost_EXCEPTION_HEADERS "boost/exception/exception.hpp")
- set(_Boost_DATE_TIME_HEADERS "boost/date_time/date.hpp")
-+ set(_Boost_EXCEPTION_HEADERS "boost/exception/exception.hpp")
- set(_Boost_FIBER_HEADERS "boost/fiber/all.hpp")
- set(_Boost_FILESYSTEM_HEADERS "boost/filesystem/path.hpp")
- set(_Boost_GRAPH_HEADERS "boost/graph/adjacency_list.hpp")
---
-2.15.1
-
-From a99b3f0698e453faf778dab5d59b91b89e35f5a1 Mon Sep 17 00:00:00 2001
-From: "Paul \"TBBle\" Hampson" <Paul.Hampson@Pobox.com>
-Date: Fri, 29 Dec 2017 21:50:54 +1100
-Subject: [PATCH 3/5] Implement "Architecture and Address Model" tag
-
-This tag is new in Boost 1.66.0, and is present in the 'versioned'
-library file name layout.
----
- Modules/FindBoost.cmake | 51 +++++++++++++++++++++++++++++++++++++++----------
- 1 file changed, 41 insertions(+), 10 deletions(-)
-
-diff --git a/Modules/FindBoost.cmake b/Modules/FindBoost.cmake
-index a7df333..81acf02 100644
---- a/Modules/FindBoost.cmake
-+++ b/Modules/FindBoost.cmake
-@@ -1385,8 +1385,11 @@ if(Boost_DEBUG)
- endif()
-
- #======================
--# Systematically build up the Boost ABI tag
--# http://boost.org/doc/libs/1_41_0/more/getting_started/windows.html#library-naming
-+# Systematically build up the Boost ABI tag for the 'tagged' and 'versioned' layouts
-+# http://boost.org/doc/libs/1_66_0/more/getting_started/windows.html#library-naming
-+# http://boost.org/doc/libs/1_66_0/boost/config/auto_link.hpp
-+# http://boost.org/doc/libs/1_66_0/tools/build/src/tools/common.jam
-+# http://boost.org/doc/libs/1_66_0/boostcpp.jam
- set( _boost_RELEASE_ABI_TAG "-")
- set( _boost_DEBUG_ABI_TAG "-")
- # Key Use this library when:
-@@ -1418,11 +1421,39 @@ if(Boost_USE_STLPORT)
- string(APPEND _boost_DEBUG_ABI_TAG "p")
- endif()
- # n using the STLport deprecated "native iostreams" feature
-+# removed from the documentation in 1.43.0 but still present in
-+# boost/config/auto_link.hpp
- if(Boost_USE_STLPORT_DEPRECATED_NATIVE_IOSTREAMS)
- string(APPEND _boost_RELEASE_ABI_TAG "n")
- string(APPEND _boost_DEBUG_ABI_TAG "n")
- endif()
-
-+# -x86 Architecture and address model tag
-+# First character is the architecture, then word-size, either 32 or 64
-+# Only used in 'versioned' layout, added in Boost 1.66.0
-+set(_boost_ARCHITECTURE_TAG "")
-+# if(NOT Boost_VERSION VERSION_LESS 106600)
-+# string(APPEND _boost_ARCHITECTURE_TAG "-")
-+# # This needs to be kept in-sync with the section of CMakePlatformId.h.in
-+# # inside 'defined(_WIN32) && defined(_MSC_VER)'
-+# if(${CMAKE_CXX_COMPILER_ARCHITECTURE_ID} STREQUAL "IA64")
-+# string(APPEND _boost_ARCHITECTURE_TAG "i")
-+# elseif(${CMAKE_CXX_COMPILER_ARCHITECTURE_ID} STREQUAL "X86"
-+# OR ${CMAKE_CXX_COMPILER_ARCHITECTURE_ID} STREQUAL "x64")
-+# string(APPEND _boost_ARCHITECTURE_TAG "x")
-+# elseif(${CMAKE_CXX_COMPILER_ARCHITECTURE_ID} MATCHES "^ARM")
-+# string(APPEND _boost_ARCHITECTURE_TAG "a")
-+# elseif(${CMAKE_CXX_COMPILER_ARCHITECTURE_ID} STREQUAL "MIPS")
-+# string(APPEND _boost_ARCHITECTURE_TAG "m")
-+# endif()
-+#
-+# if(CMAKE_SIZEOF_VOID_P EQUAL 8)
-+# string(APPEND _boost_ARCHITECTURE_TAG "64")
-+# else()
-+# string(APPEND _boost_ARCHITECTURE_TAG "32")
-+# endif()
-+# endif()
-+
- if(Boost_DEBUG)
- message(STATUS "[ ${CMAKE_CURRENT_LIST_FILE}:${CMAKE_CURRENT_LIST_LINE} ] "
- "_boost_RELEASE_ABI_TAG = ${_boost_RELEASE_ABI_TAG}")
-@@ -1616,22 +1647,22 @@ foreach(COMPONENT ${Boost_FIND_COMPONENTS})
- unset(_boost_RELEASE_NAMES)
- foreach(compiler IN LISTS _boost_COMPILER)
- list(APPEND _boost_RELEASE_NAMES
-- ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT}${compiler}${_boost_MULTITHREADED}${_boost_RELEASE_ABI_TAG}-${Boost_LIB_VERSION}
-+ ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT}${compiler}${_boost_MULTITHREADED}${_boost_RELEASE_ABI_TAG}${_boost_ARCHITECTURE_TAG}-${Boost_LIB_VERSION}
- ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT}${compiler}${_boost_MULTITHREADED}${_boost_RELEASE_ABI_TAG} )
- endforeach()
- list(APPEND _boost_RELEASE_NAMES
-- ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT}${_boost_MULTITHREADED}${_boost_RELEASE_ABI_TAG}-${Boost_LIB_VERSION}
-+ ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT}${_boost_MULTITHREADED}${_boost_RELEASE_ABI_TAG}${_boost_ARCHITECTURE_TAG}-${Boost_LIB_VERSION}
- ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT}${_boost_MULTITHREADED}${_boost_RELEASE_ABI_TAG}
- ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT} )
- if(_boost_STATIC_RUNTIME_WORKAROUND)
- set(_boost_RELEASE_STATIC_ABI_TAG "-s${_boost_RELEASE_ABI_TAG}")
- foreach(compiler IN LISTS _boost_COMPILER)
- list(APPEND _boost_RELEASE_NAMES
-- ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT}${compiler}${_boost_MULTITHREADED}${_boost_RELEASE_STATIC_ABI_TAG}-${Boost_LIB_VERSION}
-+ ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT}${compiler}${_boost_MULTITHREADED}${_boost_RELEASE_STATIC_ABI_TAG}${_boost_ARCHITECTURE_TAG}-${Boost_LIB_VERSION}
- ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT}${compiler}${_boost_MULTITHREADED}${_boost_RELEASE_STATIC_ABI_TAG} )
- endforeach()
- list(APPEND _boost_RELEASE_NAMES
-- ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT}${_boost_MULTITHREADED}${_boost_RELEASE_STATIC_ABI_TAG}-${Boost_LIB_VERSION}
-+ ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT}${_boost_MULTITHREADED}${_boost_RELEASE_STATIC_ABI_TAG}${_boost_ARCHITECTURE_TAG}-${Boost_LIB_VERSION}
- ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT}${_boost_MULTITHREADED}${_boost_RELEASE_STATIC_ABI_TAG} )
- endif()
- if(Boost_THREADAPI AND ${COMPONENT} STREQUAL "thread")
-@@ -1666,11 +1697,11 @@ foreach(COMPONENT ${Boost_FIND_COMPONENTS})
- unset(_boost_DEBUG_NAMES)
- foreach(compiler IN LISTS _boost_COMPILER)
- list(APPEND _boost_DEBUG_NAMES
-- ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT}${compiler}${_boost_MULTITHREADED}${_boost_DEBUG_ABI_TAG}-${Boost_LIB_VERSION}
-+ ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT}${compiler}${_boost_MULTITHREADED}${_boost_DEBUG_ABI_TAG}${_boost_ARCHITECTURE_TAG}-${Boost_LIB_VERSION}
- ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT}${compiler}${_boost_MULTITHREADED}${_boost_DEBUG_ABI_TAG} )
- endforeach()
- list(APPEND _boost_DEBUG_NAMES
-- ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT}${_boost_MULTITHREADED}${_boost_DEBUG_ABI_TAG}-${Boost_LIB_VERSION}
-+ ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT}${_boost_MULTITHREADED}${_boost_DEBUG_ABI_TAG}${_boost_ARCHITECTURE_TAG}-${Boost_LIB_VERSION}
- ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT}${_boost_MULTITHREADED}${_boost_DEBUG_ABI_TAG}
- ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT}${_boost_MULTITHREADED}
- ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT} )
-@@ -1678,11 +1709,11 @@ foreach(COMPONENT ${Boost_FIND_COMPONENTS})
- set(_boost_DEBUG_STATIC_ABI_TAG "-s${_boost_DEBUG_ABI_TAG}")
- foreach(compiler IN LISTS _boost_COMPILER)
- list(APPEND _boost_DEBUG_NAMES
-- ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT}${compiler}${_boost_MULTITHREADED}${_boost_DEBUG_STATIC_ABI_TAG}-${Boost_LIB_VERSION}
-+ ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT}${compiler}${_boost_MULTITHREADED}${_boost_DEBUG_STATIC_ABI_TAG}${_boost_ARCHITECTURE_TAG}-${Boost_LIB_VERSION}
- ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT}${compiler}${_boost_MULTITHREADED}${_boost_DEBUG_STATIC_ABI_TAG} )
- endforeach()
- list(APPEND _boost_DEBUG_NAMES
-- ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT}${_boost_MULTITHREADED}${_boost_DEBUG_STATIC_ABI_TAG}-${Boost_LIB_VERSION}
-+ ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT}${_boost_MULTITHREADED}${_boost_DEBUG_STATIC_ABI_TAG}${_boost_ARCHITECTURE_TAG}-${Boost_LIB_VERSION}
- ${Boost_LIB_PREFIX}${Boost_NAMESPACE}_${COMPONENT}${_boost_MULTITHREADED}${_boost_DEBUG_STATIC_ABI_TAG} )
- endif()
- if(Boost_THREADAPI AND ${COMPONENT} STREQUAL "thread")
---
-2.15.1
-
-From 6160aed8eb8e9c6ac78b1b5ec136b4601a6c1edf Mon Sep 17 00:00:00 2001
-From: "Paul \"TBBle\" Hampson" <Paul.Hampson@Pobox.com>
-Date: Fri, 29 Dec 2017 22:38:36 +1100
-Subject: [PATCH 4/5] Search for upstream-packaged libs next to includes
-
-Upstream packages Boost binaries for Windows with the 'boost' directory
-(the INCLUDE_DIR) next to the lib-... directory (the LIBRARY_DIR).
----
- Modules/FindBoost.cmake | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/Modules/FindBoost.cmake b/Modules/FindBoost.cmake
-index 81acf02..6f2fd9d 100644
---- a/Modules/FindBoost.cmake
-+++ b/Modules/FindBoost.cmake
-@@ -1501,6 +1501,7 @@ foreach(c DEBUG RELEASE)
- ${Boost_INCLUDE_DIR}/stage/lib
- )
- _Boost_UPDATE_WINDOWS_LIBRARY_SEARCH_DIRS_WITH_PREBUILT_PATHS(_boost_LIBRARY_SEARCH_DIRS_${c} "${Boost_INCLUDE_DIR}/..")
-+ _Boost_UPDATE_WINDOWS_LIBRARY_SEARCH_DIRS_WITH_PREBUILT_PATHS(_boost_LIBRARY_SEARCH_DIRS_${c} "${Boost_INCLUDE_DIR}")
- if( Boost_NO_SYSTEM_PATHS )
- list(APPEND _boost_LIBRARY_SEARCH_DIRS_${c} NO_CMAKE_SYSTEM_PATH NO_SYSTEM_ENVIRONMENT_PATH)
- else()
---
-2.15.1
-
-From 298d89e3bbbb480358c20af51c5be1e1d2929e0a Mon Sep 17 00:00:00 2001
-From: "Paul \"TBBle\" Hampson" <Paul.Hampson@Pobox.com>
-Date: Sat, 30 Dec 2017 16:00:29 +1100
-Subject: [PATCH 5/5] Generate imported targets for future Boost versions
-
-Per discussion on cmake/cmake#17575, this protection not particularly
-valuable, as the dependency information which the imported targets wrap
-is generated anyway.
-
-This removes a road-block for using `Boost_ADDITIONAL_VERSIONS` to
-support newly-released Boost versions pending a new CMake release.
----
- Modules/FindBoost.cmake | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/Modules/FindBoost.cmake b/Modules/FindBoost.cmake
-index 6f2fd9d..dbcc261 100644
---- a/Modules/FindBoost.cmake
-+++ b/Modules/FindBoost.cmake
-@@ -799,7 +799,6 @@ function(_Boost_COMPONENT_DEPENDENCIES component _ret)
- endif()
- if(NOT Boost_VERSION VERSION_LESS 106700)
- message(WARNING "New Boost version may have incorrect or missing dependencies and imported targets")
-- set(_Boost_IMPORTED_TARGETS FALSE)
- endif()
- endif()
-
---
-2.15.1
-
diff --git a/abs/core/cmake/cmake-cppflags.patch b/abs/core/cmake/cmake-cppflags.patch
new file mode 100644
index 0000000..ffac66c
--- /dev/null
+++ b/abs/core/cmake/cmake-cppflags.patch
@@ -0,0 +1,26 @@
+diff --git a/Modules/CMakeCInformation.cmake b/Modules/CMakeCInformation.cmake
+index f6d620f40e..325b11f25e 100644
+--- a/Modules/CMakeCInformation.cmake
++++ b/Modules/CMakeCInformation.cmake
+@@ -100,7 +100,7 @@ if(NOT CMAKE_MODULE_EXISTS)
+ set(CMAKE_SHARED_MODULE_CREATE_C_FLAGS ${CMAKE_SHARED_LIBRARY_CREATE_C_FLAGS})
+ endif()
+
+-set(CMAKE_C_FLAGS_INIT "$ENV{CFLAGS} ${CMAKE_C_FLAGS_INIT}")
++set(CMAKE_C_FLAGS_INIT "$ENV{CPPFLAGS} $ENV{CFLAGS} ${CMAKE_C_FLAGS_INIT}")
+
+ cmake_initialize_per_config_variable(CMAKE_C_FLAGS "Flags used by the C compiler")
+
+diff --git a/Modules/CMakeCXXInformation.cmake b/Modules/CMakeCXXInformation.cmake
+index dbb4366757..8a0ee288c6 100644
+--- a/Modules/CMakeCXXInformation.cmake
++++ b/Modules/CMakeCXXInformation.cmake
+@@ -197,7 +197,7 @@ endforeach()
+ # on the initial values computed in the platform/*.cmake files
+ # use _INIT variables so that this only happens the first time
+ # and you can set these flags in the cmake cache
+-set(CMAKE_CXX_FLAGS_INIT "$ENV{CXXFLAGS} ${CMAKE_CXX_FLAGS_INIT}")
++set(CMAKE_CXX_FLAGS_INIT "$ENV{CPPFLAGS} $ENV{CXXFLAGS} ${CMAKE_CXX_FLAGS_INIT}")
+
+ cmake_initialize_per_config_variable(CMAKE_CXX_FLAGS "Flags used by the CXX compiler")
+
diff --git a/abs/core/cmake/rebuild.list b/abs/core/cmake/rebuild.list
index f249e83..4a25a61 100644
--- a/abs/core/cmake/rebuild.list
+++ b/abs/core/cmake/rebuild.list
@@ -1,3 +1,2 @@
-quazip
-sfml
cmake-fedora
+uranium