summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2020-11-15 21:26:00 (GMT)
committerBritney Fransen <brfransen@gmail.com>2020-11-15 21:26:00 (GMT)
commitd9d9e8d1da6b97ae60b9682055de8b17289fc453 (patch)
treedb6ae449f8f87af888a5d6ef0a6d07fe3bef4349 /abs/core
parent5f225db0eb0c049d5b226ffab6b3511ee7e08fad (diff)
downloadlinhes_pkgbuild-d9d9e8d1da6b97ae60b9682055de8b17289fc453.zip
linhes_pkgbuild-d9d9e8d1da6b97ae60b9682055de8b17289fc453.tar.gz
linhes_pkgbuild-d9d9e8d1da6b97ae60b9682055de8b17289fc453.tar.bz2
python-html5lib: 1.1
Diffstat (limited to 'abs/core')
-rw-r--r--abs/core/python_modules/python-html5lib/LICENSE17
-rw-r--r--abs/core/python_modules/python-html5lib/PKGBUILD33
2 files changed, 19 insertions, 31 deletions
diff --git a/abs/core/python_modules/python-html5lib/LICENSE b/abs/core/python_modules/python-html5lib/LICENSE
deleted file mode 100644
index 89de354..0000000
--- a/abs/core/python_modules/python-html5lib/LICENSE
+++ /dev/null
@@ -1,17 +0,0 @@
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in
-all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
-THE SOFTWARE.
diff --git a/abs/core/python_modules/python-html5lib/PKGBUILD b/abs/core/python_modules/python-html5lib/PKGBUILD
index 4991390..2e7f14b 100644
--- a/abs/core/python_modules/python-html5lib/PKGBUILD
+++ b/abs/core/python_modules/python-html5lib/PKGBUILD
@@ -5,23 +5,29 @@
pkgbase=python-html5lib
pkgname=('python2-html5lib' 'python-html5lib')
-pkgver=1.0.1
-pkgrel=2
+pkgver=1.1
+pkgrel=5
arch=('any')
url="https://github.com/html5lib"
license=('MIT')
-makedepends=('python-setuptools' 'python2-setuptools' 'python-webencodings' 'python2-webencodings')
-checkdepends=('python-six' 'python2-six' 'python-pytest-expect' 'python2-pytest-expect'
- 'python-lxml' 'python2-lxml' 'python-mock' 'python2-mock')
-_test_commit=c305da74fae50fb018870de7a042da36c1a93b65
+_deps=('six' 'webencodings')
+makedepends=('python-setuptools' 'python2-setuptools' "${_deps[@]/#/python-}" "${_deps[@]/#/python2-}")
+_checkdeps=('pytest' 'pytest-expect' 'lxml' 'mock')
+checkdepends=("${_checkdeps[@]/#/python-}" "${_checkdeps[@]/#/python2-}")
+_test_commit=71eebd59772d1d39aced0c0582ae9c09acf3ce6e
source=("$pkgbase-$pkgver.tar.gz::https://github.com/html5lib/html5lib-python/archive/${pkgver}.tar.gz"
+ "https://github.com/html5lib/html5lib-python/commit/2c19b9899ab3a3e8bd0ca35e5d78544334204169.patch"
"https://github.com/html5lib/html5lib-tests/archive/${_test_commit}.tar.gz")
-sha256sums=('fabbebd6a55d07842087f13849076eeed350aa8bb6c9ec840f6a6aba9388db06'
- 'cb261423c644b3469ac66926e290060b481371d0952995d270492fc761d0209a')
+sha256sums=('66e9e24a53c10c27abb6be8a3cf2cf55824c6ea1cef8570a633cb223ec46e894'
+ '6f37b33667e35ea138279be9842f012792821b1497b81ae4b108a74180cfe249'
+ 'c866f5e4ae9ef34313e2b61fcb74849b6f8aef970bf8249956b6a5d142197087')
prepare() {
cd "${srcdir}"/html5lib-python-${pkgver}
+ # fix pytest 6 compat
+ patch -p1 -i ../2c19b9899ab3a3e8bd0ca35e5d78544334204169.patch
+
rmdir html5lib/tests/testdata
ln -sfT ../../../html5lib-tests-${_test_commit} html5lib/tests/testdata
}
@@ -42,22 +48,21 @@ check() {
package_python-html5lib() {
pkgdesc="A Python HTML parser/tokenizer based on the WHATWG HTML5 spec"
- depends=('python' 'python-six' 'python-webencodings')
+ depends=("${_deps[@]/#/python-}")
optdepends=('python-lxml: lxml treebuilder'
'python-genshi: genshi treewalker')
cd "${srcdir}"/html5lib-python-${pkgver}
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm755 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}
package_python2-html5lib() {
pkgdesc="A Python2 HTML parser/tokenizer based on the WHATWG HTML5 spec"
- depends=('python2' 'python2-six' 'python2-webencodings')
- optdepends=('python2-lxml: lxml treebuilder'
- 'python2-genshi: genshi treewalker')
+ depends=("${_deps[@]/#/python2-}")
+ optdepends=('python2-lxml: lxml treebuilder')
cd "${srcdir}"/html5lib-python-${pkgver}
python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm755 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}