summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2020-11-15 20:42:46 (GMT)
committerBritney Fransen <brfransen@gmail.com>2020-11-15 20:42:46 (GMT)
commite70c1195556daf2b8ab077b0a3fb6c823abccf63 (patch)
treee5499393baa07ca78f9e7c638d75f49f4ebc6b81 /abs/core
parent2110f5644f13e491067b96f4a69a2fe443036d39 (diff)
downloadlinhes_pkgbuild-e70c1195556daf2b8ab077b0a3fb6c823abccf63.zip
linhes_pkgbuild-e70c1195556daf2b8ab077b0a3fb6c823abccf63.tar.gz
linhes_pkgbuild-e70c1195556daf2b8ab077b0a3fb6c823abccf63.tar.bz2
python-sphinxcontrib-htmlhelp: 1.0.3
Diffstat (limited to 'abs/core')
-rw-r--r--abs/core/python_modules/python-sphinxcontrib-htmlhelp/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-sphinxcontrib-htmlhelp/PKGBUILD b/abs/core/python_modules/python-sphinxcontrib-htmlhelp/PKGBUILD
new file mode 100644
index 0000000..ac87604
--- /dev/null
+++ b/abs/core/python_modules/python-sphinxcontrib-htmlhelp/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Daniel M. Capella <polyzen@archlinux.org>
+
+_name=sphinxcontrib-htmlhelp
+pkgname=python-sphinxcontrib-htmlhelp
+pkgver=1.0.3
+pkgrel=3
+pkgdesc='Sphinx extension which renders HTML help files'
+arch=('any')
+url=https://github.com/sphinx-doc/sphinxcontrib-htmlhelp
+license=('BSD')
+makedepends=('python-setuptools')
+checkdepends=('python-html5lib' 'python-pytest' 'python-sphinx')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('e8f5bb7e31b2dbb25b9cc435c8ab7a79787ebf7f906155729338f3156d93659b')
+
+build() {
+ cd $_name-$pkgver
+ python setup.py build
+}
+
+check() {
+ cd $_name-$pkgver
+ pytest
+}
+
+package() {
+ cd $_name-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname LICENSE
+}
+
+# vim:set ts=2 sw=2 et: