summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/autofs/heimdal.patch
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verison.net>2010-07-16 01:27:59 (GMT)
committerMichael Hanson <hansonorders@verison.net>2010-07-16 01:27:59 (GMT)
commit677bbf9bc1a7b1e638c33d2683b367d3b0fd5159 (patch)
treed0a5c2f68206846798a0c4eebbdc48dddab0373c /abs/extra-testing/autofs/heimdal.patch
parent1520f89cb8cad4eb6ba5685bdd5fb14470acf992 (diff)
parent494d57bcc659282c41e99606b0496163dcd9b35d (diff)
downloadlinhes_pkgbuild-677bbf9bc1a7b1e638c33d2683b367d3b0fd5159.zip
linhes_pkgbuild-677bbf9bc1a7b1e638c33d2683b367d3b0fd5159.tar.gz
linhes_pkgbuild-677bbf9bc1a7b1e638c33d2683b367d3b0fd5159.tar.bz2
Merge branch 'master' of mihanson@knoppmyth.net:LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/autofs/heimdal.patch')
-rw-r--r--abs/extra-testing/autofs/heimdal.patch24
1 files changed, 17 insertions, 7 deletions
diff --git a/abs/extra-testing/autofs/heimdal.patch b/abs/extra-testing/autofs/heimdal.patch
index c49b1fd..4aa3218 100644
--- a/abs/extra-testing/autofs/heimdal.patch
+++ b/abs/extra-testing/autofs/heimdal.patch
@@ -1,5 +1,5 @@
---- autofs-5.0.4/modules/cyrus-sasl.c~ 2009-01-11 17:18:55.000000000 +0100
-+++ autofs-5.0.4/modules/cyrus-sasl.c 2009-01-11 17:18:55.000000000 +0100
+--- autofs-5.0.5/modules/cyrus-sasl.c~ 2010-03-03 01:38:41.582901786 +0100
++++ autofs-5.0.5/modules/cyrus-sasl.c 2010-03-03 01:41:32.313704755 +0100
@@ -66,6 +66,15 @@
#endif
#endif
@@ -16,19 +16,29 @@
/*
* Once a krb5 credentials cache is setup, we need to set the KRB5CCNAME
* environment variable so that the library knows where to find it.
-@@ -451,11 +460,11 @@
+@@ -452,11 +452,11 @@
/* setup a principal for the ticket granting service */
ret = krb5_build_principal_ext(ctxt->krb5ctxt, &tgs_princ,
- krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)->length,
- krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)->data,
-+ krb5_realm_length(*krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)),
-+ krb5_realm_data(*krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)),
++ krb5_realm_length(*krb5_principal_get_realm(ctxt->krb5ctxt, krb5_client_princ)),
++ krb5_realm_data(*krb5_principal_get_realm(ctxt->krb5ctxt, krb5_client_princ)),
strlen(KRB5_TGS_NAME), KRB5_TGS_NAME,
- krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)->length,
- krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)->data,
-+ krb5_realm_length(*krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)),
-+ krb5_realm_data(*krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)),
++ krb5_realm_length(*krb5_principal_get_realm(ctxt->krb5ctxt, krb5_client_princ)),
++ krb5_realm_data(*krb5_principal_get_realm(ctxt->krb5ctxt, krb5_client_princ)),
0);
if (ret) {
error(logopt,
+--- autofs-5.0.5/modules/Makefile~ 2010-03-03 01:42:18.532868539 +0100
++++ autofs-5.0.5/modules/Makefile 2010-03-03 01:42:35.360367371 +0100
+@@ -43,7 +43,7 @@
+ ifeq ($(SASL), 1)
+ SASL_OBJ = cyrus-sasl.o
+ LDAP_FLAGS += $(SASL_FLAGS) $(XML_FLAGS) -DLDAP_THREAD_SAFE
+- LIBLDAP += $(LIBSASL) $(XML_LIBS)
++ LIBLDAP += $(LIBSASL) $(XML_LIBS) -lkrb5
+ endif
+ endif \ No newline at end of file