summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/bluez/run.hid2hci
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-04-02 17:43:16 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-04-02 17:43:16 (GMT)
commit6ee95c24a4ffc57f8397f2cd15d3fa7474631510 (patch)
treeb268dd4bd38f6764899d8877cae757cd68771709 /abs/extra-testing/bluez/run.hid2hci
parentd41c2fc032d8767c388d56aa325d023ad2713cb3 (diff)
parent42d091df6c811163378e16e6de0f83ea4afb660b (diff)
downloadlinhes_pkgbuild-6ee95c24a4ffc57f8397f2cd15d3fa7474631510.zip
linhes_pkgbuild-6ee95c24a4ffc57f8397f2cd15d3fa7474631510.tar.gz
linhes_pkgbuild-6ee95c24a4ffc57f8397f2cd15d3fa7474631510.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/bluez/run.hid2hci')
-rw-r--r--abs/extra-testing/bluez/run.hid2hci15
1 files changed, 15 insertions, 0 deletions
diff --git a/abs/extra-testing/bluez/run.hid2hci b/abs/extra-testing/bluez/run.hid2hci
new file mode 100644
index 0000000..6ef1f47
--- /dev/null
+++ b/abs/extra-testing/bluez/run.hid2hci
@@ -0,0 +1,15 @@
+#!/bin/sh
+#
+# Start/stop the Bluetooth daemons
+#
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+[ -f /etc/conf.d/bluetooth ] && . /etc/conf.d/bluetooth
+
+svwaitup 3 /var/service/bluetoothd || exit 1
+
+ stat_runit "Starting Bluetooth HID to HCI mode switching utility"
+ /usr/bin/hid2hci --tohci > /dev/null 2>&1 || true
+ /sbin/sv down .