summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/bluez/run.rfcomm
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-04-02 17:43:16 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-04-02 17:43:16 (GMT)
commit6ee95c24a4ffc57f8397f2cd15d3fa7474631510 (patch)
treeb268dd4bd38f6764899d8877cae757cd68771709 /abs/extra-testing/bluez/run.rfcomm
parentd41c2fc032d8767c388d56aa325d023ad2713cb3 (diff)
parent42d091df6c811163378e16e6de0f83ea4afb660b (diff)
downloadlinhes_pkgbuild-6ee95c24a4ffc57f8397f2cd15d3fa7474631510.zip
linhes_pkgbuild-6ee95c24a4ffc57f8397f2cd15d3fa7474631510.tar.gz
linhes_pkgbuild-6ee95c24a4ffc57f8397f2cd15d3fa7474631510.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/bluez/run.rfcomm')
-rw-r--r--abs/extra-testing/bluez/run.rfcomm17
1 files changed, 17 insertions, 0 deletions
diff --git a/abs/extra-testing/bluez/run.rfcomm b/abs/extra-testing/bluez/run.rfcomm
new file mode 100644
index 0000000..72b3e0f
--- /dev/null
+++ b/abs/extra-testing/bluez/run.rfcomm
@@ -0,0 +1,17 @@
+#!/bin/sh
+#
+# Start/stop the Bluetooth daemons
+#
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+[ -f /etc/conf.d/bluetooth ] && . /etc/conf.d/bluetooth
+
+RFCOMM_CONFIG="/etc/bluetooth/rfcomm.conf"
+
+svwaitup 3 /var/service/bluetoothd || exit 1
+
+ stat_runit "Starting RFCOMM for the bluetooth subsystem"
+ /usr/bin/rfcomm -f $RFCOMM_CONFIG bind all
+ /sbin/sv down .