summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/bluez/run.rfcomm
diff options
context:
space:
mode:
authorGreg Frost <gregfrost1@bigpond.com>2010-04-18 05:55:06 (GMT)
committerGreg Frost <gregfrost1@bigpond.com>2010-04-18 05:55:06 (GMT)
commitd4589eee8998a168eaa79af7a04d82faac1a738d (patch)
tree731625204f3902bb9b5f7a8a492c6b8fcc09c915 /abs/extra-testing/bluez/run.rfcomm
parent5106977528d3d26919263bf62d504035a7720633 (diff)
parent787f13cd63c75c9c5090c10c0e888f48a59c0e49 (diff)
downloadlinhes_pkgbuild-d4589eee8998a168eaa79af7a04d82faac1a738d.zip
linhes_pkgbuild-d4589eee8998a168eaa79af7a04d82faac1a738d.tar.gz
linhes_pkgbuild-d4589eee8998a168eaa79af7a04d82faac1a738d.tar.bz2
Merge branch 'master' of ssh://gregfrost@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/bluez/run.rfcomm')
-rw-r--r--abs/extra-testing/bluez/run.rfcomm17
1 files changed, 17 insertions, 0 deletions
diff --git a/abs/extra-testing/bluez/run.rfcomm b/abs/extra-testing/bluez/run.rfcomm
new file mode 100644
index 0000000..8bc619b
--- /dev/null
+++ b/abs/extra-testing/bluez/run.rfcomm
@@ -0,0 +1,17 @@
+#!/bin/sh
+#
+# Start/stop the Bluetooth daemons
+#
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+[ -f /etc/conf.d/bluetooth ] && . /etc/conf.d/bluetooth
+
+RFCOMM_CONFIG="/etc/bluetooth/rfcomm.conf"
+
+svwaitup -s 3 /var/service/bluetoothd || exit 1
+
+ stat_runit "Starting RFCOMM for the bluetooth subsystem"
+ /usr/bin/rfcomm -f $RFCOMM_CONFIG bind all
+ /sbin/sv down .