summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/ccache/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verison.net>2010-03-22 19:37:16 (GMT)
committerMichael Hanson <hansonorders@verison.net>2010-03-22 19:37:16 (GMT)
commit21383e4ca51bc151601a51e6d75885959deb89e1 (patch)
treef9c1e3739098b700c0e0421c069ae926cc1b8cc2 /abs/extra-testing/ccache/PKGBUILD
parentdbff62a9a2550bd0bed77860fa4164d74c90dfb3 (diff)
parente51cf415764a2c267f373965c48eec082ad59d81 (diff)
downloadlinhes_pkgbuild-21383e4ca51bc151601a51e6d75885959deb89e1.zip
linhes_pkgbuild-21383e4ca51bc151601a51e6d75885959deb89e1.tar.gz
linhes_pkgbuild-21383e4ca51bc151601a51e6d75885959deb89e1.tar.bz2
Merge branch 'master' of mihanson@knoppmyth.net:LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/ccache/PKGBUILD')
-rw-r--r--abs/extra-testing/ccache/PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/abs/extra-testing/ccache/PKGBUILD b/abs/extra-testing/ccache/PKGBUILD
new file mode 100644
index 0000000..14c3be9
--- /dev/null
+++ b/abs/extra-testing/ccache/PKGBUILD
@@ -0,0 +1,35 @@
+# $Id: PKGBUILD 33524 2009-04-04 13:56:15Z giovanni $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=ccache
+pkgver=2.4
+pkgrel=5
+pkgdesc="ccache is a compiler cache"
+url="http://ccache.samba.org/"
+source=(http://samba.org/ftp/${pkgname}/$pkgname-$pkgver.tar.gz)
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('glibc')
+md5sums=('73c1ed1e767c1752dd0f548ec1e66ce7')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make || return 1
+ install -Dm 755 ccache ${pkgdir}/usr/bin/ccache
+ install -Dm 644 ccache.1 ${pkgdir}/usr/share/man/man1/ccache.1
+
+ mkdir -p ${pkgdir}/usr/lib/ccache/bin
+ ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/cc
+ ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/gcc
+ ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/g++
+ ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/cpp
+ ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/c++
+ ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/${CHOST}-cc
+ ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/${CHOST}-gcc
+ ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/${CHOST}-g++
+ ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/${CHOST}-cpp
+ ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/${CHOST}-c++
+}
+