summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/community/foldingathome/run
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-08-30 14:52:42 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-08-30 14:52:42 (GMT)
commit39f7114420e01a1ee8cae488164ff2ab3504350a (patch)
tree7390c2303fe547544fa1ac45d8dfda2086b49ee3 /abs/extra-testing/community/foldingathome/run
parent7c38541dbbbead64f04641065ab038ed545190bd (diff)
parent3aef682afa6426e44abaceb56e510af8dcf7bd94 (diff)
downloadlinhes_pkgbuild-39f7114420e01a1ee8cae488164ff2ab3504350a.zip
linhes_pkgbuild-39f7114420e01a1ee8cae488164ff2ab3504350a.tar.gz
linhes_pkgbuild-39f7114420e01a1ee8cae488164ff2ab3504350a.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
* 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD: rrdtool: add ruby dep to resolve RRD.so dependency python-netifaces: chmod -x on info files xulrunner: add libs to ld.so.conf in install script perl-text-kakasi: fix kakasi dependency pyorbit: rebuild to fix libpython2.5.so.1.0 => not found xine-lib: upgrade to 1.1.16.3 and rebuild to fix missing shared lib references local-website:updated link for f@h. Folding@Home:Updates for webpage. foldingathome:bump. gd:bump for libjpeg foldingathome: change location to /myth/foldingathome/ shepherd: update to latest from http://www.whuffy.com/shepherd/shepherd foldingathome: git add run script LinHES-config mythinstall foldingathome: initial inclusion of Folding@home
Diffstat (limited to 'abs/extra-testing/community/foldingathome/run')
-rw-r--r--abs/extra-testing/community/foldingathome/run26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/extra-testing/community/foldingathome/run b/abs/extra-testing/community/foldingathome/run
new file mode 100644
index 0000000..ede51f2
--- /dev/null
+++ b/abs/extra-testing/community/foldingathome/run
@@ -0,0 +1,26 @@
+#!/bin/sh
+export TERM=linux
+. /etc/rc.conf
+. /etc/rc.d/functions
+stat_runit "Starting folding@home"
+
+FOLDING_DIR=/myth/foldingathome/$(hostname)
+
+if [ -d $FOLDING_DIR ] ; then
+ cd $FOLDING_DIR
+ # Ensure that the client configuration file has the same details as /etc/systemconfig
+
+ source /etc/systemconfig
+
+ if [ -n "$foldingusername" ] ; then
+ sed -i 's/username=.*$/username='$foldingusername'/g' $FOLDING_DIR/client.cfg
+ fi
+
+ if [ -n "$foldingworksize" ] ; then
+ sed -i 's/bigpackets=.*$/bigpackets='$foldingworksize'/g' $FOLDING_DIR/client.cfg
+ fi
+
+ # No need to direct output to a log file becase a log file
+ # will automatically be placed in $FOLDING_DIR
+ exec /usr/bin/fah6 -verbosity 9 &> /dev/null < /dev/null
+fi