summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/community/mediatomb/mediatomb-gcc-4.3.patch
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verison.net>2010-03-22 19:37:16 (GMT)
committerMichael Hanson <hansonorders@verison.net>2010-03-22 19:37:16 (GMT)
commit21383e4ca51bc151601a51e6d75885959deb89e1 (patch)
treef9c1e3739098b700c0e0421c069ae926cc1b8cc2 /abs/extra-testing/community/mediatomb/mediatomb-gcc-4.3.patch
parentdbff62a9a2550bd0bed77860fa4164d74c90dfb3 (diff)
parente51cf415764a2c267f373965c48eec082ad59d81 (diff)
downloadlinhes_pkgbuild-21383e4ca51bc151601a51e6d75885959deb89e1.zip
linhes_pkgbuild-21383e4ca51bc151601a51e6d75885959deb89e1.tar.gz
linhes_pkgbuild-21383e4ca51bc151601a51e6d75885959deb89e1.tar.bz2
Merge branch 'master' of mihanson@knoppmyth.net:LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/community/mediatomb/mediatomb-gcc-4.3.patch')
-rw-r--r--abs/extra-testing/community/mediatomb/mediatomb-gcc-4.3.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/abs/extra-testing/community/mediatomb/mediatomb-gcc-4.3.patch b/abs/extra-testing/community/mediatomb/mediatomb-gcc-4.3.patch
new file mode 100644
index 0000000..9440bec
--- /dev/null
+++ b/abs/extra-testing/community/mediatomb/mediatomb-gcc-4.3.patch
@@ -0,0 +1,24 @@
+# GCC-4.3 compatibility patch by Mika Hynnä (ighea) <igheaxATgmailDOTcom>
+#
+--- mediatomb-0.11.0/src/url.cc 2008-03-02 00:48:36.000000000 +0200
++++ mediatomb-0.11.0.new/src/url.cc 2008-04-14 00:53:21.000000000 +0300
+@@ -75,7 +75,7 @@
+
+ if (only_header)
+ {
+- curl_easy_setopt(curl_handle, CURLOPT_NOBODY);
++ curl_easy_setopt(curl_handle, CURLOPT_NOBODY,0);
+ curl_easy_setopt(curl_handle, CURLOPT_HEADERFUNCTION, URL::dl);
+ curl_easy_setopt(curl_handle, CURLOPT_HEADERDATA,
+ (void *)buffer.getPtr());
+--- mediatomb-0.11.0/src/metadata/id3_handler.cc 2008-03-02 00:48:36.000000000 +0200
++++ mediatomb-0.11.0.new/src/metadata/id3_handler.cc 2008-04-14 01:22:36.000000000 +0300
+@@ -36,6 +36,8 @@
+
+ #ifdef HAVE_ID3
+
++#include <string.h>
++
+ #ifdef HAVE_CONFIG_H
+ #undef HAVE_CONFIG_H // else utils.h from the id3 library tries to import "config.h"
+