summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/community/mythtv-vdpau/mythtv.install
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-04-06 02:30:41 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-04-06 02:30:41 (GMT)
commit6a486a28262c43e8ae2c1a742b4ffd4b29eaf0d0 (patch)
tree73be24d44f57373ccd535852082ca71a9f90b5ae /abs/extra-testing/community/mythtv-vdpau/mythtv.install
parentbabd45727da96c550e8015aacf7c158d15a246dd (diff)
parentf2a8d326cbb1017a27ad5dc12f73704e85b8be99 (diff)
downloadlinhes_pkgbuild-6a486a28262c43e8ae2c1a742b4ffd4b29eaf0d0.zip
linhes_pkgbuild-6a486a28262c43e8ae2c1a742b4ffd4b29eaf0d0.tar.gz
linhes_pkgbuild-6a486a28262c43e8ae2c1a742b4ffd4b29eaf0d0.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/community/mythtv-vdpau/mythtv.install')
-rw-r--r--abs/extra-testing/community/mythtv-vdpau/mythtv.install38
1 files changed, 31 insertions, 7 deletions
diff --git a/abs/extra-testing/community/mythtv-vdpau/mythtv.install b/abs/extra-testing/community/mythtv-vdpau/mythtv.install
index 5f911e4..3bd6b56 100644
--- a/abs/extra-testing/community/mythtv-vdpau/mythtv.install
+++ b/abs/extra-testing/community/mythtv-vdpau/mythtv.install
@@ -1,19 +1,43 @@
# arg 1: the new package version
post_install() {
- echo
echo
- echo "As is with no guarantee, please do not file any bug reports against this package."
-}
+ echo
+ echo "As is with no guarantee, please don't file any bu reports against this package."
+ if [ ! -d /var/log/mythtv ]
+ then
+ mkdir -p /var/log/mythv
+ chown -R mythtv /var/log/mythtv
+ echo "---" > /var/log/mythtv/mythbackend.log
+ chown mythtv /var/log/mythtv/mythbackend.log
-post_upgrade(){
- echo
+ fi
+}
+post_upgrade() {
echo
- echo "As is with no guarantee, please do not file any bug reports against this package."
+ echo
+ echo "As is with no guarantee, please don't file any bu reports against this package."
+}
+pre_upgrade() {
+ cp /usr/share/mythtv/is.xml /tmp
+ cp /usr/share/mythtv/media_settings.xml /tmp
+}
+post_upgrade() {
+ cp /tmp/is.xml /usr/share/mythtv/
+ cp /tmp/media_settings.xml /usr/share/mythtv/
+ if [ ! -d /var/log/mythtv ]
+ then
+ mkdir -p /var/log/mythv
+ chown -R mythtv /var/log/mythtv
+ fi
}
+
+
# arg 1: the old package version
post_remove() {
- echo -e "NOTE: mysql database was not removed. To remove run:\nmysql -u root -e 'drop database mythconverg;'"
+ echo -e "NOTE: MySQL database was not removed. To remove run:\nmysql -u root -e 'drop database mythconverg;'"
+ /bin/true
+
}
op=$1